Memory allocation problem

Discussion in 'Installation/Configuration' started by aceyzeriat, May 8, 2008.

  1. aceyzeriat

    aceyzeriat New Member

    When trying to save one of my sites I get the following message in the zip content :

    <br />
    <b>Fatal error</b>: Allowed memory size of 134217728 bytes exhausted (tried to allocate 197890777 bytes) in <b>/home/admispconfig/ispconfig/web/tools/tools/backup/backup.php</b> on line <b>157</b><br />

    Any suggestion ?
    regards,
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Set the memory limit to a higher value in the file /root/ispconfig/php/php.ini
     
  3. aceyzeriat

    aceyzeriat New Member

    I tried the following (previous value is commented) and restarted apache through ISP_Config

    ;max_execution_time = 300 ; Maximum execution time of each script, in seconds
    max_execution_time = 600 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    ;memory_limit = 128M ; Maximum amount of memory a script may consume (8MB)
    memory_limit = 512M ; Maximum amount of memory a script may consume (8MB)

    same result
    :confused:
     
  4. aceyzeriat

    aceyzeriat New Member

    Precision

    I took the opportunity to update my server to ISP_Config 2.2.23
    The values of the php.ini went back to the old ones.
    I had to put back the memory limit to 512M

    .....
    I tried again but I still have the same error :
    <br />
    <b>Fatal error</b>: Allowed memory size of 134217728 bytes exhausted (tried to allocate 197890868 bytes) in <b>/home/admispconfig/ispconfig/web/tools/tools/backup/backup.php</b> on line <b>157</b><br />

    There must be another parameter hidden somewhere ....
     
    Last edited: May 9, 2008
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you restart ISPConfig after your modifications?
     
  6. aceyzeriat

    aceyzeriat New Member

    Just the web service ... thought that would be enough following a php.ini modification ...
    Anything else should be restarted ?

    regards,
     
    Last edited: May 11, 2008
  7. aceyzeriat

    aceyzeriat New Member

    Closed

    Hello Falko and Till,
    I restarted completely the ISP_Config server and it worked this time, :D
    regards,
     

Share This Page