Memcached with PHP 7.2?

Discussion in 'General' started by fips, May 13, 2019.

  1. fips

    fips New Member

    I am running an ISPConfig3 3.1.13p1 with nginx on debian 9.9. So far everything worked fine :)
    Today I added PHP 7.1 and PHP 7.2 according to that guide (
    Switch to PHP 7.2 worked so I wanted to enable memcached by adding "" at /etc/php/7.2/fpm/php.ini
    But when I check the output of phpinfo memcached is not loaded.
    memcached is running (simple check with telnet 11211 was successfully).

    What can I test/check to get this done?
    Last edited: May 14, 2019
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Which memcached do you have installed? I use the PHP 7.x versions provided by Ondres Sury from his apt-repository, and have installed from there
    apt-cache policy  php-memcached
      Asennettu: 3.1.3+2.2.0-1+0~20190104095850.7+stretch~1.gbpb26597
      Ehdokas:   3.1.3+2.2.0-1+0~20190104095850.7+stretch~1.gbpb26597
     *** 3.1.3+2.2.0-1+0~20190104095850.7+stretch~1.gbpb26597 500
            500 stretch/main amd64 Packages
            100 /var/lib/dpkg/status
         3.0.1+2.2.0-1 500
            500 stretch/main amd64 Package
    That version description says:
    Provides: php5.6-memcached, php7.0-memcached, php7.1-memcached, php7.2-memcached, php7.3-memcached
    The php-memcached package from Debian repository is only
    Provides: php7.0-memcached
  3. fips

    fips New Member

    Well now I forced apt to install the package from sury via:
    apt install php-memcached=3.1.3+2.2.0-1+0~20190104095850.7+stretch~1.gbpb26597
    phpinfo now the parsed memcached.ini but the extension was not loaded...
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I'm not sure it is wise to mix PHP components from several sources. I did not compile myself the PHP-versions. I used this to install additional PHP versions :
    So I could install php-memcached from the same source I got the PHP packages from. This way the work together.
    I don't trust my PHP knowledge so I do not try to compile the packages myself, instead I trust that PHP maintainer to do a good job.
  5. fips

    fips New Member

    Sorry, copied the wrong link in the first post. I used the same tutorial as you did.

    BTW: could you install php7.3?
    I couldn't cause of problems with libpcre2-8-0

    BTW2: can you do me a favour and post output of: /etc/apt/preferences.d/deb-sury-org ??
    Last edited: May 14, 2019
  6. fips

    fips New Member

    Ok, problem solved.
    For some reason the pin-priority from the sury repository was set to 100.
    So no packaged where installed from sury, only from debian.
    Changed it to 500 and now everything workes like a charm.

    till likes this.

Share This Page