memcache doesn't show up in phpinfo()

Discussion in 'Server Operation' started by jautukas87, Sep 4, 2008.

  1. jautukas87

    jautukas87 New Member

    so i've installed memcached, and PECL but memcache doesn't seem to be showing up in phpinfo()

    I've installed everything like shown in here, but can't make php.ini parse, and also not sure where exactly should be?

    I'm using debian distro, my phpinfo()

    I also used these links as guides, they are very simila one to another.
  2. falko

    falko Super Moderator ISPConfig Developer

    You must add
    to /usr/local/lib/php.ini and restart Apache.
  3. jautukas87

    jautukas87 New Member

    The end of my php.ini file, which is located at /usr/local/lib/php.ini

    ; Enables or disables WSDL caching feature.
    ; Sets the directory name where SOAP extension will put cache files.
    ; (time to live) Sets the number of second while cached file will be used
    ; instead of original one.
    ; Local Variables:
    ; tab-width: 4
    ; End:

    To add:

    1. I've reinstalled newer version of libevent-1.4.7-stable -- no errors.
    2. I've also installed memcached-1.2.6 -- no errors.
    3. Ran couple of tests with memcached, which worked -- no errors.

    everything done exactly as at

    4. I've installed memcache-2.2.3 PECL:

    JTP003:/usr/local/src/memcache-2.2.3# make
    /bin/sh /usr/local/src/memcache-2.2.3/libtool --mode=install cp ./ /usr/local/src/memcache-2.2.3/modules
    cp ./.libs/ /usr/local/src/memcache-2.2.3/modules/
    cp ./.libs/memcache.lai /usr/local/src/memcache-2.2.3/modules/
    PATH="$PATH:/sbin" ldconfig -n /usr/local/src/memcache-2.2.3/modules
    Libraries have been installed in:

    JTP003:/usr/local/src/memcache-2.2.3# make install
    Installing shared extensions:     /usr/local/lib/php/extensions/no-debug-non-zts-20060613/
    I also have in php.ini

    So everything should work ok now after restarting apache, but it doesn't.

    Also I cannot find these files:
    I think the problem is that php cannot find

    PS: i've just found this
    JTP003:/usr/local/lib/php/extensions/no-debug-non-zts-20060613# ls
    So now really dont know why it's not working.
    Tried to search but everythere is same things written, i must be missing something really small.

    Please help
    Last edited: Sep 5, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you try the full path in php.ini?
  5. jautukas87

    jautukas87 New Member

    works perfectly, thanks a lot.

Share This Page