mbstring prob with phpMyAdmin

Discussion in 'General' started by hyperclock, Sep 12, 2005.

  1. hyperclock

    hyperclock New Member

    Hi,
    everytime I login to phpMyAdmin the bottom shows:

    Die PHP-Erweiterung "mbstring" wurde nicht gefunden, trotzdem jedoch scheinen Sie einen Mehrbyte-Zeichensatz zu verwenden. Ohne besagte Erweiterung ist phpMyAdmin nicht in der Lage Zeichenketten zu trennen, was zu unerwarteten Ergebnissen führen kann.

    I'm using a dedicated server from STRATO, And did the install as far as I could using HOW TO for SuSE 9.3

    the only thing I couldn't do was the installation. things I did different are:
    1) instead of ::server1.example.com :: i did my strato server name.
    2) added zlib zlib-devel postfix after the apt-get update.
    3) did dist-update
    4) turned SuSe Firewall off
    the rest was done according to the HOW TO.

    everything else works VERY WELL :D
     
  2. till

    till Super Moderator

    Is this error from the ISPConfig phpMyadmin package?
     
  3. hyperclock

    hyperclock New Member

    yes it is I'm using PHPMyAdmin 2.6.3-pl1
     
  4. hyperclock

    hyperclock New Member

    Still having probs with this. Is there some I can change in the config file of phpmyadmin?
     
  5. falko

    falko Super Moderator

    Nothing to worry about, you can ignore the warning. Otherwise install the 2.6.1-RC1 phpMyAdmin package ( http://www.ispconfig.org/downloads/phpmyadmin-2.6.1-rc1.pkg ), it doesn't have this warning.
     
  6. hyperclock

    hyperclock New Member

    Ok, thanx!!! :)

    I really do like ISPConfig.
     
  7. gustavop

    gustavop New Member

    Hi,
    I am new and this it is my first message. :)
    (I do not know much English, it attempt with http://translate.google.com)

    I also have the same problem. :(

    :rolleyes: I believe that the error must to that the PHP5 that installs the ISPConfig does not come compiled with the extension php-mbstring.

    Some suggestion of how adding it? :confused:

    Greetings.
     
  8. till

    till Super Moderator

    To change the compile settings for the PHP, edit the configure line for PHP in the script compile_aps/compile in the install_ispconfig folder before installing ISPConfig.
     
    Last edited: Sep 22, 2005
  9. till

    till Super Moderator

    You're right, i totally forgot that we already changed it to PHP5. :cool:
     
  10. gustavop

    gustavop New Member

    Ok, thanks for its answer.

    If one adjusts so that it uses PHP4, it will use the installation that is installed in our distribution, or will do a new one that listens by port 81?

    I ask this, because in the PHP4 of my distribution (Mke 10,2) yes I have installed php-mbstring.
     
  11. till

    till Super Moderator

    ISPConfig can not use the PHP that is installed on your system for the services on port 81.

    The only solution i see is to change the compile settings as i described above and add an statement like "--enable-mbstring=all". Make shure you have an mbstring devel package installed on your server.
     

Share This Page