maxmum upload limit doesnt take effect even after changes.

Discussion in 'Installation/Configuration' started by mnzava, Apr 6, 2010.

  1. mnzava

    mnzava Member

    Hi,
    I have been trying to change maximum upload limit on php.ini to no avail. Can somebody help me on how i can get rid of this setting issue?
    Here is what i did. I changed settings in the following php.ini files and they are all the same:
    /etc/php5/apache/php.ini
    /etc/php5/cgi/php.ini
    /etc/php5/cli/php.ini

    settings i've added is as follows
    memory_limit = 96M
    post_max_size = 64M
    upload_max_filesize = 64M

    then i added the same limit to .htaccess file but when i refresh the files that i've created to see server setting, still i see upload_max_filesize is 2M.

    Default configuration file according to my ispconfig 3 settings in CGI and is the same i see in phpinfo file. So the proper file is /etc/php5/cgi/php.ini(according to phpinfo)

    Am using ISPConfig 3 on ubuntu 9.04.

    Thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The file sthat you changed are ok. Have you restartet apache?
     
  3. mnzava

    mnzava Member

    Dear Till,
    I did every thing i.e restarting apache and even rebooting the machine but still memory limit does not change.

    Also funny thing is that it shows MEMORY LIMIT = 128 while in my settings i set it to 96M. Is there something wrong with php in ubuntu?

    Regards.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please check your vhost configurations and your .htaccess file. Maybe you have different settings there.
     
  5. mnzava

    mnzava Member

    Thank you very much Till and Falko.

    When falko mentioned vhost file then i decided to check other things apart from just upload limit configuration.

    Then i decided to run this command to see if php package am using is properly compiled with fast cgi. Coz i started to think that may be fast-cgi is not working properly.

    Then i run this command:

    HTML:
    php-cgi -v
    Then i got what i was looking for with addition of the following ERROR msg

    HTML:
    PHP:  Error parsing /etc/php5/cgi/php.ini on line 222
    Since vi doesn't show line numbers by default, i enabled line numbers with the following command. :set nu

    After reaching that line i remembered that i did some security issues on the server before, but i made some errors on disable_functions

    Code:
    disable_functions = [B]disable_functions =[/B] show_source, system, shell_exec, passthru, exec, phpinfo, popen, escapeshellarg, escapeshellcmd, proc_open
    instead of

    Code:
    disable_functions = show_source, system, shell_exec, passthru, exec, phpinfo, popen, escapeshellarg, escapeshellcmd, proc_open
    note on the first part disable_functions repeated twice.

    Hope this will help someone else facing the same problem.

    Thanks.
     

Share This Page