max_allowed_packet for database backups

Discussion in 'General' started by pinkfeet, Dec 14, 2017.

  1. pinkfeet

    pinkfeet Member HowtoForge Supporter

    Hi to all,
    i'm getting this error when ispconfig runs backup plugin:
    Got error: 1153: "Got a packet bigger than 'max_allowed_packet' bytes" when using LOCK TABLES
    As result, the affected databases aren't backuped.

    I think, it can be solved easily by changing the mysqldump parameter in the file server/lib/classes/cron.d/500-backup.inc.php. This is the parameter: --max_allowed_packet=512M
    My question is, what was the criteria to establish 512M for max_allowed_packet ? Perhaps save memory usage ?
    Thanks a lot,
    Regards,
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    If you change the cron-class, this will be overwritten by any ispconfig-update. I would set this in the global mysql-config.
     
  3. pinkfeet

    pinkfeet Member HowtoForge Supporter

    Hi,
    right, thank you Florian, i've changed my my.cnf in order to do this change permanent.
    Regards,
     

Share This Page