Many questons from a confused newb.

Discussion in 'Server Operation' started by jopa123, Feb 9, 2009.

  1. jopa123

    jopa123 New Member

    Again I climb the mountain to gain the wisdom of the elders.

    My situation:

    I am doing this more as a learning experience but all learning has stopped. Purely my fault I guarantee. I just have too many variables that I do not understand and they keep tripping me up.

    I have tried to research these in the forums here but I thought since I have so many, someone could save me years of research and answer them quickly.

    I am semi admin literate, but not to the level of most folks here. I am trying to set up a server where I can just add a site, setup something like Wordpress on it, and have it running within a day or two.

    My setup:

    Ubuntu Hardy Heron - perfect setup (actually used the setup for the previous distro since there was not a Heron walkthrough online at the time.
    ISPConfig
    Wireless connection (bad idea I know, but I don't have a choice) through a Linksys WRT600n - everything is working fine with the connection, all ports are open and everything seems to send/receive the proper info, i.e. I can logon to ISPConfig, I can see most sites I have set up, etc.


    My questions
    1) Do I actually need 2 servers (physical computers) since I need 2 DNS servers at the registrar? With separate IP's? Can I do this through DYDNS or something?
    2) In ISPConfig, when I create a site, is it supposed to put a reference (new master) under DNS Manager? This does not seem consistent on mine. Sometimes it does, sometimes it doesn't.
    3) Where should the sites reside in Linux? I believe I have setup sites that have ended up in /var/www as web1, web2, etc., but then some ended up in the same folder as www.example.com. Which is correct and how do I make it consistent?
    4) When it doe add a new site under the DNS Manager, under records, shouldn't the A record host name be "www"? It seems to default to "mail"
    5) Under ISP Manager, when it asks for ip address, is that internal or external? How about under the DNS Manager?
    6) After adding a site, do I need to reboot ISPConfig? Or possibly an individual service? They do not seem to show up immediately even though the new domain should have propagated through the registrar. Is there a time lag in ISPConfig somehow?
    7) If I need to reboot ISPConfig, how do I do that via SSH? I know how to reboot an individual service (Apache, Proftp, etc)

    I probably have more questions once (and if) someone answers these. Your time and consideration is greatly appreciated.

    Thank you
     
  2. jopa123

    jopa123 New Member

    No takers?

    Let me see if I can distill this down so that it is easier to answer quickly.


    DNS
    1) Do I need 2 servers (physical computers) since I need 2 DNS servers at the registrar?

    2) When I create a site, is it supposed to put a reference (new master or new slave) under DNS Manager?

    3) If so should the site's ip address be internal (192.168.1.x) or external (71.82.33.x) in DNS Manager? Is the same true for the domain that is associated with the dns server(s)?


    Site

    1) Under ISP Manager, should the ip be internal (192.168.1.x) or external (71.82.33.14). Is the same true for the domain that is associated with the dns server(s)?

    2) When I add a new site under the DNS Manager, under records, should the A record hostname be "www"?

    3) After adding a site, do I need to reboot ISPConfig? Or possibly Apache?

    4) If I need to reboot ISPConfig, how do I do that via SSH?


    System
    1) Where should the sites reside in Linux? Under what name?


    I hope this makes it easier to give quick answers.

    Thanks again in advance
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Probably yes. There are only a handful of registrars that let you register one IP address for two nameservers.

    Only if the ISPConfig server is the authoritative nameserver for that domain. If someone else (e.g. your registrar) runs the nameservers, then you don't need the DNS Manager at all.

    USe public IP addresses in the DNS Manager because otherwise people from outside your LAN won't be able to access your sites.


    USe the IP that you see in the output of
    Code:
    ifconfig
    If the server is in your LAN, this should be a private IP.

    You can define all kinds of hostnames there, like www, ftp, mail, etc. You should also define an A record with an empty hostname (for the domain itself).

    No.

    Code:
    /etc/init.d/ispconfig_server restart

    Depends on your distribution. Debian/Ubuntu/Fedora/CentOS/Mandriva: /var/www
    SUSE: /srv/www
     
  4. jopa123

    jopa123 New Member

    Thanks

    Falko,

    You rock as always. Let me digest this and I will probably be back with more. Thanks again for your quick response.
     
  5. jopa123

    jopa123 New Member

    Okay,

    Here's where my problem lies and why I am so confused.

    You (Falko) say
    "If someone else (e.g. your registrar) runs the nameservers".

    I would much rather have my registrar (admitedly, they are a cheap one) run my nameserevers but after a day or so of playing with their interface, I could not find out how to make that happen.

    My options were:

    Parked (park domains there)
    Hosting (Host domains there)
    Custom (Host domains elsewhere)

    Under "Parked", I get their dns servers and no where to enter my ip address. So the sites won't resolve to my server.

    Obviously, "Hosting" makes me host the sites there

    With Custom, I have to enter my dns names (ns1.example.com, etc). Therefore, I have to handle the dns in ISPConfig, correct?

    There is an area where I can add a "Host Summary". In thise area I can enter my ip address. It also asks me for a Host name (________.mydomain.com). But entering info here does no good. After 24 hours to allow for propogation, a traceroute doesn't get past the registrar.

    So I called their tech support. They said that what I was attempting to do was impossible. The dns server MUST reside on the same server as the website.

    Am I confusing DNS server, and name server, and authoritative name server? Was I confusing my terms when I talked to him? Maybe I need a new registrar? Maybe their tech support is full of shite? Maybe I'm a [email protected]?

    In researching the problem, every site I go to simply says "go to your registrar and point the domain at your server)." Am I supposed to point it at my nameserver or the web server, or what?

    How do I do this? Do I simply enter ns1.myexample.com? (my dns server should be setup correctly through the perfect setup). Once I do that, do I then need the once again need the dns manager in ISPConfig. This would mean Falko is mistaken so I don't believe this is correct.

    Can you or someone please give me detailed instructions on how this is accomplished? I am extremely frustrated since I can't even get a site to resolve now unless I use the DNS manager.

    Thanks again in advance.
     
    Last edited: Feb 12, 2009
  6. jopa123

    jopa123 New Member

    Semi-resolution but still confused

    Okay,

    If I use the Custom option from my registrar and use ns1.myserver.com, everything seems to resolve.

    So am I running the DNS and they are basically forwarding? Do I need to use the DNS manager at all? Or does ISPConfig handle this for me?

    Is there some sort of delay after adding the site to ISPConfig? Not the DNS propagation delay, I understand that. But if I buy the domain, enter my nameserver, add the site, wait for it to resolve, then I have to delete the site for some reason, empty the recycle bin, then re-add the site, will it pop up automatically via the web or is there a delay?

    Still confused. But live!
     
  7. falko

    falko Super Moderator ISPConfig Developer

  8. jopa123

    jopa123 New Member

    Think I got it.

    Falko,

    Again, thanks. I think the cloud is beginning to lift. I had read that first tute, but not the second. It was very hepful.

    If I am understanding correctly. I really only need to mess with the DNS Manager when I am setting up the nameservers (ns1.myserver.com), not when setting up a site. Is this correct?

    Thanks again.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's right.
     
  10. jopa123

    jopa123 New Member

    Stil issues

    Falko,

    Here's the issue I have, then. The domain that has the nameserver attached to it (ns1mymainsite.com) will resolve online, no problem.

    Any additional site I add does not resolve.

    The domains are now over a month old so it is not a propagation issue. The dns servers are registered with the registrar as ns1.mymainsite.com and ns2.mymainsite.com.

    A traceroute of the domains reaches my server. It actually shows it reaching the internal ip (192.169.1.x).

    Where do I look to find the problem here? Why are the sites not online?

    Thanks
     
  11. falko

    falko Super Moderator ISPConfig Developer

  12. jopa123

    jopa123 New Member

    Connectivity issues

    Falko,

    I do not have internet currently. Basic outage in my area. I should be back online today and able to give you a response on this.

    Thanks,
     
  13. jopa123

    jopa123 New Member

    intodns.com results

    The site that resolves (and is associated with the ns server) returns these warnings:

    -------------------
    Different subnets -WARNING: Not all of your nameservers are in different
    Different autonomous systems -WARNING: Single point of failure
    -------


    and this other info:


    -----------
    Number of MX records OK. Looks like you only have one MX record at your nameservers. You should be carefull about what you are doing since you have a single point of failure that can lead to mail being lost if the server is down for a long time.

    WWW A Record Your www.mymainsite.com A record is:
    www.mymainsite.com [71.86.91.x]
    -------------------


    Which is odd since that last A record is an old IP address and is listed nowhere in ISPConfig (anymore)

    For the sites that are NOT resolving. I get the same two error messages but the A record entry is this:


    --------
    Your www.mysite1.com A record is:
    www.mysite1.com [71.86.88.x]
    -------

    Which is the correct IP. Isn't that odd? The ones that are NOT resolving show the correct IP.

    Everything else shows a green checkmark.

    Any ideas?
     
  14. falko

    falko Super Moderator ISPConfig Developer

    That sounds as if the ISPConfig nameservers are not authoritative for your domains. Please check in your registrar's web interface again.
     
  15. jopa123

    jopa123 New Member

    Registrar info

    Falko,

    I do not know what "authoritative for your domains" means. According to my regustrar, the Nameservers for each of these domains is :

    ns1.mymainsite.com and
    ns2.mymainsite.com


    There is another area at the registrar that says "Totla DNS: (Not hosted here).

    The main site (the one that resolves) and has the dns servers associated with it, says the ns servers are 71.86.88.83 (for both servers, which is how I have it set up. Not optimal, I know)

    Like I said, these sites are more for testing and learning, so if it is easier, I am happy to give you the actual domain names, ip's, and even a regitrar login if it will help.

    In a PM, of course.
     
  16. jopa123

    jopa123 New Member

    Update

    Okay, this morning the main site and website1 resolve but website2 does not. I have tried to find an discrepancies in the site setup, dns manager, registrar.

    Everything seems to be exactly the same. This is killing me.

    Why did website1 show up today and not yesterday? Is there some delay I am unaware of? Why does website2 not resolve?

    Where do I look for the answer?
     
  17. falko

    falko Super Moderator ISPConfig Developer

    It can take up to 72 hours for DNS changes to propagate.
     
  18. jopa123

    jopa123 New Member

    DNS propogation

    Falko,

    I changed the ip that was showing in the dns manager for site2 and today it resolves.

    I think the DNS propogation may be at the root of all of my confusion. Please set me straight on this.

    Let's say a domain is over a month old and has resolved at one time. Then I make changes in ISPConfig and screw it up. Then I change everything back to where it is supposed to be. Will it still take some time for this to propogate?

    I would have assumed that as long as the registrar is pointing everything at my server, and the initial domain registration and propogation had occured, then changes in ISPConfig would be instantaneous. Is this not the case?
     
  19. falko

    falko Super Moderator ISPConfig Developer

    That depends on your TTL. Other name servers cache your data for TTL seconds (so if your TTL is 86400 seconds, they will cache for a day). And many big ISPs don't care about TTLs, they cache even longer (for example a week).
     
  20. jopa123

    jopa123 New Member

    Excellent

    Falko,

    This may be the info I needed. Knowing that I have to wait to see changes may answer many questions. I'll see if that was my big oversight.

    Thanks again for everything.
     

Share This Page