Manual update doesn't work anymore

Discussion in 'Installation/Configuration' started by zeeman, Jul 7, 2008.

  1. zeeman

    zeeman New Member


    We use ISPconfig (always the current version) and have build something simmilar to DynDNS/DynAlias.

    A scirpt updates the database entry of an host in isp_dns_isp and creates the .run-file.

    This doesn't work any more (can't say when exactly).
    The .run-file is still deleted, but the 'u' remains in the database and the bind-file isn't recreated.

    Our script (shortend):
    mysql -u USER -pPASSWORD db_ispconfig << ENDOFMYSQL
    UPDATE dns_a SET ip_adresse='$1' WHERE doc_id=9 AND doctype_id=1018 AND host='MYHOST';
    UPDATE dns_isp_dns SET status='u' WHERE doc_id=5 AND doctype_id=1016 AND dns_soa='DOMAIN.TLD';
    #Notify ISPconfig
    touch /home/admispconfig/ispconfig/.run
    Do I have to add an 'u' somehere else?
    I guess ISPconfig's behavoir changed after an update, because it worked some time ago...

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The behaviour of ISPConfig has not been changed. I guess that there is a config problem with bind on your server. E.g. when you install a bind update, some linux distributions mess up the bind directory permissions which causes ISPConfig to fail after the bind update.

    Please check that the permissions of the bind config directory are the same then described in the perfect setup guide for your linux distribution and that the path to the bind config files is correct in ispconfig under management > server > settings.
  3. zeeman

    zeeman New Member

    Thanks till!

    Just for the archive: (Problem occurs on two different CentOS 4.5 servers)

    • /var/named/* were screwed up
    • The paths at management > server > settings were wrong. The correct values have to be /var/named/chroot/etc/named.conf and /var/named/chroot/var/named

Share This Page