Mandriva Autoresponder dont work

Discussion in 'Installation/Configuration' started by madmucho, Oct 18, 2007.

  1. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    Today i test one posted problem on mandriva servers .., Autoresponder dont work, everithing seems to be set correctly, my vacation.msg my config, procmail recepie is uncommented for user.

    pice of /var/log/mail/info

    Oct 18 21:28:27 linsrv01 postfix/smtpd[13032]: TLS connection established from unknown[194.108.135.67]: TLSv1 with cipher ADH-CAMELLIA256-SHA (256/256 bits)
    Oct 18 21:28:27 linsrv01 postfix/smtpd[13032]: 3FCE02CC801: client=unknown[194.108.135.67]
    Oct 18 21:28:27 linsrv01 postfix/cleanup[13036]: 3FCE02CC801: message-id=<[email protected]>
    Oct 18 21:28:27 linsrv01 postfix/smtpd[13032]: disconnect from unknown[194.108.135.67]
    Oct 18 21:28:27 linsrv01 postfix/qmgr[9394]: 3FCE02CC801: from=<[email protected]>, size=1918, nrcpt=1 (queue active)
    Oct 18 21:28:37 linsrv01 postfix/local[13037]: 3FCE02CC801: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=9.9, delays=0.1
    6/0/0/9.8, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)

    Thats look normal, mail is send to procmail.

    But isnt correctly proced :) anyone have some idea? Can i set procmail to log somwhere? I normaly dont see what he do.


    Most close topic to this is http://www.howtoforge.com/forums/showthread.php?t=5447

    But i thing my hostname is correctly set


    hostname linsrv01.meteoguru.cz
    hostname -f linsrv01.meteoguru.cz

    postfix

    mydomain = meteoguru.cz
    myhostname = $mydomain
    myorigin = $myhostname

    /etc/hosts
    127.0.0.1 localhost.localdomain localhost meteoguru.cz
    82.100.16.194 linsrv01.meteoguru.cz meteoguru meteoguru.cz

    Please know someone where can be problem? Im little bit confused from this, im trying to solve it some hours...i realy dont know.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    To enable logging in procmail, try to put these lines in the .procmailrc of the user (I guess they might be put at the beginning of the file):

    VERBOSE=on
    LOGFILE=$HOME/procmail.log

    Procmail should now write a procmail.log file in the home directory of the user.
     
  3. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    Debug

    Ok loging for specific user is on..that is i log file

    procmail: Assigning "INCLUDERC=/var/www/web3/user/web3_michalek/.mailsize.rc"
    procmail: Assigning "SHELL=/bin/sh"
    procmail: Executing " wc -c | formail -A"X-Loop: ${LOGNAME}@localhost.localdomain" \
    -I"Subject: Mailsize: ${LOGNAME}" | \
    $SENDMAIL -oi [email protected]ldomain"
    procmail: Assigning "LASTFOLDER= wc -c | formail -A"X-Loop: ${LOGNAME}@localhost.localdomain" \
    -I"Subject: Mailsize: ${LOGNAME}" | \
    $SENDMAIL -oi [email protected]ldomain"
    procmail: Assigning "INCLUDERC=/var/www/web3/user/web3_michalek/.autoresponder.rc"
    procmail: Assigning "SHELL=/bin/sh"
    procmail: Executing "formail,-zxTo:"
    procmail: Assigning "EMAIL=[email protected]"
    procmail: Match on ! "(^(Mailing-List:|Precedence:.*(junk|bulk|list)|To: Multiple recipients of |(((Resent-)?(From|Sender)|X-Envelope-From):|>?
    From )([^>]*[^(.%@a-z0-9])?(Post(ma?(st(e?r)?|n)|office)|(send)?Mail(er)?|daemon|m(mdf|ajordomo)|n?uucp|LIST(SERV|proc)|NETSERV|o(wner|ps)|r(e(
    quest|sponse)|oot)|b(ounce|bs\.smtp)|echo|mirror|s(erv(ices?|er)|mtp(error)?|ystem)|A(dmin(istrator)?|MMGR|utoanswer))(([^).!:a-z0-9][-_a-z0-9]
    *)?[%@> ][^<)]*(\(.*\).*)?)?$([^>]|$)))"
    procmail: Match on ! "^X-Loop: ${EMAIL}"
    procmail: Locking "vacation.lock"
    procmail: Executing "formail,-rD,8192,/var/www/web3/user/web3_michalek/.vacation.cache"
    /bin/sh: line 2: -oi: command not found
    procmail: Assigning "LASTFOLDER=formail -rD 8192 /var/www/web3/user/web3_michalek/.vacation.cache"
    procmail: Unlocking "vacation.lock"
    procmail: Assigning "LASTFOLDER=/var/www/web3/user/web3_michalek/Maildir/new/1192795451.23724_1.linsrv01.meteoguru.cz"
    procmail: Notified comsat: "web3_michalek@0:/var/www/web3/user/web3_michalek/Maildir/new/1192795451.23724_1.linsrv01.meteoguru.cz"
    From [email protected] Fri Oct 19 14:04:11 2007
    Subject: ahoj
    Folder: /var/www/web3/user/web3_michalek/Maildir/new/1192795451.2372 1970

    Any idea? i dont know what script that run and where can be problem inside
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    In the .autoresponder.rc file there is a last line:

    ) | $SENDMAIL -oi -t

    I guess that under mandriva, the $SENDMAIL variable is not filled automatically.

    What is the result of:

    which sendmail
     
  5. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    Result is /usr/sbin/sendmail

    But if i try sendmail command and [Tab] key i see
    sendmail sendmail.postfix
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to add a line:

    SENDMAIL=/usr/sbin/sendmail

    right after the line:

    SHELL=/bin/sh

    in the .autoresponder.rc file and check if the autoresponder is working then.
     
  7. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    Bingo!

    till that work :) i set variable as you say and autoresponder for that user works ok :)
    i try rewrite autoresponder template

    Edit: I see i must rewrite more then one template
    autoresponder.rc.master
    mailsize.rc.master
    trashcan.master
    ...
    Or can be set this varialbe globaly?
     
    Last edited: Oct 20, 2007

Share This Page