Mandriva 2006 / ISPConfig Php compilation error

Discussion in 'Installation/Configuration' started by oreinaud, Jul 18, 2006.

  1. oreinaud

    oreinaud New Member

    php doesn't compil on mandriva 2006 FREE. Any idea?

    /bin/sh /root/install_ispconfig/compile_aps/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc -Iext/date/lib -Iext/date/ -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/date/ -DPHP_ATOM_INC -I/root/install_ispconfig/compile_aps/php-5.1.4/include -I/root/install_ispconfig/compile_aps/php-5.1.4/main -I/root/install_ispconfig/compile_aps/php-5.1.4 -I/root/ispconfig/openssl/include -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/date/lib -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/mbstring/oniguruma -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/mbstring/libmbfl -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/root/install_ispconfig/compile_aps/php-5.1.4/TSRM -I/root/install_ispconfig/compile_aps/php-5.1.4/Zend -I/usr/include -g -O2 -prefer-non-pic -c /root/install_ispconfig/compile_aps/php-5.1.4/ext/date/lib/parse_date.c -o ext/date/lib/parse_date.lo
    /root/install_ispconfig/compile_aps/php-5.1.4/ext/date/lib/parse_date.c: In function 'timelib_strtotime':
    /root/install_ispconfig/compile_aps/php-5.1.4/ext/date/lib/parse_date.c:22598: internal compiler error: Erreur de segmentation
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <URL:https://qa.mandriva.com/> for instructions.
    make: *** [ext/date/lib/parse_date.lo] Erreur 1
    ERROR: Could not make PHP
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You have a segmentation fault there. This can mean it's a problem with your hardware, but it can also be something different. Did you follow this tutorial? http://www.howtoforge.com/perfect_setup_mandriva_2006
     
  3. oreinaud

    oreinaud New Member

    problem solved

    Yes, i follow this tutorial. My rpms database was corrupt and gcc don't work correctly. After reinstall gcc rpm, no problem.

    Thanks Falco.
     
  4. benbalbo

    benbalbo ISPConfig Developer ISPConfig Developer

    I just had the same problem when upgrading from 2.2.5 to 2.2.6 on Debian 3.1:

    Code:
    /bin/sh /root/install_ispconfig/compile_aps/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc -Iext/date/lib -Iext/date/ -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/date/ -DPHP_ATOM_INC -I/root/install_ispconfig/compile_aps/php-5.1.4/include -I/root/install_ispconfig/compile_aps/php-5.1.4/main -I/root/install_ispconfig/compile_aps/php-5.1.4 -I/root/ispconfig/openssl/include -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/date/lib -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/mbstring/oniguruma -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/mbstring/libmbfl -I/root/install_ispconfig/compile_aps/php-5.1.4/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/root/install_ispconfig/compile_aps/php-5.1.4/TSRM -I/root/install_ispconfig/compile_aps/php-5.1.4/Zend    -I/usr/include -g -O2  -prefer-non-pic -c /root/install_ispconfig/compile_aps/php-5.1.4/ext/date/lib/parse_date.c -o ext/date/lib/parse_date.lo
    gcc: Internal error: Terminated (program cc1)
    Please submit a full bug report.
    See <URL:http://gcc.gnu.org/bugs.html> for instructions.
    For Debian GNU/Linux specific bug reporting instructions, see
    <URL:file:///usr/share/doc/gcc-3.4/README.Bugs>.
    
    make: *** [ext/date/lib/parse_date.lo] Error 1
    ERROR: Could not make PHP
    
    ...lots of errors about not being able to stat files because install_ispconfig directory has been removed by installer...
    
    ./setup2: line 816: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    Strange thing is it installed 2.2.5 properly.

    A bit more history. I tried the upgrade a few hours ago and got the abopve error. There was no backup in the /tmp/ directory, so I dumped the database and installed 2.2.5 from scratch again. This failed in a similar fashion with gcc-3.3 but worked with gcc-3.4.

    I then upgraded to 2.2.6 again and it failed.

    Any tips would be greatly appreciated.

    Thanks,
    Ben
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The strange thing is, that the PHP version and compile script has not been changed between 2.2.5 and 2.2.6.

    Do you have currently 2.2.5 installed and running again?
     

Share This Page