Management -> Server Settings -> DNS -> Default MX doesn't work :-(

Discussion in 'General' started by ddelbia, Jan 13, 2006.

  1. ddelbia

    ddelbia Member

    From the manual:

    ---
    If you mark "Default MX" each zone (in this example "domain.tld") created by the DNS-Manager will get an A record of the form

    mail A 192.168.0.100

    as well as an MX record of the form

    MX 10 mail.domain.tld.

    ---

    Ok, I've marked "Default MX" but I get this result:

    Code:
    www  MX      10 my_primary_domain.com.
    
    customer_domain.com.      A        1.2.3.4
    www       A       1.2.3.4
    
    instead of (if I understand well):

    Code:
    MX      10 mailcustomer_domain.com.
    
    mail       A       1.2.3.4
    
    customer_domain.com.      A        1.2.3.4
    www       A       1.2.3.4
    
     
  2. till

    till Super Moderator

    It does work in the DNS manager, but the mail.domain.tld option is only implemented in the DNS manager, not the web manager part.
     
  3. ddelbia

    ddelbia Member

    Excuse me, I don't understand what you mean :(

    I found the code directly in /etc/bind/pri.domain.tld
     
  4. till

    till Super Moderator

    Try to add a primary DNS record in DNS manager and you know what i mean :) The functionality you are talking about is part of the DNS-Manager module.
     
  5. ddelbia

    ddelbia Member

    OK, I understand now :)
    But my problem is still there...
    I think that implement this feature for web manager part will be not simple, then... is there a way to change the template of the web manager part DNS? If yes, I think I'll need a variable containing the customer's domain name too...
     
  6. till

    till Super Moderator

    I think a better way would be to include it in the in the ispconfig_isp_web.lib.php class. But as you already guessed, the programming is not that simple.
     
  7. ddelbia

    ddelbia Member

    Ok, thank you very much :)
     

Share This Page