manageing sql from ispconfig web admin

Discussion in 'General' started by lolbrin, Aug 2, 2021.

  1. lolbrin

    lolbrin New Member HowtoForge Supporter

    Hello,

    I cannot manage sql users or databases from my ispconfig admin frontend. Nothing happening if i do anyhthing.

    I migraited the isp from older server but changed this: /usr/local/ispconfig/server/lib/mysql_clientdb.conf

    Also as Till told me i tried this:
    Code:
    [email protected]:~# mysql -h localhost -u root -p
    Enter password:
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 2823247
    Server version: 10.3.29-MariaDB-0+deb10u1 Debian 10
    Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    MariaDB [(none)]> quit
    Bye
    
    [email protected]:~# mysql -h 127.0.0.1 -u root -p
    Enter password:
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 2823273
    Server version: 10.3.29-MariaDB-0+deb10u1 Debian 10
    Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    MariaDB [(none)]> quit
    Bye
    I can login on both way.
    On error log i see this:
    Unable to connect to the database: Access denied for user 'root'@'localhost' (using password: YES)
    and ofc mysql dumps failing to.

    What should i check?

    Thanks:
    Máté
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The settings are all in /usr/local/ispconfig/server/lib/mysql_clientdb.conf file, double-check what's in there. And in case you have some chars in the password that might cause issues, try another password.
     
    lolbrin and ahrasis like this.
  3. lolbrin

    lolbrin New Member HowtoForge Supporter

    Is there any character lengt maximum? My password is random 20 char alphanumeric
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    MariaDB password maximum length is 80 characters, unless configuration changed by user.
    What can be problem is some characters confuse the password handler. But if you use only numbers and characters a-zA-z that works. I'm sure MariaDB documentation explains which characters are allowed.
     
    lolbrin and ahrasis like this.
  5. lolbrin

    lolbrin New Member HowtoForge Supporter

    hello,

    after i run ispconfig update, the problem solved.
    thanks for your help.
    i don't know if i should make an another topics about it, but is there any way to make multiple backups? maybe to another server too?

    Thanks
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The number of backups is configurable within ISPConfig and an option to store backups on remote servers (search for backup mount) too.
     
    lolbrin likes this.
  7. lolbrin

    lolbrin New Member HowtoForge Supporter

    sorry for my poor english, i meant by multiple backups like 1. for local 2. for remote server too
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The easiest way to achieve that would be to store backups locally and then create a small cronjob that calls a bash script that syncs this folder with a remote backup system e.g. using rsync once a day. So if you would ever lose your local backups in /var/backup, then you can just copy them back from your remote backup system.
     
    lolbrin likes this.
  9. lolbrin

    lolbrin New Member HowtoForge Supporter

    Thanks!
     

Share This Page