Mambo, ISPConfig, suPHP, MySQL

Discussion in 'Installation/Configuration' started by toolswizard, Aug 18, 2007.

  1. toolswizard

    toolswizard Member

    I successfully installed Ubuntu 6.06 using the perfect setup here on the site. I also installed Mambo and Dokeos onto a site. When I tried to FTP up some documents I ran into permissions problems and after doing research, decided to load suPHP.

    Dokeos is not accessible I get a blank screen. However, mambo show that "This site is temporarily unavailable" with an error 1 letting me know that Mysql can no longer be connected to. I can connet from phpmyadmin through ispconfig to MySQL.

    I think this will still come down to a permissions problem. Can anyone offer any advice? Remember, this was working before suPHP.
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Please login to your server as root.
    Then goto your web with the command: cd /var/www/webX
    Next give this command: chown -R -v -f webX_admin:webX web/*

    Where webX_admin is the administrator user of that website and webX the websitenumber, both as created within ISPConfig.

    That should work!
     
  3. toolswizard

    toolswizard Member

    I restored back to a backup of just before I start this. Then did the procedure again. I found a few errors in the compiling. So I did an apt get update and tried again, this time more succesfully.

    The procedure went a lot smoother this time, but still didn't work. First I received a 500 internal server error. I figured that it was the owner ship. So I changed the owner as you suggested. Now I am right back to the error page with the 1 as the error.

    Also, I have dokeos on one of the sites. When I try to access it, I get an error page now. In the apache error log file, it says that it is looking to open the .htaccess file. There was never one there, and there is still not. But now I get an access error when trying to access the page. I guess getting an error is better than an empty page and nothing in the log.
     
  4. toolswizard

    toolswizard Member

    BTW, when I did the restore, i was able to connect to the database again, and after the procedure, nada, nothing.
     
  5. toolswizard

    toolswizard Member

    one more thing, when I restart apache, I see suexec being started. There is a message in the log. I thought the process I followed removes this. Could there be a conflict?
     
  6. toolswizard

    toolswizard Member

    I am back up and working. The problem was when following the instructions to load suPHP, the loading of php5-cgi loaded without any mysql support. I had to preform a apt-get install php5-mysql php5-mysqli --reinstall to enable mysql in php. I will probably go back and reinstall all the php5 modules I originally did in the Perfect Setup instructions that I originall followd.

    The dokeos issues was that world or all did not have execute privildges on the main directory. That now also works.
     

Share This Page