make-kpkg comes to work, but finds nothing to do

Discussion in 'Kernel Questions' started by anw, Jan 31, 2009.

  1. anw

    anw New Member

    I am experimenting with different options for the kernel in preparation for ultimately trying to get a root-on-LVM installation working (and wondering what difference various preemption algorithms make), and am having some basic problems. I am using the 2.6.18 source with the P4 processor family and 4 gig memory. Here are the anomalies:

    1. First and foremost, make-kpkg --initrd tells me there's nothing to do and won't build anything. It built the first time after I unpacked the source, and that was it. Spending a lot of google time only has shown me I'm not the only one to have this problem, but I've found no solution. I've tried make clean, make mrproper, and deleteing 'debian' in the source directory, and, in all cases, make-kpkg thinks for a while, spits out some stuff that doesn't *seem* to be relavant, then comes back and says nothing to do. make deb-pkg works, but I have to build the initrd separately and I have no idea what I may be missing by not using make-kpkg (although it does boot and I'm working under a new kernel now).

    2. On boot, I get two messages, and can't find where in "make menuconfig" to fix them: "unknown file system type 'devfs'", and "sbp2 ieee1394 driver forced to serialize I/O". The first seems to be (according to google) because I'm using udev but have devfs compiled into the kernel. I can't find anywhere to get rid of it in the kernel (using "make menuconfig"). For the other message, it is, of course, the firewire, but I can't find any option that seems to "un-serialize" the I/O.

    On question #2, it would be nice if there was an index somewhere that cross-referenced all the options with where they were in menuconfig, a la apropos. Is there such a thing? Although I'm beginning to think both of these may be module issues.

    TIA!
    anw
     
  2. falko

    falko Super Moderator

    How exactly did you try to build the kernel? Did you try this tutorial? http://www.howtoforge.com/kernel_compilation_debian_etch

    I guess you need to build a ramdisk that you use for booting the system.
     
  3. anw

    anw New Member

    Thanks for the help, Falko! It appears I left the target off my make-kpkg command:
    Code:
    [b]make-kpkg --initrd[/b]
    instead, should have been:
    [b]make-kpkg --initrd kernel_image[/b]
    
    As for #2, in the process of continuing to research this, it came to my attention that the 2.6.18 kernel I'm on is several revs behind; so I'm upgrading to the 2.6.26 kernel, then see if I still have these problems.

    Meantime, I got sidetracked on a different task, with a post coming imminently on the problem there!!

    Again, thanks for the help.

    anw
     

Share This Page