make fails on nginx-0.8.49

Discussion in 'Installation/Configuration' started by bluethundr, Oct 3, 2010.

  1. bluethundr

    bluethundr New Member


    I am attempting to compile nginx-0.8.49 with the upstream fair module. The configure script seems to run ok with the following options:

    #./configure --add-module=../upfair

    but when I run make it fails with this error:

    objs/src/os/unix/ngx_process.o: In function `ngx_process_get_status':
    /mnt/store/src/nginx/SOURCES/nginx-0.8.49/src/os/unix/ngx_process.c:490: warning: `sys_errlist' is deprecated; use `strerror' or `strerror_r' instead
    /mnt/store/src/nginx/SOURCES/nginx-0.8.49/src/os/unix/ngx_process.c:490: warning: `sys_nerr' is deprecated; use `strerror' or `strerror_r' instead
    make[1]: Leaving directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'
    I believe the above `sys_nerr' is deprecated; /en/docs/sys_errlist.html is actually normal. This is according to what I've found on the web and according to what I've heard in #nginx on freenode.

    Given this information, what I _really_ think is the problem may be the fact that make install produces this error:

    root@LCENT01:/mnt/store/src/nginx/SOURCES/nginx-0.8.49]#make install
    make -f objs/Makefile install
    make[1]: Entering directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'
    test -d '/usr/local/nginx' || mkdir -p '/usr/local/nginx'
    test -d '/usr/local/nginx/sbin' 		|| mkdir -p '/usr/local/nginx/sbin'
    test ! -f '/usr/local/nginx/sbin/nginx' 		|| mv '/usr/local/nginx/sbin/nginx' 			'/usr/local/nginx/sbin/nginx.old'
    cp objs/nginx '/usr/local/nginx/sbin/nginx'
    test -d '/usr/local/nginx/conf' 		|| mkdir -p '/usr/local/nginx/conf'
    cp conf/koi-win '/usr/local/nginx/conf'
    cp conf/koi-utf '/usr/local/nginx/conf'
    cp conf/win-utf '/usr/local/nginx/conf'
    test -f '/usr/local/nginx/conf/mime.types' 		|| cp conf/mime.types '/usr/local/nginx/conf'
    cp conf/mime.types '/usr/local/nginx/conf/mime.types.default'
    test -f '/usr/local/nginx/conf/fastcgi_params' 		|| cp conf/fastcgi_params '/usr/local/nginx/conf'
    cp conf/fastcgi_params 		'/usr/local/nginx/conf/fastcgi_params.default'
    test -f '/usr/local/nginx/conf/fastcgi.conf' 		|| cp conf/fastcgi.conf '/usr/local/nginx/conf'
    cp conf/fastcgi.conf '/usr/local/nginx/conf/fastcgi.conf.default'
    test -f '/usr/local/nginx/conf/uwsgi_params' 		|| cp conf/uwsgi_params '/usr/local/nginx/conf'
    cp conf/uwsgi_params 		'/usr/local/nginx/conf/uwsgi_params.default'
    test -f '/usr/local/nginx/conf/scgi_params' 		|| cp conf/scgi_params '/usr/local/nginx/conf'
    cp conf/scgi_params 		'/usr/local/nginx/conf/scgi_params.default'
    test -f '/usr/local/nginx/conf/nginx.conf' 		|| cp conf/nginx.conf '/usr/local/nginx/conf/nginx.conf'
    cp conf/nginx.conf '/usr/local/nginx/conf/nginx.conf.default'
    test -d '/usr/local/nginx/logs' 		|| mkdir -p '/usr/local/nginx/logs'
    test -d '/usr/local/nginx/logs' || 		mkdir -p '/usr/local/nginx/logs'
    test -d '/usr/local/nginx/html' 		|| cp -r html '/usr/local/nginx'
    test -d '/usr/local/nginx/logs' || 		mkdir -p '/usr/local/nginx/logs'
    make[1]: Leaving directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'
    And if I try to start nginx this is what I get:

    [root@LCENT01:/home/bluethundr]#service nginx start
    Starting nginx:                                           [FAILED]
    I am on CentOS 55 x86_64

    [root@LCENT01:/home/bluethundr]#uname -a
    Linux LCENT01 2.6.18-194.11.3.el5xen #1 SMP Mon Aug 30 17:42:28 EDT 2010 i686 i686 i386 GNU/Linux
    [root@LCENT01:/home/bluethundr]#cat /etc/redhat-release 
    CentOS release 5.5 (Final)
    I would greatly appreciate any advice and effort that could help me get this going. Thanks in advance!!
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you sure the install failed? I don't see any errors, just warnings...

Share This Page