Main domain throwing 1001 error but not the subdomains when creating a aliasdomain

Discussion in 'Installation/Configuration' started by anlz, Oct 7, 2020.

  1. anlz

    anlz New Member

    Hi, I've digged a lot, to the point of hitting the last page of google searches. So I gave up and had to register this issue here for future generations! hehehe

    I have a production environment with several websites working fine in a up to date debian server. Now I've created a aliasdomain to point to a site within my ISPConfig. So my new-domain com uses a parent website main-domain com and have /especific-path/ to redirect to. When I hit www new-domain com I go the the right place but when I hit new-domain com I'm facing a error 1001 webpage.

    I've tried all redirect types but without any different outcome. It's also important to point out that I'm experiencing this issue with 2 aliasdomain that I created recently.

    The error 1001 page even says that is a cloudflare network related but I have nothing at cloudflare, my DNS is configure in a Brazil's domain registration platform and my server resides on AWS.

    I'm quite new to ISPConfig but manage to troubleshoot all of my issues so far, but this is pretty sketchy. Since DNS don't seem to be the issue since www new-domain com is working.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Where do you see error 1001? Server errors are all 3 digit, so I'd guess it comes from your application or other external source. You don't simply have wrong DNS, pointing to a cloudflare address, do you?
     
  3. anlz

    anlz New Member

    Yes I had! Just figure it out. I trusted the previous A record on my DNS configuration. I changed it after posting this thread and now the new-domain.com is working with and without the www before. My second domain with the same error was pointing to the same A record IP.

    The reason why the www new-domain com was working because de CNAME record is pointing to srv1 main-domain com, where my ISPconfig is.

    All the clues was there, I just couldn't connect the dots. Now everything made sense.
     
    Th0m likes this.

Share This Page