mailuser plugin for roundcubemail (passwd change not allowed)

Discussion in 'Installation/Configuration' started by aclhkaclhk, May 26, 2010.

  1. aclhkaclhk

    aclhkaclhk New Member

    i am using roundcube 0.3.1, ispconfig

    i followed your steps:

    after configuration, i could update autoreply, mail filter and junk but NOT changing passwd.

    the error is "Soap Error: you do not have permission to access this function roundcube"

    i just tried enabling all Mail***functions and client functions in remote users and changing passwd is ok.

    my config:
    $rcmail_config['plugins'] = array("ispconfig3_account", "ispconfig3_autoreply", "ispconfig3_pass", "ispconfig3_spam", "ispconfig3_fetchmail", "ispconfig3_filter")

    remote functions in db

    i suspect that a function is missing via this sql command:
    UPDATE `remote_user` SET `remote_functions` = 'mail_user_get,mail_user_update,mail_alias_get,mail_forward_get,mail_forward_add,mail_forward_update,mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update,mail_fetchmail_get,mail_fetchmail_add,mail_fetchmail_update,mail_fetchmail_delete,mail_user_filter_get,mail_user_filter_add,mail_user_filter_update,mail_user_filter_delete' WHERE `remote_user`.`remote_username` = '<<REMOTE USERNAME>>' LIMIT 1 ;

    pls advise which one.
  2. austingecko

    austingecko New Member

    Did you replace <<REMOTE USERNAME>> in the SQL statement with the actual remote user you set up in the database as per the instructions?

    WHERE `remote_user`.`remote_username` = '[B][COLOR="Blue"]<<REMOTE USERNAME>>[/COLOR][/B]' LIMIT 1 ;
    For example:
    WHERE `remote_user`.`remote_username` = '[B][COLOR="Blue"]rcube_remote_user[/COLOR][/B]' LIMIT 1 ;
  3. aclhkaclhk

    aclhkaclhk New Member

    yes, otherwise all of the functions will be denied. only changing passwd is denied.
  4. geekrohit

    geekrohit New Member

    Same problem.

    Am facing the same problem, of Soap: You dont have permission for this function.

    I tried your method of adding everything in the remote_functions. But, still the same problem. Any solution ?

    I am using ISPConfig

    Please help me with it.
  5. austingecko

    austingecko New Member

    As per the Troubleshooting section at the bottom of the page:

    "Q: I get an error "Soap Error: you do not have permission to access this function roundcube" when using the plugins.
    A: You probably haven't configured the permissions for the remote ISPconfig user yet. Please refer to steps 2 and 3 of the instructions."

    Verify you did steps 2 and 3 correctly. Hope this helps.
  6. geekrohit

    geekrohit New Member


    I tried already with those steps multiple times. Same result, no use.

    Thanks for the reply though. :)
  7. Stoned

    Stoned New Member

    Same problem here, only with change password solution ? :confused:
  8. Horfic

    Horfic Member

    Did you also tick the client functions? Because this are needed!!
  9. Stoned

    Stoned New Member

    Ok, now all work, thanks!! :D
    The problem is that in the guide that i follow (here, that is the guide linked on ispconfig download page) nothing is written about this option to's possible to update the guide ?
  10. Horfic

    Horfic Member

Share This Page