Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.

?

Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    219 vote(s)
    98.6%
  2. No

    3 vote(s)
    1.4%
  1. Horfic

    Horfic Member

    I updated the SVN.

    Already done:
    *) Account
    *) Password
    *) Fetchmail
    *) Filter

    In changing progress:
    *) Autoreply (still looking for a proper jquery widget for date and time!)
    *) Spam (Slider will go away, you will only get more to choose your policy name)

    In development progress:
    *) Forwarding
    *) White/Blacklist

    -------------------------------------------------------------------------

    The above was for Roundcube 0.3.x, but now comes a surprise. A friend of me wyrie, ported all above for Squirrelmail. So from now on you will be also able to have all features in Squirrelmail. A post regarding the Squirrelmail Mail User Interface will coming shortly.

    PS: We are still looking for somebody who would be willing to port it to horde.
     
  2. mats

    mats New Member

    Good job :D

    Only got 1 problem, I can change all settings except for the password.

    I get:
    Soap Error: You do not have the permissions to access this function.

    I did the sql thing in phpmyadmin
     
  3. NeeChee

    NeeChee New Member

    You are amazing! I will soon post the Squirrelmail howto!
     
  4. NeeChee

    NeeChee New Member

  5. Horfic

    Horfic Member

    I actually using now the datetimepicker from here: http://milesich.com/timepicker/

    Just fighting with the localization.

    @mats
    The only thing what I changed in here is the sysuser_id, which we developers aren't suppose to use. So I'm using the function client_get_id which provides me the right client_id which I need.

    So new function client_get_id.

    PS: What I know, you don't have to use phpmyadmin anymore, you can just tick it on under the remote properties. NeeChe, I guess you have to change your howto now a little bit.^^
     
  6. NeeChee

    NeeChee New Member

    Oh wow that picker looks pretty nice :D What's wrong with the localization?

    I'll adapt the howto as soon as I find time!
     
  7. hanaga

    hanaga New Member

    Soap Error: Function 'client_get_id' doesn't exist

    Hello guys,

    In first I would like to congratulate the efforts to develop the mailuser interface.

    I follow the instructions on post #20 of this thread and have no problems during the procedures but, in the Password changing function I get the message "Soap Error: Function 'client_get_id' doesn't exist'".

    [​IMG]

    And so, the perform to changing pass is stoppep.

    I change the Query

    Code:
    UPDATE `remote_user` SET `remote_functions` = 'mail_user_get,mail_user_update,mail_alias_get,mail_forward_get,mail_forward_add,mail_forward_update,mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update,mail_fetchmail_get,mail_fetchmail_add,mail_fetchmail_update,mail_fetchmail_delete,mail_user_filter_get,mail_user_filter_add,mail_user_filter_update,mail_user_filter_delete' WHERE `remote_user`.`remote_username` = '<<REMOTE USERNAME>>' LIMIT 1 ;
    I insert "client_get_id" after "mail_user_filter_delete", but I have no result.

    Somebody already caught this message ??


    Thank's

    Hanaga
     
  8. NeeChee

    NeeChee New Member

    Just check all the boxes of the remote user when creating it in step 2 of that post. Don't execute the query in your database... This howto is soon to be updated! Excuse me for the delay!
     
  9. hanaga

    hanaga New Member

    NeeChee,

    Thanks for your quickly answer.

    I remove the remote user that I was set in: [roundcube root dir]/plugins/ispconfig3_account/config/config.inc.php

    And I create a new remote user without to execute mentioned SQL Query.

    Code:
    UPDATE `remote_user` SET `remote_functions` = 'mail_user_get,mail_user_update,mail_alias_get,mail_forward_get,mail_forward_add,mail_forward_update,mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update,mail_fetchmail_get,mail_fetchmail_add,mail_fetchmail_update,mail_fetchmail_delete,mail_user_filter_get,mail_user_filter_add,mail_user_filter_update,mail_user_filter_delete' WHERE `remote_user`.`remote_username` = '<<REMOTE USERNAME>>' LIMIT 1 ;
    I receive the message: "Soap Error: You do not have permissons to access this function."

    Ans so, when I run SQL query after all checkboxes marked, I get permission, but I receive againg this message: "Soar Error: Function 'client_get_id' doesn't exist".

    I don't know what is happen, I think that something wrong in my conf., although that all procedures had been made with successfully.

    Thank you again.

    Hanaga
     
  10. hanaga

    hanaga New Member

    Just for remember,

    When I run SQL query, functions like as Autoresponder and Mail filter rules, perfectly works, except Password changing.

    Thank's again.
     
  11. hanaga

    hanaga New Member

    NeeChee

    I supress a variable $uid that calling the funciont "client_get_id" in file ispconfig3_pass.php:

    line 82:
    //$uid = $client->client_get_id($session_id, $mail_user[0]['sys_userid']);

    But I don't know how the influence in other parts of the db or the code.

    In the first view of table mail_user, the column 'server_id' is missing. The previous data of this column were 'NULL'.

    Howhever, the password string is changing and my issue was solved.

    Iam taking care because i'm not sure about the effects of this changing of missing variable.


    Hanaga
     
  12. hanaga

    hanaga New Member

    I'm Sorry

    The field that was missing is "autoresponder_text" not "server_id".

    Hanaga
     
  13. centosarus

    centosarus New Member

    All permissions are set according to steps 2 and 3 of the instructions, but yet ...

    I had the same problem as Hanaga for password changing where I was getting the soap error: Soap Error: You do not have the permissions to access this function. When I commented out line 82 in file ispconfig3_pass.php as he did, it worked out for me. Perhaps this is a bug. Please look into it if you can.

    Also, there may be a bug in the Fetchmail function. If you have an entry in the POP/IMAP textarea box and you click on it to edit it, you automatically get redirected to the Mail Filter page with this error: Operation Not Permitted.

    Please advise.

    Thanks.
     
  14. bitbit

    bitbit New Member

    I have the same Problem with Ispconfig 3.1.6 and roundcube 0.3.1.

    I modife /interface/lib/classes/remoting_lib.inc.php with this:
    PHP:
    //* Load the user profile
            
    function loadUserProfile($client_id 0) {
                global 
    $app,$conf;

                
    $client_id intval($client_id);
                
                if(
    $client_id == 0) {
                    
    $this->sys_username         'admin';
                    
    $this->sys_userid            1;
                    
    $this->sys_default_group     1;
                    
    $this->sys_groups            1;
                } else {
                    
    //* load system user - try with sysuser and before with userid (workarrond)
                    
    $user $app->db->queryOneRecord("SELECT * FROM sys_user WHERE sysuser_id = $client_id");
                    if(empty(
    $user["userid"])) {
                            
    $user $app->db->queryOneRecord("SELECT * FROM sys_user WHERE userid = $client_id");        
                            if(empty(
    $user["userid"])) {
                                    
    $this->errorMessage .= "No sysuser with the ID $client_id found.";
                                    return 
    false;
                            }
                    }
                    
    $this->sys_username         $user['username'];
                    
    $this->sys_userid            $user['userid'];
                    
    $this->sys_default_group     $user['default_group'];
                    
    $this->sys_groups             $user['groups'];
                }

            return 
    true;
            }  
    and modife remote user SQL :

    Code:
    UPDATE `remote_user` SET `remote_functions`= 'mail_user_get,mail_user_add,mail_user_update,mail_user_delete,mail_alias_get,mail_alias_add,mail_alias_update,mail_alias_delete,mail_forward_get,mail_forward_add,mail_forward_update,mail_forward_delete,mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update,mail_spamfilter_user_delete,mail_fetchmail_get,mail_fetchmail_add,mail_fetchmail_update,,mail_user_filter_get,mail_user_filter_add,mail_user_filter_update,mail_user_filter_delete,mail_fetchmail_delete,mail_filter_get,mail_filter_add,mail_filter_update,mail_filter_delete\r\n' where remote_username=' USER NAME ';
    
    If i setup remote user from ispconfig, then missing get metods like mail_user_get. And somtimes add ; instead ,
     
  15. Horfic

    Horfic Member

    The mailinterface requires ISPConfig 3.0.2.x due to a change in the remote library.

    So, please upgrade.
     
  16. centosarus

    centosarus New Member

    I am running the latest version of ISPConfig.

    thanks
     
  17. Germanius

    Germanius Member

    Same here. Password change is not working :-(

    I am running the latest version of ispconfig. All the other functions are working, password change is not working.
     
  18. Horfic

    Horfic Member

    I referred to him. I should have next week time to look into that problem. Got a lot of workload :(
     
  19. centosarus

    centosarus New Member

    Germanius,

    If you comment out line 82 in the ispconfig3_pass.php as suggested by Hanaga, the password change will work. My other problem is with Fetchmail. Please see my post above.

    Horfic, thanks for looking into it, as always.

    Regards
     
  20. Germanius

    Germanius Member

    Thx @centosarus :)

    I tried to deactivate a filter rule but I got the same error (no permissions). Deleting is no problem.
     

Share This Page