Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.


Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    220 vote(s)
  2. No

    3 vote(s)
  1. giftsnake

    giftsnake New Member

    the error is in the javascript-file from the autoreply-plugin. (jquery.ui.datetime.min.js)

    Uncaught TypeError: Object function (a,b){return new e.fn.init(a,b,h)} has no method 'widget'.
    Last edited: Jan 18, 2012
  2. moglia

    moglia New Member

    Enable jqueryui and update plugins and Rc to 0.7.

    You need activate jquery plugin before it your screen will be normal.

    Include jqueryui on array plugins var like that:

    $rcmail_config['plugins'] = array("jqueryui",
  3. GrafPorno

    GrafPorno New Member

    jquery should activated:
    $rcmail_config['plugins'] = array("jqueryui","ispconfig3_account","ispconfig3_pass","ispconfig3_forward","ispconfig3_fetchmail","ispconfig3_autoreply");
  4. Horfic

    Horfic Member

    Well as I said I'm not supporting such a low roundcube version anymore. Please try to upgrade. It got faster and better with every newer version.

    But I can say, that my autoreply is using now jqueryui and jquery. It needs at least jquery 1.4.4 and at least jqueryui 1.8.8.

    So thats also a reason for upgrading rc.
  5. moglia

    moglia New Member

    Round Cube Upgrade

    Backup your webmail database (dump) and all files.
    Get roundcube 0.7.1 version.

    unpack all files on fresh instalation dir get your config files from RC and RC plugins for ispconfig from the old dir and put on correct locations. Then you replace de old dir with new fresh files.

    First check if your have duplicated usernames on user table with this SQL. If you do the update without check it will be fail.

    select username, count(user_id) from users group by username having count(user_id) > 1
    If you located duplicated indexes you need delete one user and update some tables to reflect one unique index i do small script for it and can pass if is necessary.

    Looking for update.sql on SQL folder and execute the lines according you using mysql, postgresql or sqlite. (i´m using mysql) your roundcube 0.5.4 you need execute all lines before 140 before "-- Updates from version 0.5.4" comment line. You can do it with phpmyadmin or console.

    All most done don´t forget put config of roundcube and plugin on the right place. Enter on bin/ directory and execute script on console shell.

    DONE :)
  6. cbj4074

    cbj4074 Member

  7. radim_h

    radim_h Member HowtoForge Supporter

    how should be jquery used with debian, in squeeze current versions are:

    ii libjs-jquery 1.4.2-2 JavaScript library for dynamic web applications
    ii libjs-jquery-ui 1.8.dfsg-3 JavaScript UI library for dynamic web applications

    so, both version are lower then you require

    Last edited: Jan 19, 2012
  8. cbj4074

    cbj4074 Member

    Remove the repository packages and install newer ones yourself.

    I have the following packages installed, with which the Autoreply element of the plug-in (as of rev. 122) appears to function just fine:

    ii  libjs-jquery                    1.6.4-1~bpo60+1
    ii  libjs-jquery-ui                 1.8.dfsg-3
    I describe the process of performing a package-based (although, not repository-bound) upgrade in the thread to which I provided a link in my previous post.
  9. radim_h

    radim_h Member HowtoForge Supporter

    one more question please..

    what is that jquery for?
    i was running RoundCube 0.7 without jquery plugin without any problems... also the autoresponder

    edit: But With plugins version 115 this maybe it ?
    Last edited: Jan 19, 2012
  10. Horfic

    Horfic Member

    Roundcube is based on jquery and uses it for everything and the jquerui is in the plugins folder.
  11. neutrino

    neutrino Member


    I just did the following :

    svn co .
    svn: Failed to add directory 'ispconfig3_account': a versioned directory of the same name already exists

    What did I miss ? I just wanted to upgrade my current version (haven't done it for some month now).

  12. Horfic

    Horfic Member

    Well because of our change, people who used svn checkout have to do first

    svn switch --relocate
    and than the svn checkout does work.
  13. neutrino

    neutrino Member

    Thanks for the help, but that didn't made it, the relocate seemed to work but the checkout failed with the same error as above.

    Edit : Problem solved, I did a rm ispconfig* -r in the plugin directory after that I did a svn co and now it's all up to date.

    Edit 2 : I had of course to restore the following file /web/plugins/ispconfig3_account/config/
    Last edited: Jan 29, 2012
  14. neutrino

    neutrino Member

    By the way since the update, the account tab looks a bit screwed up.

    The section part takes 80% from the screen width while the other part takes the rest, this doesn't look like the 3 standard tabs.

    Here is what I mean :


    Done with firefox 9.01 (with Opera it doesn't look the same but it's still screwed up)
    Last edited: Jan 29, 2012
  15. Horfic

    Horfic Member

  16. neutrino

    neutrino Member

    Ah my bad, I didn't follow the latest news, thanks, it works perfectly now :)
  17. beliashou

    beliashou New Member

    Soap error: wrong version

    Roundcube -> Setting -> Account -> Fetchmail

    Ok, mail collector work perfect.

    Check my account, deselect "enable" and press Save - not work and red message "Soap error: Wrong version"

    Try to [Delete] in Available entries - Ok, record removed.

    How can I solve the problem?
  18. Horfic

    Horfic Member

    which ispconfig version, which roundcube version?
  19. beliashou

    beliashou New Member

    ISPConfig Version:
    Roundcube 0.4.2
  20. Horfic

    Horfic Member

    try upgrading both systems

    if the error still exists i will check it after that.

    Also update the plugins to the current version. Currently 123

Share This Page