Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.

?

Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    220 vote(s)
    98.7%
  2. No

    3 vote(s)
    1.3%
  1. radim_h

    radim_h Member HowtoForge Supporter

    Roundcube 0.7

    I have just installed new version Roundcube 0.7 and everything is working OK!
     
  2. cbj4074

    cbj4074 Member

    I finally had a chance to install the Roundcube plug-in. It's fantastic! Thank you to everyone whose hard work has gone into its development.

    I apologize in advance if these questions have already been asked/addressed elsewhere in this thread. At 41 pages and growing, it's becoming difficult to digest.

    1.) The overall page layout when viewing the plug-in's Account tab appears to be missing a header include or similar. Please see attached screenshot.

    2.) I receive the following message when I first hit the Junk section or attempt to save a password change:

    Code:
    Soap Error: You do not have permission to access this function.
    
    Fetchmail, Autoreply, and Mail Filter all function as expected.

    Are the permissions outlined in the installation guide ( http://www.howtoforge.com/forums/showpost.php?p=213239&postcount=20 ) sufficient? Per the guide, the permissions relevant to SPAM/Junk rules appear to be:

    Code:
    mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update
    
    Did I miss something during the installation?

    I'm happy to assist with implementing solutions if these are "real" problems and not simply "operator error".

    Thanks!
     

    Attached Files:

  3. cbj4074

    cbj4074 Member

    I resolved the first issue by modifying /ispconfig3_account/skins/default/templates/account.html, line 22, and changing

    Code:
    <div id="mainscreen">
    
    to

    Code:
    <div id="prefsscreen">
    
    Is this a change that should be committed?
     
  4. cbj4074

    cbj4074 Member

    As to my second issue, I was able to resolve it by applying the correct Remote User permissions.

    I determined that the following checkboxes in the Remote User interface allowed each section of the plug-in to function properly:

    General
    • Mail alias functions

    Password
    • Client functions

    Fetchmail
    • Mail fetchmail functions

    Autoreply
    • Mail user functions

    Mail Filter
    • Mail user filter functions

    Junk
    • Mail user functions
    • Mail spamfilter user functions
    • Mail spamfilter policy functions
    • Mail spamfilter whitelist functions
    • Mail spamfilter blacklist functions

    Obviously, setting the checkboxes via the ISPConfig Remote User interface overwrites the values that were inserted manually during installation. So, either one should set the values during installation using the interface, or the instructions should be updated to include all of the necessary permission flags.

    Perhaps at some point in the past the necessary permission checkboxes had not yet been added to the interface, but at this point, I see no reason to insert the values manually during installation. Using the interface seems to be far less error-prone.

    EDIT: I realized that I was following outdated instructions. Horfic's post at http://www.howtoforge.com/forums/showthread.php?p=235926#post235926 is newer than the one I was using (NeeChee's at http://www.howtoforge.com/forums/showpost.php?p=213239&postcount=20 ). Horfic does mention which permissions need to be enabled for the Remote User, although his list is longer than mine. I don't receive any errors in the Roundcube plug-in with the shorter list of permissions enabled, but it's possible that something isn't working behind-the-scenes.
     
    Last edited: Dec 30, 2011
  5. rkhalil

    rkhalil New Member

    soap error: login_error_regex

    I always get a

    "soap error: login_error_regex"

    when I try to use any of the ispconfig plugis for roundcube. I'm using Ubuntu 10.04, ISPconfig 3.0.4.1, followed the guide http://www.howtoforge.com/forums/showthread.php?p=235926#post235926 from Horfic and tried roundcube 0.3 and 0.4 from Subversion 115 revision. The problem is that have no idea where to look for the logs to solve the problem, nothing in apache logs, nothing in ispconfig logs...:(. Any idea?

    Thanks for your great job.
     
  6. cbj4074

    cbj4074 Member

    One of the core developers would probably know exactly what the issue is, but in their absence, we're left to troubleshoot on our own. :D

    I searched the ISPConfig source-code for that error string and it's found in interface/web/mail/form/mail_user.tform.php (line 90).

    From what I can tell, the error is triggered because the local portion of the email address fails the designated regular expression check, which is as follows:

    Code:
    ^[a-z0-9][\w\.\-_\[email protected]]{1,63}$
    
    The part I don't understand is why this code is even being executed when you're using the Roundcube webmail plug-in. I can't even find any reference to the string "validators" in the Roundcube plug-in source code. Again, one of the developers would know more.

    Out of curiosity, what email address are you using (just the first part)?
     
  7. skuli434

    skuli434 ISPConfig Developer ISPConfig Developer


    thanks for the tip!!!!
     
  8. maumar

    maumar Member HowtoForge Supporter

    i think that is better to take howto updated than to read 41 pages of this thread :D
     
  9. maumar

    maumar Member HowtoForge Supporter

    you should debug

    Code:
    /usr/local/ispconfig/interface/lib/classes/remoting_lib.inc.php
    
    as i did, it was helpful to me
     
  10. maumar

    maumar Member HowtoForge Supporter

    here
    -> ispconfig 3.0.4.1
    -> rc 0.7

    i did it, but still i have the isssue
    did u changed anything else?
     
    Last edited: Jan 1, 2012
  11. rkhalil

    rkhalil New Member

    Thanks guys, as skuli434 says, the latest version of the trunk still needs a change in some files. Now is working. Thanks again :)
     
  12. maumar

    maumar Member HowtoForge Supporter

    does <div id="prefsscreen"> works for you?
    i have still page scrambled, exactly like cbj4074's screenshot
     
  13. cbj4074

    cbj4074 Member

    I did not find this to be the case. I checked-out rev. 115 and did not have to make this change. Line 75 contains the ['login'] key, so you must not have the latest revision, rkhalil.

    You didn't change the Roundcube template from the default, did you? Are you sure that you are modifying the correct file? Be sure to examine the actual HTML source of the page to ensure that the <div> ID is indeed "prefsscreen".

    It's worth noting at this point that the Roundcube skin cannot be changed from the default if the plug-in is to continue to function. I tried duplicating the default skin directory, changing its name, and then using the skin, but the plug-in interface falls apart. This indicates that something within the plug-in is hard-coded to the default skin, which should be addressed.
     
    Last edited: Jan 2, 2012
  14. maumar

    maumar Member HowtoForge Supporter

    here
    rc 0.7
    plugin trunk 115 as u see:

    Code:
    /var/www/roundcubemail-0.7/plugins/.svn # cat all-wcprops 
    K 25
    svn:wc:ra_dav:version-url
    V 40
    /ispconfig3_roundcube/!svn/ver/115/trunk
    END
    
    restoring mainscreen instead of prefsscreen solved the issue
    now it's working well and Account tab is not scrambled
    mah!
     
  15. cbj4074

    cbj4074 Member

    I'm using Roundcube 0.3.1, so perhaps this line was changed between Roundcube 0.3 and 0.7.

    If I understand you correctly, you implemented this change before testing the interface, and then found the interface to be scrambled with this change in-place. Yes? And undoing this change (reverting the ISPConfig plug-in code back to its original state [rev. 115]) fixed the problem?

    If that is all correct, then users will need to check their Roundcube versions before implementing that change.

    Anyway, glad to hear that everything is working! :D
     
  16. cbj4074

    cbj4074 Member

    If I delete a rule from the Mail Filter section of the Account tab, the rule continues to be applied.

    The problem appears to be that while the Mail Filter is deleted, the Custom Rules entry that is created along with the rule is not.

    This behavior may be confirmed within the ISPConfig interface (Email -> Email Mailbox -> [email protected] -> Mail -> Custom Rules).

    At first, I thought that this may have been caused by whittling-down the list of function permissions that are enabled for the Roundcube remote user. More specifically, I had left the following boxes unchecked, as I could not find a need for them to be enabled, despite the fact that they are listed in Horfic's instructions:

    • Mail Domain functions
    • Mail whitelist functions
    • Mail blacklist functions
    • Server functions

    I tried enabling the above permissions, but the Custom Rules are not deleted when the Mail Filter is deleted via the Roundcube interface.

    If the Mail Filter is deleted via the ISPConfig interface, the accompanying Custom Rules entry is deleted, too, so this does indeed appear to be a bug with the Roundcube plug-in.
     
  17. rangerluke

    rangerluke New Member

  18. Horfic

    Horfic Member

    yes we changed servers and due of our new svn addon for ispconfig the domain changed from

    svn.web-wack.at/ispconfig3_roundcube

    to

    svn.web-wack.at/svn/ispconfig3_roundcube

    EDIT
    --------------
    All issues regarding, install, bugs, features, language, etc will be now handled here
    http://bugs.web-wack.at/projects/isp3-roundcube

    PS: People who already got an svn account or are contributing with translation
    should please create an account and write a pm to me so I can give them right
    permissions.

    PPS: I'm sorry for the long absence and the missed translations!
     
    Last edited: Jan 8, 2012
  19. jariasca

    jariasca Member

    Es_ES.inc

    This is an update for spanish, running on 0.7 roundcube

    regards,
    Jorge
     

    Attached Files:

  20. GrafPorno

    GrafPorno New Member

    ispconfig3_autoreply layout/safe button problem

    hey,

    i`m running ispconfig 3.0.4.2 with roundcube 0.5.4 (backports) and using your current122-plugin set.
    all plugins working fine, except the ispconfig3_autoreply.

    the layout is broken and the safe-button ist not working.
    if i disable the autoreply-plugin everthing looks fine.

    is this a bug or what can i do to use this plugin?
     

    Attached Files:

Share This Page