Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.

?

Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    210 vote(s)
    98.6%
  2. No

    3 vote(s)
    1.4%
  1. Horfic

    Horfic Member

    Thats a little bit wrong. The current version which includes all bugfixes is available under http://svn.web-wack.at/ispconfig3_roundcube3/

    I wrote that already some previous posts before.

    PS: Thanks for the nice tut.
     
  2. NeeChee

    NeeChee New Member

    I've modified step 4... Hope this will do better =)

    EDIT: Made some more changes overall... If you could check if they're correct, that would be nice. And maybe you can add my translation to Dutch to the SVN...
     
    Last edited: Dec 11, 2009
  3. Horfic

    Horfic Member

    Everything looks fine except that in the plugin array there shouldn't be a ispconfig3_forward.

    It is planed, but due to lack of time at the moment and that i have to write my own wrap for it, so that the user can have a forward and a mail account at the same time, talking about writing into the custom rule field for the moment until ispconfig solves this little issue.

    PS: I will upload your translations and all other translations which people sent me to the svn server.
     
  4. NeeChee

    NeeChee New Member

    Yes, I know you've planned maing another forwarding plugin, hence I left it there... Roundcube won't activate plugins that aren't in the plugin folder so it's there when the new forwarding plugin comes out =)
     
  5. SpeedyB

    SpeedyB Member HowtoForge Supporter

    Soap error

    Hello,

    I installed ISPConfig 3.0.1.6 on Fedora 10.
    I installed Roundcube webmail.

    I installed the plugins from the svn according to the tutorial from post 20

    When I enter into Roundcube I see the information from ispconfig:
    I see the linked emails and autoresponder info.

    But when I try to save a new password are spam settings or anything else I recieve an error "Soap Error: No client with ID $client_id found."

    See the attached screenshot

    I tried to find the problem in several ways. but wasn't able to.

    Can someone point me in the right direction for solving this?

    Regards,

    Bas Steelooper
     

    Attached Files:

  6. Horfic

    Horfic Member

    The email really exists in that server?

    He can't find the id from the mysql table with the email you provided with the login.

    Try to login with the full email, and not only username.

    otherwise write me a email.
     
  7. SpeedyB

    SpeedyB Member HowtoForge Supporter

    Dear Horfic,

    I entered the full email at login.
    Also the general tab shows the linked emailadresses info.
    Or is this a default IMAP function?

    I'll drop you an email to.

    Regards,

    Bas Steelooper
     
  8. NeeChee

    NeeChee New Member

    This is "easily" done through querying the MySQL-Database using Soap.
     
    Last edited: Dec 26, 2009
  9. SpeedyB

    SpeedyB Member HowtoForge Supporter

    Off course things are easily done several ways. But I was trying to give the developer as much information as possible to help me solve the problem in the app.

    Yesterday chatted with Horfic a while and it seems that I have this problem because of the following:

    I have 3 clients (id's : 1, 2 and 3)
    I have 6 sys users (id's: 0, 1, 2, 3, 4 and 5)

    When I use sys user with ID 5 to create a mailbox the password changing does not work any more. When I change the sys_userid field in the db to 2 it starts working.

    The problem is in the following line
    Code:
    $update = $client->mail_user_update($session_id, $mail_user[0]['sys_userid'], $mail_user[0]['mailuser_id'], $params);
    In this line of code the sys_userid is read from the mailbox properties and passed to the mail_user_update function.

    In the example the following is done:
    Code:
    $client_id = 0;
    $domain__id = $client->mail_user_update($session_id, $client_id,  $mail_user[0]['mailuser_id'], $params);
    
    Here the set a value to the clientid. When I added this in the ispconfig3_pass file the problem was gone.

    The new code is now:
    Code:
    $clientid = 0;
    $update = $client->mail_user_update($session_id, $clientid, $mail_user[0]['mailuser_id'], $params);
    
    And it is working.

    PS. Also added this to the autoresponder and spamfilter files.

    Regards,

    Bas Steelooper
     
    Last edited: Feb 17, 2010
  10. yoplait

    yoplait Member

    Hi there, I tried to install your plugin (and roundcube, for this occasion), But I had some problems.
    I've followed this howto : http://trac.roundcube.net/wiki/Howto_Install_fr
    Here it was quite long (but I'm just too bad :p ). Don't forget to put "CGI" for php in the website category in ISPconfig 3.
    In this same Howto, they tell us to rename some files and that didn't work, so I let the original name. After that, I saw that the rights of my files didn't let me try roundcube, So I put all in 755.
    That was for the installation of roundcube.

    For your plugin, it was quite good.
    I took this one : http://www.howtoforge.com/forums/showpost.php?p=209992&postcount=13
    and followed your explications : http://www.howtoforge.com/forums/showpost.php?p=213239&postcount=20
    ( I didn't succeed in using svn, because it's not installed on my server... Maybe it would be better, but I don't know how it works and in which package it is... but fault is mine)

    The problems I have :
    - I fall on a "soap error : The login failed, username and password was wrong." when I go on "General"
    - "SERVICE CURRENTLY NOT AVAILABLE! Error No. [524]" on the forwarding item (but I think it's normal, isn't it ?
    - the same soap error for "autoreply" and "spam(ind├ęsirables in french...)"

    I hope it could help you, and if the problem is mine, don't hesitate to tell me ! :)

    Thanks for this plugins.

    edit : I tried this http://www.howtoforge.com/forums/showpost.php?p=213206&postcount=19 , but the problem is still there.

    edit 2 : sorry for my english, I'm french ;) .

    edit 3 : if I can translate in french for you. Just tell me where to send the files I've found in "localization" folder. (If you think it can help...)
     
    Last edited: Dec 27, 2009
  11. Horfic

    Horfic Member

    First at all, when you fail to use the svn version, then you shouldn't use the plugins!

    1.) Soap error says it already, you are using a wrong username or password or both!
    2.) There is currently no forwarding plugin, delete it out of the plugin array in the roundcube config file

    PS: I only give support to the svn version + the language packs I didn't include yet.
     
    Last edited: Dec 28, 2009
  12. yoplait

    yoplait Member

    why shouldn't I use the plugin ?
    Maybe I can try with the svn... I will try to find how to use svn and give you news.

    For the soap error : That's all right, I knew it was a user/pass problem ^^ , but I don't know which one (and where!) and I often mistake them... :S .
    I'll try to find myself.
     
  13. Horfic

    Horfic Member

  14. yoplait

    yoplait Member

    I erase the plugins I tested just before.
    I've installed subversion (it was this one ! :p ), but nothing seems to happen.
    No folder is added after this command :
    Code:
    svn up http://svn.web-wack.at/ispconfig3_roundcube3/trunk/
    'http://svn.web-wack.at/ispconfig3_roundcube3/trunk' omis
    nsxxxx:/var/www/test.xxxx.org/web/rc/plugins# ls -l
    total 80
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 additional_message_headers
    drwxr-xr-x 4 web4 client3 4096 oct 31 14:20 archive
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 autologon
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 database_attachments
    drwxr-xr-x 3 web4 client3 4096 oct 31 14:20 debug_logger
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 emoticons
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 example_addressbook
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 filesystem_attachments
    drwxr-xr-x 5 web4 client3 4096 oct 31 14:20 help
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 http_authentication
    drwxr-xr-x 5 web4 client3 4096 oct 31 14:20 managesieve
    drwxr-xr-x 4 web4 client3 4096 oct 31 14:20 markasjunk
    drwxr-xr-x 3 web4 client3 4096 oct 31 14:20 new_user_dialog
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 new_user_identity
    drwxr-xr-x 4 web4 client3 4096 oct 31 14:20 password
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 show_additional_headers
    drwxr-xr-x 2 web4 client3 4096 oct 31 14:20 squirrelmail_usercopy
    drwxr-xr-x 3 web4 client3 4096 oct 31 14:20 subscriptions_option
    drwxr-xr-x 3 web4 client3 4096 oct 31 14:20 userinfo
    drwxr-xr-x 3 web4 client3 4096 oct 31 14:20 vcard_attachments
    nsxxxx:/var/www/test.xxxx.org/web/rc/plugins# 
    
    Am I wrong somewhere ?
    Is there something to do before this command ?

    I'm really on a test server, so there's nohing to worry about ;) .
     
  15. Horfic

    Horfic Member

    You forgot the "." and you probably want to install it, not update it!
    Code:
    svn co http://svn.web-wack.at/ispconfig3_roundcube3/trunk/ .
    Don't forget the "." (period) at the end of the second command, or it could be creating a directory called "/trunk/". Obviously, this is not what we want.
     
    Last edited: Dec 28, 2009
  16. yoplait

    yoplait Member

    Ok, I see now it was my fault, I didn't see the "co" command... (sorry, I never used svn before...)
    Ok, the installation with svn works, and I've done the changes in config.inc.php.dist, but I fall on the same error.
    I tried to rename the config.inc.php.dist to config.inc.php, but It changes nothing (do I really have to let the ".dist" ?)

    Do you think about something wrong ?
     
  17. atjensen11

    atjensen11 New Member

    First of all, I need to apologize to Horrific. I volunteered to be a Beta tester a while back and am just now getting around to installing the plugin. I will give some feedback once it is installed.

    Anyhow, I followed the steps in Post #20. Things were going smooth until I log in to Roundcube. I see the Account tab under the Settings menu. When I click on three of menu options on the left (General, Autoreply, & Junk), the Roundcube error message appears at the top of the window.

    The error message reads "Soap Error: Could not connect to host".

    I eventually resolved the problem by copying the config.inc.php.dist file to config.inc.php. I don't recall seeing that step specified in the steps in Post #20. That copy step is pretty typical when dealing with Roundcube Plugins.

    Additionally, since my test server setup has Roundcube installed as a vhost on the same physical machine as ISPConfig3, I had to use localhost instead of the FQDN in the plugin config file. If I used the FQDN, I still received the Soap Error message.

    Code:
    $rcmail_config['soap_url'] = 'http://localhost:8080/remote/';
    
    Finally, the demo site that Horrific gave me a link for showed a lot more functionality than this plugin currently provides. I remember seeing the ability to interact with the SPAM filter settings more directly such as White/Black lists. Is that functionality planned for this plugin or am I expecting too much?
     
  18. atjensen11

    atjensen11 New Member

    OK, so here is the feedback.

    Generally, I like the start. I do wish there were more options and I anticipate they will be added as time allows.

    First, I really like how the General tab shows the linked email addresses. I have some clients that like to use one email account as a catch all for a bunch of aliases. Sometimes, it gets hard to track them down in ISPConfig3. Having this displayed to the end user in one spot is useful in my opinion.

    The password changer worked great. For an administrator, I really like the ability for users to change their passwords. It takes a lot of pressure off of me to do that and frees me up to do other important things. I would like to see the ability (either in Roundcube or ISPConfig3) for an email to request a password reset should they forget their password. I don't know how the workflow would happen yet, but at least they could initiate the process. Additionally, I am coming from Squirrelmail. The Squirrelmail Change Password plugin could be configured to force users to change their password after a fixed time interval. I liked that option as an administrator.

    Autoreply worked as advertised and mostly as expected. When I enabled the Autoreply and sent a test message from a Hotmail account, I received an automatic response nearly immediately. When I disabled the Autoreply and sent a test message from a Hotmail account, I received an automatic response nearly immediately. I waited a bit and then sent another test message. An automatic response was not received. Is there a ISPConfig3 cron job on an interval that must run before the autoresponse settings take effect? If so, perhaps my first test after disabling was performed too quickly before that cron job had updated the system settings.

    I tested the Junk settings. My test account had the Priority setting at 5. When I changed it to 6 in Roundcube, I saw the email account added to the Spam filter Users list with the priority set to 6. So it would appear it worked. Prior to the change in Roundcube, only the domain was listed in the ISPConfig3 Spam filter Users list. However, I have posted many times here seeking clarification on the Spam filter settings. I don't understand how the Priority setting is applied.

    On my wish list of features, I would like to see users have the ability to white/black list settings for the Spam filter. I haven't thought it through yet, but some advanced users should have the ability to change their Spam filter policy setting. I don't know how you would limit which users would have the capability and which ones wouldn't.
     
  19. Horfic

    Horfic Member

    That is great idea.

    I could include that. Good idea.

    ISPConfig3 is using a Cronjob, it runs every minute. So every changes, password, autoreply, spamfilter, etc. are taking effect after 1 min.

    Black/Whitelist for user isn't supported yet by ISPConfig3 as I know. Although the programs can do it, but then i can't use the remote functions of ISPConfig3 and I couldn't be sure if the plugin works then for every OS(I use Debian 5).

    You really think the users would know what it means? I mean the default policy names are not really the best explanation.

    PS: When you have the https mod for the ISPConfig3 webinterface. Then the remote_url starts with https://....
     
    Last edited: Dec 28, 2009
  20. atjensen11

    atjensen11 New Member

    In ISPConfig3, it appears that entries that are listed in the Spam filter User/Domain listing are compiled in a drop down box for the white/black list users. I'm not an expert, but my hunch is that if each user were listed, then they could have individual access to white/black lists.

    I agree. As I mentioned, I still have a tough time understanding the settings as the administrator.

    Going back to my force password change suggestion. When I used this setting in the past, it was with Squirrelmail on a different email server setup. That email server setup was a Virtual User setup using one of Falko's excellent tutorials on this site. But it was not an ISPConfig setup. There were some additional database fields that the Squirrelmail plugin referenced to determine if and when a user had to change the password. As a result, I anticipate implementing this suggestion may require some work on the ISPConfig side as well as the Roundcube plugin.
     

Share This Page