mailuser access

Discussion in 'Server Operation' started by sirmee2001, Jan 10, 2006.

  1. sirmee2001

    sirmee2001 New Member

    I am having problems accessing mailuser from outside my network. Everything works OK within my LAN. When I connect to www.myweb.com:81/mailuser I see a connection being made to my local (internal) address and then the connection times out. Where should I change the IP address in order to get rid of this problem. Help!
     
  2. till

    till Super Moderator

    Have you forwarded port 81 from your router to your server? is www.myweb.com an officially registered domain that points to your external IP adress?
     
  3. sirmee2001

    sirmee2001 New Member

    Thanks. I think I forwarded port 81. I will check when I get home.
     
  4. sirmee2001

    sirmee2001 New Member

    Port 81 is forwarded. Everything works including webmail. The only problem is access to the mailuser login page where users can change their passwords.
     
  5. sirmee2001

    sirmee2001 New Member

    My registered domain is igorg.hopto.org
     
  6. till

    till Super Moderator

    If the domain igorg.hopto.org points to your external IP of your router and you forwarded port 81 to your internal server IP, you should be able to login. If this does not work, ask your ISP if port 81 is blocked.
     
  7. falko

    falko Super Moderator

    When I try to access http://igorg.hopto.org:81/mailuser the browser tells me that it tries to load something from 192.168.2.114 which cannot work because this is a local IP address from your network.

    I guess you have 192.168.2.114 in /home/admispconfig/ispconfig/lib/config.inc.php. Try to replace it with igorg.hopto.org.
     
  8. sirmee2001

    sirmee2001 New Member

    Thanks for your replies. I don't have that local address (192.168.2.114) anywhere in the file config.inc.php. The only place that I know of where I do have that IP is in "Server settings" where I also have the domain "igorg.hopto.org".
     
  9. sirmee2001

    sirmee2001 New Member

    Port 81 is not blocked because I am able to log in to my email accounts and check mail. The only problem is logging in to mailuser to change user passwords. I would like my users to be able to change their passwords. Besides that I am really happy with the whole set up thanks to all those who helped prepare the "perfect setup - Debian Sarge 3.1.".
     
  10. falko

    falko Super Moderator

    I know that port 81 isn't blocked because I can access the ISPConfg login page.

    Can you post your /home/admispconfig/ispconfig/lib/config.inc.php here? Please make sure to remove your MySQL details when you post it here.
     
  11. sirmee2001

    sirmee2001 New Member

    Here is the file. I hope I did it the right way.
     
  12. falko

    falko Super Moderator

    Looks ok. Do you have 192.168.2.114 somewhere in /root/ispconfig/httpd/conf/httpd.conf? Because http://igorg.hopto.org:81/mailuser/ works, but http://igorg.hopto.org:81/mailuser doesn't.
     
  13. sirmee2001

    sirmee2001 New Member

    It works. :D Thanks a lot. The address was in that file. I changed it and everything is OK now.
     

Share This Page