Mailservers

Discussion in 'ISPConfig 3 Priority Support' started by JosephDesign, Mar 4, 2014.

  1. JosephDesign

    JosephDesign New Member

    Hi!

    Im able to send out email, but when I try to send an email to the emailadres Im sending from I get an Bounce.

    What are the mailservers I should enter in my (hosting, 3rd party) dns?

    Right now they' re like mx2.example.com.

    How works this in ISP Config?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can enter any domain name or subdomain name that points to the ip address of your server.
     
  3. JosephDesign

    JosephDesign New Member

    So, mx.example.nl will work just fine?
    I didn't try anything yet cause I don't want to screw up anything :D
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, as long as mx.example.nl exists in dns and points to the ip address of your server. you can e.g. test it like this:

    ping mx.example.nl

    if the command returns the ip address of your server, then you can use it as mx record target.
     
  5. JosephDesign

    JosephDesign New Member

    Ok. did that, ping is succesfull, but email is not getting deliverd. Now im not getting an bounce either. Where can I check if the email arrives? Cause in squirrel its not
     
  6. JosephDesign

    JosephDesign New Member

    Has this anything to do with it?

    952F7A1A9A 4445 Tue Mar 4 17:20:26 chilionsnoek@gmail.com
    (temporary failure. Command output: lda: Error: user contact@artistagency.nl: Error reading configuration: Invalid settings: postmaster_address setting not given lda: Fatal: Internal error occurred. Refer to server log for more information.)
    contact@artistagency.nl
     
  7. JosephDesign

    JosephDesign New Member

    Fixt some, it works right now, i restarted dovecot after adding a postmaster_address.
    After reboot, emails got deliverd. But email I send now is not there after 2 minutes. Is this normal behavior?
     
  8. JosephDesign

    JosephDesign New Member

    Now the email still isn't there and besides that, I sended more emails then the 2 that were delivered. I took more then 15 minutes now (at least in squirrel) can I check somewhere if the emails are on the server orso?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Check yor mail.log for errors. A local delivery takes just a few seconds. If external servers are involved or when you use greylisting, then it will take longer.
     
  10. JosephDesign

    JosephDesign New Member

    Excuse for the long post... whole log...

     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The log is fine, no errors and emails that reached your server got successfully delivered within 15 seconds, so on your server there is everything ok.
     

Share This Page