mailserver not receiving mails

Discussion in 'HOWTO-Related Questions' started by NovaMoon, Jan 13, 2016.

  1. NovaMoon

    NovaMoon New Member

    after i run chown -R vmail:vmail /var/vmail i tried to send an email again

    Code:
    Jan 13 18:07:41 ts postfix/smtpd[9535]: connect from mail-wm0-f54.google.com[74.125.82.54]
    Jan 13 18:07:41 ts postfix/smtpd[9535]: NOQUEUE: filter: RCPT from mail-wm0-f54.google.com[74.125.82.54]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> p$
    Jan 13 18:07:41 ts postfix/smtpd[9535]: NOQUEUE: filter: RCPT from mail-wm0-f54.google.com[74.125.82.54]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> p$
    Jan 13 18:07:41 ts postfix/smtpd[9535]: 87C21E0C3A: client=mail-wm0-f54.google.com[74.125.82.54]
    Jan 13 18:07:41 ts postfix/cleanup[9543]: 87C21E0C3A: message-id=<[email protected]om>
    Jan 13 18:07:41 ts postfix/qmgr[1556]: 87C21E0C3A: from=<[email protected]>, size=2489, nrcpt=1 (queue active)
    Jan 13 18:07:41 ts postfix/smtpd[9535]: disconnect from mail-wm0-f54.google.com[74.125.82.54]
    Jan 13 18:07:42 ts postfix/smtpd[9548]: connect from localhost[127.0.0.1]
    Jan 13 18:07:42 ts postfix/smtpd[9548]: 46D96E0C42: client=localhost[127.0.0.1]
    Jan 13 18:07:42 ts postfix/cleanup[9543]: 46D96E0C42: message-id=<[email protected]om>
    Jan 13 18:07:42 ts postfix/qmgr[1556]: 46D96E0C42: from=<[email protected]>, size=3009, nrcpt=1 (queue active)
    Jan 13 18:07:42 ts amavis[1868]: (01868-01) Passed CLEAN {RelayedInbound}, [74.125.82.54]:35899 [74.125.82.54] <[email protected]> -> <[email protected]>, Queue-ID: 87C21E0C3A, Message-ID: <CAEai0ad9EYQhipyNGxNYrfJtxB10yS0zbpv5-Os0Gk6+$
    Jan 13 18:07:42 ts postfix/smtp[9544]: 87C21E0C3A: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.84, delays=0.13/0.08/0.01/0.62, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued$
    Jan 13 18:07:42 ts postfix/qmgr[1556]: 87C21E0C3A: removed
    Jan 13 18:07:42 ts dovecot: lda([email protected]): Fatal: setresgid(5000,5000,150(vmail)) failed with euid=150(vmail): Operation not permitted
    Jan 13 18:07:42 ts postfix/pipe[9549]: 46D96E0C42: to=<[email protected]>, relay=dovecot, delay=0.14, delays=0.07/0.01/0/0.07, dsn=4.3.0, status=deferred (temporary failure)
    Jan 13 18:08:04 ts postfix/master[1549]: terminating on signal 15
    Jan 13 18:08:04 ts postfix/master[9730]: daemon started -- version 2.11.3, configuration /etc/postfix
    
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Strange. Please try this:

    usermod -u 5000 vmail
    groupmod -g 5000 vmail
    usermod -g 5000 vmail
     
  3. NovaMoon

    NovaMoon New Member

    that seemed to fix it! i received an email from the outside world

    roundcube cant still send emails. but it also showed the incoming one
     
  4. NovaMoon

    NovaMoon New Member

    sry for this question but how do i safely change the /var/vmail one back after i set it to 777
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, thats good to hear. I guess there was another controlpanel installed on that server that used the user vmail before ispconfig was installed (e.g. postfix admin) or your ISP uses a strange base setup that has a default user with that name.

    Regarding the send problem, try to send an email and then check the mail.log right afterward to see which errors has been logged for that issue, so we can fix that as well.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    chown vmail:vmail /var/vmail
    chmod 750 /var/vmail

    should fix it.
     
  7. NovaMoon

    NovaMoon New Member

    it doesnt log errors. the only thing that changes is the browser link. it adds an # at the end
     

Share This Page