Mails with Attachments not sent

Discussion in 'General' started by m1_davidson, May 28, 2009.

  1. m1_davidson

    m1_davidson New Member

    Hi All,

    My environment is thus:

    Centos 5.2 - 32 bit
    ISPConfig - 2.2.32
    CPU - P4 - 2.8GHz
    Memory - 2.0 GB
    Email Client - Outlook 2003

    I can send emails fine - so long as they have no attachments. I can receive emails with or without attachments fine.

    I have accessed my emails via webmail and tried to send emails with attachments - still same problem, no joys.

    Has anyone experienced this issue before? Can anyone help resolve?

    Thanks in advance
     
  2. tusshar

    tusshar New Member

    Hello,

    Please provide exact error, and please check attachements size of email.
     
  3. m1_davidson

    m1_davidson New Member

    Hi tusshar,

    I have tried sending various attachment sizes: from 200k - 7M. Below is the anomally I see in the maillog:

    May 28 00:02:12 res postfix/smtp[2226]: 9241292877E: to=<ttaller@gmail.com>, relay=mailhost.zen.co.uk[212.23.3.98]:25, delay=113779, delays=113593/0.16/0.37/185, dsn=4.4.2, status=deferred (conversation with mailhost.zen.co.uk[212.23.3.98] timed out while sending message body)
    May 28 00:49:06 res postfix/qmgr[2211]: 29568928784: from=<first.last@mydomain.com>, size=1599287, nrcpt=1 (queue active)
    May 28 00:49:06 res postfix/qmgr[2211]: 97740928783: from=<first.last@mydomain.com>, size=7619236, nrcpt=1 (queue active)
    May 28 00:49:06 res postfix/smtp[3329]: certificate verification failed for mailhost.zen.co.uk: num=19:self signed certificate in certificate chain
    May 28 00:49:06 res postfix/smtp[3330]: certificate verification failed for mailhost.zen.co.uk: num=19:self signed certificate in certificate chain


    Especially the bit in red. It seems as if there is a delay/defer of message transmission - because of certificate verification?
     
  4. Grey

    Grey New Member

    That's just a warning. It depends on Postfix' setup if a mail is being sent while the certificate is not entirely trusted. Your mail log shows the mail gets deferred long before the message with the certificate problem so that may not be your problem after all. Try to send a mail again and search for the response (e.g. deferred like above) and then grep for all lines that have the same mail-ID (e.g. 9241292877E) so we can see the complete process. The problem must happen in the same time frame as the sending process, not that much afterwards me thinks.
    As postfix mentions "timed out while sending message body" it can't have to do with a certificate problem, as then postfix would have stopped the communication before sending any vital data.
     

Share This Page