Mails can't be delivered

Discussion in 'Installation/Configuration' started by --::wizZzard::--, Jan 16, 2006.

  1. falko

    falko Super Moderator ISPConfig Developer

    The end of the log lines are cut off. Can you post the complete lines again?
     
  2. --::wizZzard::--

    --::wizZzard::-- New Member

    oh man these lines are long! i had to download the file to my local computer....so here we go:

    Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 1006B7BFB6: to=<[email protected]_webmin.blue.kundencontroller.de>, orig_to=<root>, relay=none, delay=41770, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)
    Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: B97C67BFD9: to=<[email protected]_webmin.blue.kundencontroller.de>, orig_to=<[email protected]>, relay=none, delay=388541, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

    Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: B88FB7BFC1: to=<[email protected]_webmin.blue.kundencontroller.de>, orig_to=<root>, relay=none, delay=171370, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

    Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 822207BF5B: to=<[email protected]_webmin.blue.kundencontroller.de>, relay=none, delay=168799, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

    Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 8D3A87BFAE: to=<[email protected]_webmin.blue.kundencontroller.de>, relay=none, delay=49391, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

    Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 69F877BFDF: to=<[email protected]_webmin.blue.kundencontroller.de>, orig_to=<[email protected]>, relay=none, delay=305041, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

    so, now they are completely posted
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Somehow your server tries to connect to a private IP address (192.168.0.29).
    What's in /etc/hosts and /etc/postfix/main.cf? Also post the output of
    Code:
    hostname
    and
    Code:
    hostname -f
     
  4. --::wizZzard::--

    --::wizZzard::-- New Member

    cat /etc/hosts (preconfigured from Server Provider, here i have editet nothing)
    127.0.0.1 localhost
    192.168.0.8 INSTALLSERVER
    85.31.186.56 85-31-186-56
    192.168.0.29 debian_webmin.blue.kundencontroller.de debian_webmin
    127.0.0.1 localhost

    cat etc/postfix/main.cf:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    myhostname = debian_webmin.blue.kundencontroller.de
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = debian_webmin.blue.kundencontroller.de, localhost.blue.kundenco
    ntroller.de, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,rejec
    t_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/

    virtual_maps = hash:/etc/postfix/virtusertable

    and:

    85-31-186-56:/# hostname
    85-31-186-56
    85-31-186-56:/# hostname -f
    85-31-186-56
    85-31-186-56:/#



    mydestination = /etc/postfix/local-host-names
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Either change /etc/hosts to

    Code:
    127.0.0.1 localhost.localdomain localhost debian_webmin.blue.kundencontroller.de debian_webmin
    192.168.0.8 INSTALLSERVER
    85.31.186.56 85-31-186-56.blue.kundencontroller.de 85-31-186-56
    or - this is the better solution, I think - change myhostname in /etc/postfix/main.cf from debian_webmin.blue.kundencontroller.de to 85-31-186-56.blue.kundencontroller.de and restart Postfix.
     
  6. --::wizZzard::--

    --::wizZzard::-- New Member

    must i wait some time untill the changes take efect after i restartet postfix ?(postfix reload was the command, wasn't it?)

    2nd: can i alter both? etc/hosts and /etc/postfix/main.cf ?

    what purpose has the line "192.168.0.29 debian_webmin.blue.kundencontroller.de debian_webmin" in etc/hosts ?
     
    Last edited: Jan 24, 2006
  7. falko

    falko Super Moderator ISPConfig Developer

    No, the changes should work immediately.
    The command is
    Code:
    /etc/init.d/postfix restart
    Sure, you can change both.
    It tells your server that debian_webmin.blue.kundencontroller.de has the IP address 192.168.0.29 so it doesn't have to ask a DNS server.
     
  8. --::wizZzard::--

    --::wizZzard::-- New Member

    i thought that, but why want somebody this? i think i don't need that server.

    by the way i changed postfix/main.cf and restartet the postfix service.

    then i had a look at the error logs, and the problem is still there. the mailserver reroutes the message and gets a time out from 192.168.0.29. perhaps i change etc/hosts now too! results tomorrow.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    I think your hoster should provide better Linux images. The /etc/hosts file looks pretty weird...
     
  10. --::wizZzard::--

    --::wizZzard::-- New Member

    so...i changed both.....like you said

    here the last lines of my mail.log

    Jan 25 10:05:05 85-31-186-56 postfix/postfix-script: stopping the Postfix mail system
    Jan 25 10:05:05 85-31-186-56 postfix/master[16451]: terminating on signal 15
    Jan 25 10:05:05 85-31-186-56 postfix/postfix-script: starting the Postfix mail system
    Jan 25 10:05:05 85-31-186-56 postfix/master[24883]: daemon started -- version 2.1.5
    Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: connect from smtp07.web.de[217.72.192.225]
    Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: setting up TLS connection from smtp07.web.de[217.72.192.225]
    Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: TLS connection established from smtp07.web.de[217.72.192.225]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: E7F7C7BFB9: client=smtp07.web.de[217.72.192.225]
    Jan 25 10:05:26 85-31-186-56 postfix/cleanup[24894]: E7F7C7BFB9: message-id=<[email protected]>
    Jan 25 10:05:26 85-31-186-56 postfix/qmgr[24886]: E7F7C7BFB9: from=<[email protected]>, size=7894, nrcpt=1 (queue active)
    Jan 25 10:05:27 85-31-186-56 postfix/smtpd[24891]: disconnect from smtp07.web.de[217.72.192.225]
    Jan 25 10:05:27 85-31-186-56 postfix/smtp[24895]: E7F7C7BFB9: to=<[email protected]_webmin.blue.kundencontroller.de>, , orig_to=<[email protected]>, relay=none, delay=1, status=bounced (mail for debian_webmin.blue.kundencontroller.de loops back to myself)
    Jan 25 10:05:27 85-31-186-56 postfix/cleanup[24894]: 0944F7BFC8: message-id=<[email protected]>
    Jan 25 10:05:27 85-31-186-56 postfix/qmgr[24886]: 0944F7BFC8: from=<>, size=10035, nrcpt=1 (queue active)
    Jan 25 10:05:27 85-31-186-56 postfix/qmgr[24886]: E7F7C7BFB9: removed
    Jan 25 10:05:44 85-31-186-56 postfix/smtp[24895]: 0944F7BFC8: to=<[email protected]>, relay=mx-ha01.web.de[217.72.192.149], delay=17, status=sent (250 OK id=1F1fg5-00053h-00)
    Jan 25 10:05:44 85-31-186-56 postfix/qmgr[24886]: 0944F7BFC8: removed

    in the webmail-->inbox ore no mails, except through the webmail how can i get to my mails? what i have to enter as "pop3 server name" and "smtp server name" both mail.project-bizarre.de ?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add this domain:

    debian_webmin.blue.kundencontroller.de

    at the end of the file /etc/postfix/local-host-names and restart postfix.
     
  12. --::wizZzard::--

    --::wizZzard::-- New Member

    good! it works! now why i get this message when i send an mail with outlook through my mailserver:

    Ihre Nachricht hat einige oder alle Empfänger nicht erreicht.

    Betreff: Test
    Gesendet am: 25.01.2006 09:36

    Folgende Empfänger konnten nicht erreicht werden:

    '[email protected]' am 25.01.2006 09:36
    554 <[email protected]>: Relay access denied
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to check "server needs authentication" in the SMTP settings from outlook.
     

Share This Page