Mails are redirected to wrong address

Discussion in 'Installation/Configuration' started by laqup, Nov 11, 2009.

  1. laqup

    laqup New Member

    Hey everybody,

    I have a big problem with my postfix: All incoming mails are stored in the wrong folder. They all get assigned to the first user I created. Even Mails for diffrent clients with diffrent domains are sent to the first user.
    (the virtualusertable and local-hostnames in etc/postfix look fine)

    Mail-Log:
    Nov 11 22:27:19 www postfix/qmgr[13217]: 00ABA1CB2167: from=<[email protected]>, size=865, nrcpt=1 (queue active)
    Nov 11 22:27:25 www postfix/local[13250]: 00ABA1CB2167: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=6.9, delays=0.14/0/0/6.7, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 11 22:27:25 www postfix/qmgr[13217]: 00ABA1CB2167: removed

    Email was being sent from [email protected] to [email protected] but ist sent to [email protected]. Why?

    Part of master.cf:
    Thanks in advance,

    Best regards,
    Daniel
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Change the myhostname and mydomain settings in postfix to a domain or subdomain that is not used to receive emails.
     
  3. laqup

    laqup New Member

    Okay, now it works. Thank you.

    For people with a similar problem: You can't use any Domain/Subdomain that is assigned to a Website / Client, cause they all get mail aliases automatically by ispconfig.

    I entered a new subdomain in etc/postfix/local-host-names that is not used by any website / client below the following line:

    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    mail.mydomain.net

    And used this domain as hostname. Now it works.
     

Share This Page