Mails are always sent to the server admin mail address. Making me crazy. :-(

Discussion in 'Installation/Configuration' started by Sheridan, Sep 7, 2006.

  1. Sheridan

    Sheridan New Member

    Hi to all here.

    I've now three domains on my server and the for the first domain mail delivery is working very well.
    The problem now is, that every mail sent to another domain on this server will be sent to [email protected] which forwards this to a bunch of users mailboxes. I now tried to enter two other domains, but the result is always the same.

    I'm not sure but the postfix files below seems to look ok:

    [/etc/postfix/local_host_names]
    Code:
    localhost
    web01.digital-solution.cc
    localhost.web01.digital-solution.cc
    localhost.digital-solution.cc
    localhost.localdomain
    www.digital-solution.cc
    www.apert-syndrom.at
    www.matthias-stuben.at
    digital-solution.cc
    apert-syndrom.at
    matthias-stuben.at
    
    [/etc/postfix/virtusertable]
    Code:
    [email protected]    web1_admin
    [email protected]    web1_admin
    @www.digital-solution.cc    web1_admin
    [email protected]    web1_admin
    [email protected]    web1_admin
    @digital-solution.cc    web1_admin
    [email protected]    web1_mschuetz
    [email protected]    web1_mschuetz
    [email protected]    web1_mschuetz
    [email protected]    web1_mschuetz
    [email protected]    web3_admin
    [email protected]    web3_admin
    [email protected]    web3_admin
    [email protected]    web3_admin
    [email protected]    web3_office
    [email protected]    web3_office
    [email protected]    web3_office
    [email protected]    web3_office
    [email protected]    web3_mschuetz
    [email protected]    web3_mschuetz
    [email protected]    web3_mschuetz
    [email protected]    web3_mschuetz
    

    [/etc/postfix/main.cf]
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    append_dot_mydomain = no
    myhostname = web01.digital-solution.cc
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydomain = localhost
    mydestination = /etc/postfix/local-host-names
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    
    I've now checked everything i could imagine to be the problem, but i still don't have any clue what the problem or misconfiguration is.

    I hope that anyone here can bring some light into the darkness. ;-)


    many thanks anyway
    Sheridan
     
    Last edited: Sep 7, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Sheridan

    Sheridan New Member


    Hi Till.
    Thanks for your help.
    I've set the mydomain param in /etc/postfix/main.cf to localhost, but that didn't fix the problem. :(

    Here is the part of the mail.log that show's the way of one of the test mails. Sorry that i've forgot to post it in the first post here, but it was late yesterday. ;-)

    Code:
    Sep  7 15:15:21 web01 postfix/pickup[19964]: C8C9478C2F7: uid=10011 from=<web1_mschuetz>
    Sep  7 15:15:21 web01 postfix/cleanup[19986]: C8C9478C2F7: message-id=<[email protected]>
    Sep  7 15:15:21 web01 postfix/qmgr[19965]: C8C9478C2F7: from=<[email protected]>, size=417, nrcpt=1 (queue active)
    Sep  7 15:15:22 web01 postfix/local[19992]: C8C9478C2F7: to=<[email protected]>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep  7 15:15:22 web01 postfix/qmgr[19965]: C8C9478C2F7: removed
    Sep  7 15:15:27 web01 postfix/local[19990]: 7A9AF78C2F5: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=6, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep  7 15:15:27 web01 postfix/local[19991]: 7A9AF78C2F5: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=6,
    status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep  7 15:15:27 web01 postfix/qmgr[19965]: 7A9AF78C2F5: removed
    
    I don't know why the reciever address is [email protected]ldomain. The rest is clear as this address doesn't exist on my sys he delivers it to the default mail address which is the on that forwards it's mails to some other mailboxes.

    Looks like a typical case of "pebkac". :rolleyes:


    many thanks for any idea
    Sheridan
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. Sheridan

    Sheridan New Member

    Ah. Many thanks for the link Falko. That's the mail for the ispconfig traffic statistic. Very nice idea.

    Any ideas why it forwards all messages sent to other domains then the first and main one to the main mail address of the server admin?

    I absolutely don't have a clue why postfix is doing this.
    By the way, i'm using debian sarge and installed it following the perfect setup guide.

    greets & thanks
    Sheridan
     
  6. Sheridan

    Sheridan New Member

    Here is the complete mail.log block to corresponds to my last try.

    Code:
    Sep  7 21:10:24 web01 postfix/smtpd[14958]: connect from 85-125-151-110.dynamic.xdsl-line.inode.at[85.125.151.110]
    Sep  7 21:10:24 web01 postfix/smtpd[14958]: setting up TLS connection from 85-125-151-110.dynamic.xdsl-line.inode.at[85.125.151.110]
    Sep  7 21:10:24 web01 postfix/smtpd[14958]: TLS connection established from 85-125-151-110.dynamic.xdsl-line.inode.at[85.125.151.110]: TLSv1 with cipher RC4-MD5 (128/128 bits)
    Sep  7 21:10:24 web01 postfix/smtpd[14958]: A45C378C48A: client=85-125-151-110.dynamic.xdsl-line.inode.at[85.125.151.110], sasl_method=PLAIN, sasl_username=web1_mschuetz
    Sep  7 21:10:24 web01 postfix/cleanup[14960]: A45C378C48A: message-id=<[email protected]>
    Sep  7 21:10:25 web01 postfix/qmgr[13042]: A45C378C48A: from=<[email protected]>, size=15759, nrcpt=1 (queue active)
    Sep  7 21:10:25 web01 postfix/cleanup[14960]: 0EFED78C48B: message-id=<[email protected]>
    Sep  7 21:10:25 web01 postfix/qmgr[13042]: 0EFED78C48B: from=<[email protected]>, size=15912, nrcpt=2 (queue active)
    Sep  7 21:10:25 web01 postfix/local[14962]: A45C378C48A: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=1, status=sent (forwarded as 0EFED78C48B)
    Sep  7 21:10:25 web01 postfix/qmgr[13042]: A45C378C48A: removed
    Sep  7 21:10:25 web01 postfix/smtpd[14958]: disconnect from 85-125-151-110.dynamic.xdsl-line.inode.at[85.125.151.110]
    Sep  7 21:10:25 web01 postfix/pickup[13041]: 3BA0678C48D: uid=10011 from=<web1_mschuetz>
    Sep  7 21:10:25 web01 postfix/cleanup[14960]: 3BA0678C48D: message-id=<[email protected]>
    Sep  7 21:10:25 web01 postfix/qmgr[13042]: 3BA0678C48D: from=<[email protected]>, size=418, nrcpt=1 (queue active)
    Sep  7 21:10:25 web01 postfix/pickup[13041]: 3D1FA78C48A: uid=10012 from=<web1_rkainzbauer>
    Sep  7 21:10:25 web01 postfix/cleanup[14960]: 3D1FA78C48A: message-id=<[email protected]>
    Sep  7 21:10:25 web01 postfix/qmgr[13042]: 3D1FA78C48A: from=<[email protected]>, size=430, nrcpt=1 (queue active)
    Sep  7 21:10:25 web01 postfix/local[14962]: 3BA0678C48D: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep  7 21:10:25 web01 postfix/qmgr[13042]: 3BA0678C48D: removed
    Sep  7 21:10:25 web01 postfix/local[15000]: 3D1FA78C48A: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep  7 21:10:25 web01 postfix/qmgr[13042]: 3D1FA78C48A: removed
    Sep  7 21:10:30 web01 postfix/local[14964]: 0EFED78C48B: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=5, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep  7 21:10:31 web01 postfix/local[14963]: 0EFED78C48B: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=6, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep  7 21:10:31 web01 postfix/qmgr[13042]: 0EFED78C48B: removed
    
    What the hell did i messed up again?


    many thanks anyway
    Sheridan
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. falko

    falko Super Moderator ISPConfig Developer

    Use a domain in /etc/postfix/main.cf that you don't use for web sites and email, etc.
     
  9. edge

    edge Active Member Moderator

    falko,

    The problem I have is that for some reason I'm getting spam mail that is send to domains that I'm hosting. (I'm as in root)
    The spam is send to non existing users of the domains that are hosted on my server.

    I have no clue how they do it, as when I send an email (from an email account that is not on the server) to the same addres the spammer did, it get bounced!

    Anyway.. Are you suggesting to use any myhostname? Like a non existing one?

    Now lets say my hostname is:
    Code:
    #hostname
    host.domainname.tld
    
    My /etc/postfix/main.cf the myhostname is set to:
    myhostname = mail.domainname.tld

    When I change this to lets say host.domainname.tld, the mail will never arrive at a hotmail account.

    I think it will be the same if I set it to a non existing domainname.
     
  10. Sheridan

    Sheridan New Member

    Thanks for this hint again, but it didn't fix the problem.
    I'm now using the domain of a friend of mine where only two A records are pointing to my machine for use as dns-server entries.
    Anyway. I've sorted out something else.

    Afte unchecking the "CatchAll" of the [email protected] mail address, postfix still forwards the mail which has been originally sent to [email protected] but to [email protected] now.
    web3_office is the correct user but the digital-solution.cc domain name isn't correct here. The correct target mail address should be [email protected].

    Where the does he get the information that he should forward it to [email protected]?


    Any entries in the virtusertable corresponding to web3 can be found below:
    Code:
    [email protected]    web3_admin
    [email protected]    web3_admin
    [email protected]    web3_admin
    [email protected]    web3_admin
    
    [email protected]    web3_office
    [email protected]    web3_office
    [email protected]    web3_office
    [email protected]    web3_office
    
    [email protected]    web3_mschuetz
    [email protected]    web3_mschuetz
    [email protected]    web3_mschuetz
    [email protected]    web3_mschuetz
    
     
    Last edited: Sep 8, 2006
  11. falko

    falko Super Moderator ISPConfig Developer

    No, it must exist, and the DNS record must point to the server.
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Please post /etc/postfix/main.cf (please strip out the comments), /etc/postfix/local-host-names, and /etc/postfix/virtusertable here, and also an excerpt of your mail log when this happens.
     
  13. Sheridan

    Sheridan New Member

    Ok.

    /etc/postfix/main.cf
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    append_dot_mydomain = no
    myhostname = web01.digital-solution.cc
    mydomain = smartservercontrol.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = /etc/postfix/local-host-names
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    

    /etc/postfix/local-host-names
    Code:
    localhost
    web01.digital-solution.cc
    localhost.web01.digital-solution.cc
    localhost.digital-solution.cc
    localhost.localdomain
    www.digital-solution.cc
    www.apert-syndrom.at
    www.matthias-stuben.at
    digital-solution.cc
    apert-syndrom.at
    matthias-stuben.at
    

    /etc/postfix/virtusertable
    Code:
    [email protected]    web1_admin
    [email protected]    web1_admin
    [email protected]    web1_admin
    [email protected]    web1_admin
    [email protected]    web1_mschuetz
    [email protected]    web1_mschuetz
    [email protected]    web1_mschuetz
    [email protected]    web1_mschuetz
    [email protected]    web1_rkainzbauer
    [email protected]    web1_rkainzbauer
    [email protected]    web1_rkainzbauer
    [email protected]    web1_rkainzbauer
    [email protected]    web1_hlukaseder
    [email protected]    web1_hlukaseder
    [email protected]    web1_hlukaseder
    [email protected]    web1_hlukaseder
    [email protected]    web1_afronc
    [email protected]    web1_afronc
    [email protected]    web1_afronc
    [email protected]    web1_afronc
    [email protected]    web1_support
    [email protected]    web1_support
    [email protected]    web1_support
    [email protected]    web1_support
    [email protected]    web1_mschmid
    [email protected]    web1_mschmid
    [email protected]    web1_mschmid
    [email protected]    web1_mschmid
    [email protected]    web2_admin
    [email protected]    web2_admin
    @www.apert-syndrom.at    web2_admin
    admin@apert-syndrom.at    web2_admin
    web2_admin@apert-syndrom.at    web2_admin
    @apert-syndrom.at    web2_admin
    office@www.digital-solution.cc    web1_office
    web1_office@www.digital-solution.cc    web1_office
    office@digital-solution.cc    web1_office
    web1_office@digital-solution.cc    web1_office
    root@www.digital-solution.cc    web1_root
    web1_root@www.digital-solution.cc    web1_root
    root@digital-solution.cc    web1_root
    web1_root@digital-solution.cc    web1_root
    dgs@www.digital-solution.cc    web1_dgsverteiler
    web1_dgsverteiler@www.digital-solution.cc    web1_dgsverteiler
    dgs@digital-solution.cc    web1_dgsverteiler
    web1_dgsverteiler@digital-solution.cc    web1_dgsverteiler
    admin@www.matthias-stuben.at    web3_admin
    web3_admin@www.matthias-stuben.at    web3_admin
    admin@matthias-stuben.at    web3_admin
    web3_admin@matthias-stuben.at    web3_admin
    office@www.matthias-stuben.at    web3_office
    web3_office@www.matthias-stuben.at    web3_office
    office@matthias-stuben.at    web3_office
    web3_office@matthias-stuben.at    web3_office
    mschuetz@www.matthias-stuben.at    web3_mschuetz
    web3_mschuetz@www.matthias-stuben.at    web3_mschuetz
    mschuetz@matthias-stuben.at    web3_mschuetz
    web3_mschuetz@matthias-stuben.at    web3_mschuetz
    

    It seems that if the mails should be delivered to web3_office (for example) he adds the digital-solution.cc domain name to complete the mail address. Than the catchall function comes into place because there's no web3_office defined for this domain.

    /var/log/mail.log excerpt
    Code:
    Sep 13 01:10:01 web01 postfix/smtpd[29250]: 9BB2078C20D: client=85-125-151-110.dynamic.xdsl-line.inode.at[85.125.151.110], sasl_method=PLAIN, sasl_username=web1_mschuetz
    Sep 13 01:10:01 web01 postfix/cleanup[29253]: 9BB2078C20D: message-id=<1158102601.9640.3.camel@localhost.localdomain>
    Sep 13 01:10:01 web01 postfix/qmgr[26606]: 9BB2078C20D: from=<mschuetz@digital-solution.cc>, size=15761, nrcpt=1 (queue active)
    Sep 13 01:10:02 web01 postfix/pickup[26605]: 0455078C490: uid=10038 from=<web3_office>
    Sep 13 01:10:05 web01 postfix/local[29254]: 9BB2078C20D: to=<web3_office@digital-solution.cc>, orig_to=<office@matthias-stuben.at>, relay=local, delay=4, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 13 01:10:05 web01 postfix/qmgr[26606]: 9BB2078C20D: removed
    
    The funny thing is, that if i disable the catchall function for the admin@digital-solution.cc mail address, he delivers the mail to the right target mailbox.


    Many thanks for your help.


    greets
    Sheridan
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    What is in /etc/mailname ?
     
  15. Sheridan

    Sheridan New Member

    /etc/mailname
    Code:
    digital-solution.cc
    
    This is the setting that causes this. After reading the man page it seems that this has to be a valid domain name hosted on my sys. What setting is normally used here?

    greets
    Sheridan
     
    Last edited: Sep 14, 2006
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Use web01.digital-solution.cc instead of digital-solution.cc in /etc/mailname and restart postfix.
     
  17. Sheridan

    Sheridan New Member

    Many thanks to all for the help. That solved it.
    So as a conclusion, the mailname should be an entry that also exists in the /etc/postfix/local-host-names file and isn't used by an vhost if you want to avoid the effect to get all mails.

    As i said before, a typical case of pebkac. ;-)

    Many thanks once again.

    greets
    Sheridan
     

Share This Page