Mailman - trying to make it work

Discussion in 'General' started by smokinjo, Jan 6, 2018.

  1. jnsc

    jnsc rotaredoM Moderator

    Sorry till you are right, I tough that it was the same problem that i faced some times ago, but it's obviously not.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No problem at all :) Thank you for trying to help with this issue!
     
  3. smokinjo

    smokinjo Member

    Well, I had hope for a little while. That hope was dashed when you all said that the problem is different.
    You mention that mailman i old. They have the updated version 3.x. Might this be better suited?

    That being said, what might be other places to look to find an answer to my problem?

    Thanks

    Joseph
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I did not mean that your mailman version is old, it was just a comment on the way mailman is setup.

    The next thing would be to check if the mailman apache config is active and loaded by apache. Which Linux distribution and OS version do you use?
     
  5. smokinjo

    smokinjo Member

    NAME="Debian GNU/Linux"
    VERSION="7 (wheezy)"

    Thanks

    Joseph
     
  6. smokinjo

    smokinjo Member

    Hello Till(others too:),
    Where will I find the apache mailman config on my server? Then, how to see if it is loaded by apache?
    Thanks

    Joseph
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't have a Debian 7 here at the moment, but in that version the file is most likely in /etc/apache2/conf.d/ as the /etc/apache2/conf-enabled/ folder is only used from Debian 8 if I remember correctly.
     
  8. smokinjo

    smokinjo Member

    I found som efile:
    apache2-doc
    mailman.conf
    security
    charset
    other-vhosts-access-log
    squirrelmail.conf
    javascript-common.conf
    owncloud.conf
    localized-error-pages
    phpmyadmin.conf

    I presume that the mailman.conf is the file we are looking for?
    Thanks

    Joseph
     
  9. smokinjo

    smokinjo Member

    I presume it will be the mailman.conf file.
    How do I see if it is being used?
    Thanks for any guidance.
    Joseph

     
  10. smokinjo

    smokinjo Member

    Till, (or someone else?)
    Any feedback on how to confirm that my mainman config is being actively loaded by apache?
    Thanks

    Joseph
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Apache has commands to list loaded modules and vhosts but I'm not sure if there is a command to list aliases. So one way might be to add a wrong config line in that file and try to restart apache if it fails, then you know that the file is read. Yeah, not professional but easy :D
     
  12. smokinjo

    smokinjo Member

    So, the file mailman.conf, this is the right file to modify?

    For the wrong config text, just put any garbage text in an uncommented line? The file I have is the original install text. I could post is needed?

    Do I need to put this text n a certain area, or anywhere will work?

    Then, when I reboot, I guess that upon boot up, I would get some kind of errors throughout the boot up phase? Or. how would I know the error happens? Where would I look to see the error?

    As well, the error will not mess up the server running, right? Only that apache will not work right, right?

    Thanks

    Joseph
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    mailman.conf should be the right file. Just add a new line at the end like:

    test

    as long as it's not behnd a comment sign, then apache shuld throw an error.
     
  14. smokinjo

    smokinjo Member

    Hello,
    Thanks for the comment.
    Whee will I see the error? If I am watching the boot up script, will I see it there? Or. where else might I find the error?
    Thanks
    Joseph
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Simply restart apache. You can't miss the error as apache will stop working completely.
     
  16. BitSprocket

    BitSprocket New Member

    So, to add to the confusion, when I create a mailing list it *seems* to go okay except the welcome email references my hostname instead of my domain name which is completely different (hostname: server3.sandigital.tech domain: vetba.org) so when my users see the welcome email, they don't realize that the mailing list is for the domain they are interested in.
    I've searched the mailman docs to configure virtual hosts but to no avail. In fact, I notices that if I use the -v (verbose?) flag on withlist -l -r fix_url LISTNAME -v the output shows:
    Code:
    [email protected]:/home/scott# withlist -l -r fix_url directors -v
    Importing fix_url...
    Running fix_url.fix_url()...
    Loading list directors (locked)
    Setting web_page_url to: https://server3.sandigital.tech/cgi-bin/mailman/
    Setting host_name to: server3.sandigital.tech
    Saving list
    Finalizing
    
    When what I want is for it to use web_page_url to be https://www.vetba.org/cgi-bin/mailman and the host_name to vetba.org

    I see that in mm_cfg.py:
    Code:
    DEFAULT_EMAIL_HOST = 'server3.sandigital.tech'
    #-------------------------------------------------------------
    # Default host for web interface of newly created MLs
    DEFAULT_URL_HOST  = 'server3.sandigital.tech'
    #-------------------------------------------------------------
    # Required when setting any of its arguments.
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)
    
    #-------------------------------------------------------------
    # The default language for this server.
    DEFAULT_SERVER_LANGUAGE = 'en'
    
    #-------------------------------------------------------------
    # Iirc this was used in pre 2.1, leave it for now
    USE_ENVELOPE_SENDER  = 0  # Still used?
    
    #-------------------------------------------------------------
    # Unset send_reminders on newly created lists
    DEFAULT_SEND_REMINDERS = 0
    
    #-------------------------------------------------------------
    # Uncomment this if you configured your MTA such that it
    # automatically recognizes newly created lists.
    # (see /usr/share/doc/mailman/README.Exim4.Debian or
    # /usr/share/mailman/postfix-to-mailman.py)
    # MTA=None  # Misnomer, suppresses alias output on newlist
    
    #-------------------------------------------------------------
    # Uncomment if you use Postfix virtual domains (but not
    # postfix-to-mailman.py), but be sure to see
    # /usr/share/doc/mailman/README.Debian first.
    MTA='Postfix'
    POSTFIX_STYLE_VIRTUAL_DOMAINS = ['lists.sandigital.tech', 'vetba.org']
    
    but it still isn't picking up my virtual domain name and just using the DEFAULT_EMAIL/URL_HOST instead for any of my proper domains.

    Do I perhaps need to specify the domains in add_virtualhost ??
     
  17. BitSprocket

    BitSprocket New Member

    Okay, so making forward progress. The command:
    Code:
    withlist -l -r fix_url directors -u vetba.org -v
    
    fixed the urls so that they use my domain name instead of host name. Fantastic! Now another problem. When I post to the list I get a return error:
    Code:
    The mail system
    
    <[email protected]> (expanded from <[email protected]>):
    Host or domain name not found. Name service error for
    name=server3.sandigigital.tech type=AAAA: Host not found
    
    Thoughts?

    #EDIT#
    I see a problem: the name is misspelled. Instead of server3.sandigigital.tech it is supposed to be server3.sandigital.tech <- misspelled sandigital

    I've tried many times to fix that silly issue (I typed the name in wrong when I configured the server) and I obviously haven't gotten all the corrections made.

    Hostname is correct using hostname -f but somewhere it's still misspelled. Where could that be? A postfix configuration file?
     
  18. BitSprocket

    BitSprocket New Member

    Found it, it was hiding the dbispconfig database. So that's resolved. Now on to my last problem, I'm no longer getting the error but the mail isn't being delivered to the list. More digging!

    #edit#
    Spoke too soon - still getting the same error. Where else could it be misspelled?
     
  19. BitSprocket

    BitSprocket New Member

    Okay, found it. It was in a file called mailname in the /etc directory.
    It all checks good now! Hopefully the above will help someone else...
     

Share This Page