Mailman - trying to make it work

Discussion in 'General' started by smokinjo, Jan 6, 2018.

  1. smokinjo

    smokinjo Member

    Hello,

    I have been using ISPConfig for awhile. It allowed me to manage my server with out lots of Linux skills(though I have had other help when really needed)
    I have tried to make mailman work by creating mailing lists via ISPConfig, but it has never worked.
    I have looked around, and I see a lot of mailman files scattered throughout the server. So, it seems to be installed.
    Before trying to look at what is wrong, can someone explain the logic used with ISPConfig for crating and using a mailing list?
    1 - is there a mailman page for each and every domain for which I have a mailing list?
    2 - how am I able to see the log in and info page for each domain mailman list?

    I will be upfront and honest, I started a couple of months ago really learning Linux on a level more than just a user. I have a long way to go. I also see play with Mailman a first crack and using my newly found skill sand also gaining some practical hand on experience.
    So, bear with me and my seemingly non Linux guru like questions:)

    Thanks for the answers. I will have lots more questions by the time this quest is finished:)

    Thanks

    Joseph
     
  2. smokinjo

    smokinjo Member

    I wanted to follow up on this question by asking again:
    1 - is there a mailman page for each and every domain for which I have a mailing list?
    2 - how am I able to see the log in and info page for each domain mailman list?
    3 - where is mailman stored on the server when it is installed? I want to confirm its presence
    4 -Is mailman installed automatically with the perfect install of ISPConfig?

    I am trying to get the basic working of mailman in ISPConfig.
    Then,. I will troubleshoot.
    Thanks

    Joseph
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig uses the normal mailman installation of the operating system, so nothing is ISPConfig specific there and the mailman URL's are also default, yourserverhostname/mailman/.....

    Yes
     
  4. smokinjo

    smokinjo Member

    Thansk Till.
    I created a new list for experimentation reasons.
    I then received an email letting me know that the list was created. Great!
    I see a link for the admin page, and the user page.
    I click on them both see see the pages, and I get teh same error for eachpage:

    ERROR 404 - Not Found!
    The following error occurred:
    The requested URL was not found on this server.

    Please check the URL or contact the webmaster.

    So, the list is created, but not the pages.

    Ideas?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Use this link and relace the domain (which is probably used by a website) with the server hostname in the url.
     
  6. smokinjo

    smokinjo Member

    Hello,
    The server itself has no domain name. The only thing I could maybe do is use the IP address, but this does not produce anything, as the default website is a different domain.
    (I am not sure how the default domain happened, but anytime I use the IP to view the server, it always displays the first domain I created on the server.)

    If I create a mailing list with the default website, and change the domain to the server IP, it does not work either.
    Joseph
     
  7. smokinjo

    smokinjo Member

    Hello Till,
    I was wondering if you had any observations about my error and also me to having a server URL and needing to use the IP. This still does not work.

    Thanks for any help.

    Joseph
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Every Linux server has a hostname. The name has been set during initial server installation and you can query it with the command:

    hostname -f

    That's the normal behavior of apache and nginx web server. When there is no better matching vhost, then the first one is used.
     
  9. smokinjo

    smokinjo Member

    Hello Till,
    I found the hostname.
    It is a domain I used when I set up the server, but it is not a real, registered domain, so it goes no where.
    I obviously misunderstood the explanation and importance of this step when setting up the server.
    Because of this,. what can I do tomove forward?

    Joseph
     
  10. smokinjo

    smokinjo Member

    I just looked under the system tab in ISP config, and under the system tab in ISPConfig, my domain is listed.
    But, it is a domain that is working an dup and running.

    ispconfig.myserver1.ca - domain listed when I use the host name command
    ispconfig.myserver2.net - domain listed under the system tab (this myserver2.net domain is actually a site on the server)

    Hope this helps.

    Joseph
     
    Last edited: Jan 20, 2018
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The hostname should be a subdomain like server1.yourdomain.tld and it has to exist in dns (so that you reach your server when you type it in the browser). To set or change the hostname, edit the files:

    /etc/hostname
    /etc/mailname (only if this file exists)
    /etc/hosts
    /etc/postfix/main.cf

    and set the hostname in these files, then reboot the server.
     
  12. smokinjo

    smokinjo Member

    Hello,

    I changed all 4 domain names, as per your post.
    I retried looking at the pages, and instead of getting the404 error, I get a simple page not found error.
    It it makes a difference, I am using wordpress for this site. I mention that in case it makes a difference in the error info.

    Joseph
     
  13. smokinjo

    smokinjo Member

    Btw, the use of the IP or the host server domain name seems to pops up the same results.

    Joseph
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    The server hostname has to be a subdomain and there should be no site running on that subdomain. That's why we use a subdomain as hostname like server1.yourdomain.tld and not a domain like yourdomain.tld.
     
  15. smokinjo

    smokinjo Member

    Hello,

    So, my set up is the right format:
    ispconfig.myserver2.net

    I use my server2.net for something.
    But, when I visit this site, it is not supposed to go anyway, is it? Is ti supposed to go to my ISPConfig site?
    To get to my ISPConfig site, I use my IP plus : 8080

    But, as to the point that my mailman URL's go to a page not found, bing that I corrected the subdomain of my server, what would be the next step to look at?

    Thanks

    Joseph
     
  16. jnsc

    jnsc rotaredoM Moderator

  17. smokinjo

    smokinjo Member

    Hello,

    Thanks for finding this previously related issue. It is me EXACTLY!!

    I read over this issue. It seems that the bug issue is still open.

    But, in the meantime, for my install, I only need to use that command:
    withlist -l -r fix_url LISTNAME

    on the command line? If not, where do I use this command?
    As is, except I change the LISTNAME for the name of the real list name?

    Thanks

    Joseph


    ps. I found an example of withlist. It says that I need to run it from with in the mailman directory. Can come one point out where the main mailman folder is? Here is what I found:
    /var/log/mailman
    /var/lib/mailman
    /usr/share/mailman
    /usr/share/doc/mailman
    /usr/share/mailman
    /usr/lib/mailman
    /usr/lib/cgi-bin/mailman
    /usr/lib/mailman
    /etc/mailman
     
    Last edited: Jan 21, 2018
  18. Taleman

    Taleman Active Member HowtoForge Supporter

    I'm also trying to setup Mailman lists with ISPConfig 3.1.11.
    My understanding is:
    - the domain when creating a mailing list must be an existing domain in ISPConfig (since the domain setting is not a write-in, the dropdown list only has existing domains). I assume this domain must have an MX record for mails to work and MX points to server where mailing lists are run.
    - The e-mail received after creation of mailing list claims the admin interface is that above domain plus /cgi-bin/mailman/admin/testilista, but this does not work. The correct URL is fully qualified domain name of the host plus that cgi-bin... string. When httpS is setup for that FQDN it shows the "not safe" icon in left of address bar.
    The -request address does not work, I get
    Code:
    <[email protected]> (expanded from
        <[email protected]>): user unknown
    
    If the web interface language is Finnish, the non-ASCII characters are shown as question marks. Loos like the webpage claims charset=utf8 but the text is ISO-8859-15. This probably is Mailman bug, and not much to do with ISPConfig.
     
  19. Taleman

    Taleman Active Member HowtoForge Supporter

    I noticed the domain name must be included in the Mailman settings. So that a mailing list named members can be created for two distinct domains. I start to believe Mailman is setup is somehow broken, and ISPConfig gets confused by that.
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    That's only about the domain name in the email which is sent by mailman, it's not a problem with accessing mailman. I told @smokinjo already to us the server hostname instead of the domain in the URL, but he says that mailman cannot be reached then. so his problem is not related to this bug and @Taleman already confirmed that a correctöy installed mailman can be reached by simply replacing the domain that is set wrong by mailman with the server hostname.

    What ISPConfig does is that it creates the mailing list in mailman with the mailman list create command and that it adds the aliases required by mailman to receive emails to the postfix config. Emails that are sent by mailman and the mailinglist pages all belong to mailman itself.

    The problem with mailman, in my opinion, is that's a really old software and not well suited for virtual hosting environments with several domains and websites. So maybe I'll remove mailman completely from ISPConfig.

    Nevertheless, I'll assigned the above-mentioned bug report to the next ISPConfig release so that we can at leat fix the wrong domains in mailman mails that occur on some setups.
     
    SuperLOL likes this.

Share This Page