Mailman Service Masked After Debian 11 Upgrade

Discussion in 'ISPConfig 3 Priority Support' started by yupthatguy, Oct 2, 2021.

Tags:
  1. yupthatguy

    yupthatguy Member HowtoForge Supporter

    Hey folks,

    Guess who is back on the keyboard? :) Quick question for the gurus: Following my Debian 11 upgrade, I discovered that my mailman service somehow became "masked":

    Code:
    # service mailman status
    ● mailman.service
         Loaded: masked (Reason: Unit mailman.service is masked.)
         Active: inactive (dead)
    
    Can someone tell me how to get this working again?

    I tried: #apt-get install mailman3, but it fails with bunches of errors.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig requires mailman 2, not mailman 3. mailman 2 is not available on Debian 11, and mailman 3 is a completely different software than mailman 3.
     
  3. yupthatguy

    yupthatguy Member HowtoForge Supporter

    So rollback my update if I want to keep using mailman, got it.

    thx.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Or you have to try to manually install or compile mailman. There should be a thread about this for Debian 11 here in the forum somewhere.
     
  5. yupthatguy

    yupthatguy Member HowtoForge Supporter

    Thanks for the tip, but mailman was the 6th or 7th package giving me a headache after the Debian 11 upgrade, I took it as a sign and rolled back to Debian 10..
     

Share This Page