Mailman not detected when installing ISPConfig

Discussion in 'Installation/Configuration' started by Norm Powroz, Jun 3, 2020.

  1. Norm Powroz

    Norm Powroz New Member

    I have just finished building a new CentOS 7.6 server, following the "Perfect Server...CentOS 7.6..." to the letter. All components described in the cookbook have been installed, including Mailman. It was configured, and a first list created, exactly as described in the document.
    However, when the ISPConfig installer is run, it fails to find Mailman and emits the message:
    "[INFO] service Mailman not detected"
    I have verified that Mailman seems to be correctly installed, and executing "systemctl status mailman.service" gives the following result:
    Code:
    [[email protected] ~]# systemctl status mailman.service
    ● mailman.service - GNU Mailing List Manager
       Loaded: loaded (/usr/lib/systemd/system/mailman.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2020-06-03 00:12:53 EDT; 40min ago
      Process: 1317 ExecStart=/usr/lib/mailman/bin/mailmanctl -s start (code=exited, status=0/SUCCESS)
      Process: 1314 ExecStartPre=/bin/chmod 660 /var/log/mailman/error (code=exited, status=0/SUCCESS)
      Process: 1310 ExecStartPre=/bin/chown mailman:mailman /var/log/mailman/error (code=exited, status=0/SUCCESS)
      Process: 1298 ExecStartPre=/bin/touch /var/log/mailman/error (code=exited, status=0/SUCCESS)
      Process: 1208 ExecStartPre=/usr/bin/install -m644 -o root -g root /usr/lib/mailman/cron/crontab.in /etc/cron.d/mailman (code=exited, status=0/SUCCESS)
      Process: 1152 ExecStartPre=/usr/lib/mailman/bin/mailman-update-cfg (code=exited, status=0/SUCCESS)
     Main PID: 2127 (mailmanctl)
        Tasks: 9
       CGroup: /system.slice/mailman.service
               ├─2127 /usr/bin/python /usr/lib/mailman/bin/mailmanctl -s start
               ├─2129 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=ArchRunner:0:1 -s
               ├─2130 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=BounceRunner:0:1 -s
               ├─2131 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=CommandRunner:0:1 -s
               ├─2132 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=IncomingRunner:0:1 -s
               ├─2133 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=NewsRunner:0:1 -s
               ├─2134 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=OutgoingRunner:0:1 -s
               ├─2135 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=VirginRunner:0:1 -s
               └─2136 /usr/bin/python /usr/lib/mailman/bin/qrunner --runner=RetryRunner:0:1 -s
    
    Jun 03 00:12:31 virtual05.xxx.local systemd[1]: Starting GNU Mailing List Manager...
    Jun 03 00:12:53 virtual05.xxx.local mailmanctl[1317]: Starting Mailman's master qrunner.
    Jun 03 00:12:53 virtual05.xxx.local systemd[1]: Started GNU Mailing List Manager.
    [[email protected] ~]#
    
    Thoughts on the problem, or suggestions to fix it? I've searched in various places and didn't find anything that seemed definitive.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The 20 Install Mailman chapter is quite long in the Perfect Server Guide. Are you absolutely sure everything in that chapter is done correctly on that host?
    These Perfect Server Guides are used thousands of times, so if the Guide was wrong it should have been noticed a long time ago.
     
  3. Norm Powroz

    Norm Powroz New Member

    Yes, as I said, I followed it to the letter. I also re-checked the various files. Mailman created its initial list without problem, and it starts without complaint. I wouldn't want to bet on how many "thousands" of times the CentOS version is used, since it seems that people don't seem to like CentOS. I also tried re-running the ISPConfig installer (as an update) but it seems that if it didn't find something during the initial install then an update is a waste of time as a way to try and get it hooked up later.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The Installer uses the which command to search for mailman in the PATH variable. Check out where mailman binaries are located on your system now and add that to the PATH variable of the root user.

    Even the less popular CentOS setup is installed about a thousand times a week. But many people don't use Mailman, so it might be that CentOS changes something since the guide was written which causes Mailman to not be found anymore.
     
  5. Norm Powroz

    Norm Powroz New Member

    That was the key piece of information, thanks. Executing "which mailman" returns "no mailman in (<PATH>)", or words to that effect.
    The "mailman" binary is located in "/usr/lib/mailman/mail". To fix things I created a file called "mailman.sh" in "/etc/profile.d". The file contains:
    Code:
    pathmunge /usr/lib/mailman/mail
    Obviously, you could create the file on the fly by executing:
    Code:
    echo 'pathmunge /usr/lib/mailman/mail' > /etc/profile.d/mailman.sh
    after which you'd either need to logout and back in, or reload the profile:
    Code:
    . /etc/profile
    Executing "which mailman" after all that returns "/usr/lib/mailman/mail/mailman".
    When I ran the ISPConfig installer it located Mailman and configured it, so all now seems correct (further testing notwithstanding).

    Perhaps a minor update to the "Perfect Server...CentOS 7.6..." documentation?.
     
    Jesse Norell likes this.

Share This Page