Mailman lists not sending to external mails

Discussion in 'Installation/Configuration' started by koukouviou, Mar 3, 2013.

  1. koukouviou

    koukouviou New Member

    Hello, I have setup my institution's server following the Perfect Server Ubuntu 12.10 with ISPConfig 3 - Apache - MySQL how-to, many thanks for that.

    I spend days in debugging various errors that popped up from time to time and I finally got the server to function quite nicely but I still have a few problems I didn't manage to solve from other posts on the web.

    Primarily I have a Mailman lists problem, I can create a list, all local users get the list's mails but external mail (like gmail in this example) don't get the mail. The irony is that I can send a post to the list from the gmail account and it is received by local users but not from the outside members.
    I fixed the permissions for /usr/lib/mailman/bin/ (I had some errors there).

    I post the relevant parts from mail.log below:

    Mar 3 19:59:57 monster postfix/smtp[20755]: connect to[2a00:1450:4001:c02::1b]:25: Permission denied
    Mar 3 19:59:57 monster postfix/smtp[20753]: connect to[2a00:1450:4001:c02::1b]:25: Permission denied
    Mar 3 19:59:57 monster postfix/smtp[20754]: connect to[2a00:1450:4001:c02::1b]:25: Permission denied

    mail.err doesn't show anything relevant.

    The mails not send are shown in the mail queue in ISPConfig 3: -> Monitor -> Show Mail Queue and are only external emails:

    BA89642807D3 4695 Sun Mar 3 19:46:43 [email protected]
    (connect to[]:25: Connection timed out)
    [email protected]

    I haven't messed the postfix conf so it is default as it comes from installing ISPConfig 3.

    My "ISP", which is a bigger part of the institution is definately not blocking port 25. Any ideas relevant to this error?? I'm stuck with this and need to fix the lists before the new semester starts! :)

    Thank you very much in advance.
    Last edited: Mar 3, 2013
  2. koukouviou

    koukouviou New Member


    Typical case of solving my own problem..

    Although my ISP didn't block directly port 25, the port was closed from the upper levels of hierarchy, so I solved the problem by setting the relay host parameter to: [smtp.myisp.suffix]:25 in the postfix config.

    Thanks anyway

Share This Page