Mailman issues

Discussion in 'Installation/Configuration' started by vk3heg, Mar 17, 2015.

  1. vk3heg

    vk3heg Member

    Hello everyone
    I followed to Perfect server guide for Centos 7 here ( and have a working ISPConfig system. It's moving email/doing websites/dns etc.

    I have now come to setup a mailman list for one of the websites, but it's giving me trouble.

    accessing: http://www.domain/cgi-bin/mailman/admin/list-name
    Error's with a 404 error

    dosen't give error's, but I cant make any changes to the config of the mail list as all links refer to 'cgi-bin' in the link.

    ie: clicking on the members link refers to:
    but I then get a 404 error;

    Apache log:
    [Tue Mar 17 03:00:46.850510 2015] [cgi:error] [pid 19989] [client 220.x.x.x:32033] script not found or unable to stat: /var/www/clients/client3/web3/cgi-bin/mailman, referer:
    [Tue Mar 17 03:03:14.939381 2015] [cgi:error] [pid 19958] [client 220.x.x.x:47588] script not found or unable to stat: /var/www/clients/client3/web3/cgi-bin/mailman, referer:
    [Tue Mar 17 03:06:59.251547 2015] [cgi:error] [pid 19904] [client 220.x.x.x:45928] script not found or unable to stat: /var/www/clients/client3/web3/cgi-bin/mailman, referer:

    # httpd configuration settings for use with mailman.
    ScriptAlias /mailman/ /usr/lib/mailman/cgi-bin/
    ScriptAlias /cgi-bin/mailman/ /usr/lib/mailman/cgi-bin/
    <Directory /usr/lib/mailman/cgi-bin/>
    AllowOverride None
    Options ExecCGI
    Order allow,deny
    Allow from all

    #Alias /pipermail/ /var/lib/mailman/archives/public/
    Alias /pipermail /var/lib/mailman/archives/public/
    <Directory /var/lib/mailman/archives/public>
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    AddDefaultCharset Off

    # Uncomment the following line, to redirect queries to /mailman to the
    # listinfo page (recommended).
    #RedirectMatch ^/mailman[/]*$ /mailman/listinfo

    suExec and CGI are disabled in the site config.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to use the hostname of your server to access mailman, not a domain of a website.
  3. vk3heg

    vk3heg Member

  4. QuetzalFirst

    QuetzalFirst Member

    Hi... Same bug here...
    I fix it when I remove cgi-bin in following in these two lines in
    # If you change these, you have to configure your http server
    # accordingly (Alias and ScriptAlias directives in most httpds)
    DEFAULT_URL_PATTERN = 'http://%s/cgi-bin/mailman/'
    PRIVATE_ARCHIVE_URL = '/cgi-bin/mailman/private'

    and remove scriptAlias httpd mailman.cong :
    ScriptAlias /cgi-bin/mailman/ /usr/lib/mailman/cgi-bin/

    My problem now is whenever a add a list in ISPConfig 3, it rewrite !!!
    Where I can write de fix to make it permanent ?

    After that fix, web interface work correctly.

    Another problem : My list cant accept email. Alway get a bounce mail with unknown user.

    Help please
  5. QuetzalFirst

    QuetzalFirst Member

    Got it; I make change in the right place : /somepath/ipsconfig/server/conf-custom/....) I think this folder contains doesn't change with ispconfig update... Right?

    Got it: I add in postfix :
    alias_map : hash:/etc/aliases, hash:/etc/mailman/aliases

    All work fine now. Hope this help!

Share This Page