mailman & ispconfig 3.0.4.3 installation problem

Discussion in 'Installation/Configuration' started by Giuseppe, Mar 26, 2012.

  1. Giuseppe

    Giuseppe New Member

    Hi all,
    i have some problem when install mailman on already existent ispconfig 3.0.4.3 installation.
    I hope someone can help me.
    My environment is:
    Debian squeeze 6.0.4
    ispconfig 3.0.4.3
    ispconfig is installed on cp.mydomain.it on port 80

    I had ispconfig already installed without mailman installation, but now i need mailman so i have do the follow:
    apt-get install mailman
    newlist mailman
    added alias about mailman list in /etc/aliases
    newaliases
    /etc/init.d/postfix restart
    /etc/init.d/mailman start
    php -q update.php reconfiguring services

    BUT:
    after that up done when i go to http://cp.mydomain.it/mailman/listinfo i have:
    not found The requested URL /mailman/listinfo was not found on this server.
    if i go to: http://cp.zyzhsp.it/cgi-bin/mailman/listinfo i have:
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Please help me!
    Thank you for your collaboration.

    Giuseppe
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is cp.mydomain.it a website? If yes, is suexec enabled for the site?
     
  3. Giuseppe

    Giuseppe New Member

    Hi Till,
    thank you for your help,
    yes cp.mydomain.it is a website and exactly the website where my ispconfig control panel work and yes suexec is active on this website.
    I have linked /etc/mailman/apache.conf to /etc/apache2/conf.d/mailman.conf exactly as is it in mailman directory and without active the virtual host comment out in it. Is it correct?
    Thank you very much.

    Giuseppe
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please disable suExec and try again.
     
  5. Giuseppe

    Giuseppe New Member

    Thank you very much, solved
     
  6. baskin

    baskin Member

    I have a similar issue after installing mailman, i'm getting url not found on both (admin and listinfo).

    When i run

    Code:
    php -q update.php reconfiguring services
    there is this:

    Code:
    Traceback (most recent call last):
      File "/usr/lib/mailman/bin/mailmanctl", line 106, in <module>
        from Mailman import mm_cfg
      File "/var/lib/mailman/Mailman/mm_cfg.py", line 76, in <module>
        DEFAULT_SERVER_LANGUAGE = en
    NameError: name 'en' is not defined
    Restarting Mailman master qrunner: mailmanctl
    I have no suExec on the site and i'm on debian 6.

    Thank you in advance.
     
  7. baskin

    baskin Member

    I've managed to go a little further.

    I have started from scratch. I have created to web sites and two mail domains. The first is example.com and the second is lists.example.com.

    I have created a list for the lists.example.com and now i can access the url http://lists.example.com/cgi-bin/mailman/admin/<list>, but it only displays

    and the email for the administrator has not been received. I can't find something useful on the logs (or i'm looking at wrong places).

    I have followed the ispconfig's manual procedure numerous times without success.

    Thanks again.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Use
    Code:
    DEFAULT_SERVER_LANGUAGE = [COLOR="Red"]'[/COLOR]en[COLOR="Red"]'[/COLOR]
    instead of
    Code:
    DEFAULT_SERVER_LANGUAGE = en
    in /var/lib/mailman/Mailman/mm_cfg.py.
     
  9. baskin

    baskin Member

    Thanks falko, i have corrected this before you posted it. Check my second post.
     
  10. baskin

    baskin Member

    I want to summarize my findings after 3 installations from scratch with the same result on Debian 6.

    All the installations have been done step step by the ISPConfig Manual.

    After the installation, all services are started successfully including mailman.

    The problems occurs as soon as i create a mailing list.

    I want to host a single domain (for now) and a second one that is a subdomain but not point to the same space.

    This install is for the Pirate Party Greece so if anyone want to help us please contact me or write here. It is a non profit installation and is based only on open source software.

    I create the website "pirateparty.gr" and the website "lists.pirateparty.gr" because we want them to be separated. "pirateparty.gr" will host a wordpress, a phpbb forum, and a wiki. "lists.pirateparty.gr" will host the mailing lists and maybe something custom for reading the archives but not for now.

    I also create to different email domains, "pirateparty.gr" and "lists.pirateparty.gr". The first one will have user accounts and the second is only for the lists.

    So far everything is ok.

    I enable for the "lists.pirateparty.gr" website CGI and Python (is that correct?) and after that i create a single mailing list for the email domain "lists.pirateparty.gr". After that mailman stops working with the following error:

    Code:
    /etc/init.d/mailman restart
    Restarting Mailman master qrunner: mailmanctlTraceback (most recent call last):
      File "/usr/lib/mailman/bin/mailmanctl", line 107, in <module>
        from Mailman import Utils
      File "/var/lib/mailman/Mailman/Utils.py", line 368, in <module>
        def MakeRandomPassword(length=mm_cfg.MEMBER_PASSWORD_LENGTH):
    AttributeError: 'module' object has no attribute 'MEMBER_PASSWORD_LENGTH'
    Before the creation of the mailing list mailman was restarting without issues.

    It is obvious that the urls http://lists.pirateparty.gr/cgi-bin/mailman/admin/<list> and listinfo are not working with "error 404 not found"

    I have done the installation 3 times with the same result.

    If someone has something to contribute or point me to, we will be grateful.

    Thank you in advance

    Stratos.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker, so we will check that.
     
  12. baskin

    baskin Member

    Thanks falko. I'm looking forward for any news.
     
  13. Lontro

    Lontro New Member

    Hello,

    I can confirm that with ISPConfig 3.0.4.3 the mm_cfg.py template /usr/local/ispconfig/server/conf/mm_cfg.py.master is not copied into /etc/mailman/ correctly and it creates an empty mm_cfg.py for mailman.

    This results into a mailman without functionality.
    ISPconfig system logging in Debug does not show any informations usable just that it processed the datalog_id.

    Changing the line 116 in /usr/local/ispconfig/server/plugins-enabled/mailman_plugin

    from

    if(file_exists($conf["rootpath"]."/conf/mm_cfg.py.master")) {

    to

    if(file_exists($conf["rootpath"]."/conf-custom/mm_cfg.py.master")) {

    resolves the problem.
    Regards
     
    Last edited: Apr 7, 2012
  14. baskin

    baskin Member

    Thanks Lontro.

    What i have to do after editing the file?
     
  15. baskin

    baskin Member

    I can confirm that Lontro's solution makes mailman to restart successfully.

    I although still getting 404 not found on admin and info urls of the list.

    Also no mail has been sent with the creation of the list.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    I've just tested, and it works for me. Please disable CGI for the website and try again.

    Please check your mail log for errors.
     
  17. baskin

    baskin Member

    Thanks falko. After applying the patch and disabling cgi for the vhost, mailman is working!!!

    Should this info be applied to the manual?
     
  18. baskin

    baskin Member

    Another issue is that archiving doesn't work with the following error:

    Code:
    Apr 10 12:15:23 2012 (17078) Archive file access failure:
            /var/lib/mailman/archives/private/it.mbox/it.mbox [Errno 13] Permission denied: '/var/lib/mailman/archives/private/it.mbox/it.mbox'
    Apr 10 12:15:23 2012 (17078) Uncaught runner exception: [Errno 13] Permission denied: '/var/lib/mailman/archives/private/it.mbox/it.mbox'
    Apr 10 12:15:23 2012 (17078) Traceback (most recent call last):
      File "/var/lib/mailman/Mailman/Queue/Runner.py", line 120, in _oneloop
        self._onefile(msg, msgdata)
      File "/var/lib/mailman/Mailman/Queue/Runner.py", line 191, in _onefile
        keepqueued = self._dispose(mlist, msg, msgdata)
      File "/var/lib/mailman/Mailman/Queue/ArchRunner.py", line 73, in _dispose
        mlist.ArchiveMail(msg)
      File "/var/lib/mailman/Mailman/Archiver/Archiver.py", line 198, in ArchiveMail
        self.__archive_to_mbox(msg)
      File "/var/lib/mailman/Mailman/Archiver/Archiver.py", line 167, in __archive_to_mbox
        mbox = self.__archive_file(afn)
      File "/var/lib/mailman/Mailman/Archiver/Archiver.py", line 155, in __archive_file
        return Mailbox.Mailbox(open(afn, 'a+'))
    IOError: [Errno 13] Permission denied: '/var/lib/mailman/archives/private/it.mbox/it.mbox'
    I can see that is a permission error. Which permission settings have to be set and on which folder, for the other future lists to work as well?

    Thank you in advance.
     
  19. baskin

    baskin Member

    Running

    Code:
    chown -R list private/
    in /var/lib/mailman/archives, solved the issue.
     

Share This Page