MailMan Installation

Discussion in 'ISPConfig 3 Priority Support' started by dgeho1, Sep 9, 2014.

  1. dgeho1

    dgeho1 Member HowtoForge Supporter

    Running IspConfig 3.05sp3 on Debian 2.6.32-5-686

    when trying to install MailMan I get he following:

    Setting up mailman (1:2.1.13-5) ...
    Looking for enabled languages (this may take some time) ... done.
    Traceback (most recent call last):
    File "/var/lib/mailman/bin/list_lists", line 46, in <module>
    from Mailman import mm_cfg
    File "/var/lib/mailman/Mailman/mm_cfg.py", line 76
    DEFAULT_SERVER_LANGUAGE =
    ^
    SyntaxError: invalid syntax
    Installing site language en ............................................ done.
    Traceback (most recent call last):
    File "/usr/lib/mailman/bin/update", line 49, in <module>
    from Mailman import mm_cfg
    File "/var/lib/mailman/Mailman/mm_cfg.py", line 76
    DEFAULT_SERVER_LANGUAGE =
    ^
    SyntaxError: invalid syntax
    dpkg: error processing mailman (--configure):
    subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
    Errors were encountered while processing:
    mailman
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Any thoughts will be greatly appreciated.
     
  2. srijan

    srijan New Member HowtoForge Supporter

    You need to configure language settings first

    Then install mailman
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats uncritcal, the message will disappear as soon as you add the first mailinglist.

    If you want to fix it manually, then edit the file:

    var/lib/mailman/Mailman/mm_cfg.py

    and set

    DEFAULT_SERVER_LANGUAGE ="en"

    and restart mailman.
     
  4. dgeho1

    dgeho1 Member HowtoForge Supporter

    Thank you, got it to install and operatate, partially.

    If I create a new list via ISPConfig I get the email...

    The links provided in the email http://valleywebsystems.com/cgi-bin/mailman/admin/hostingclients
    give me a 404 not found error..

    if i look in the /web folder for the given website there is not a cgi-bin folder, and the cgi-bin folder above /web is empty.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    mailman sends yout a wrong link as it assumes that the list is reachable under the domain name of the list but the list is reachable under the hostname of the server. replace the domain name with the server hostname and you will be able to reach the mailman interface.
     
  6. dgeho1

    dgeho1 Member HowtoForge Supporter

    ok it works if I put the public IP address of the server, but what is the true "root" domain of this server?

    Also, is there a method to change the settings that go out in the email?

    And is there a method to use the login per virtual domain that's hosted?

    When trying to send mail from the list I get...

    ep 12 22:58:41 WebServer0 postfix/smtp[5513]: certificate verification failed for mta7.am0.yahoodns.net[98.136.216.26]:25: untrusted issuer /C=US/O=VeriSign, Inc./OU=Class 3 Public Primary Certification Authority
    Sep 12 22:58:42 WebServer0 postfix/smtp[5513]: 71F494C005B: to=<[email protected]>,

    Sep 12 23:04:36 WebServer0 postfix/pickup[4884]: 956B34C0083: uid=0 from=<root>
    Sep 12 23:04:36 WebServer0 postfix/cleanup[23627]: 956B34C0083: message-id=<[email protected]>
    Sep 12 23:04:36 WebServer0 postfix/qmgr[2435]: 956B34C0083: from=<[email protected]>, size=749, nrcpt=1 (queue active)
    Sep 12 23:04:38 WebServer0 postfix/smtpd[23634]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
    Sep 12 23:04:38 WebServer0 postfix/smtpd[23634]: connect from localhost.dmgenterprises[127.0.0.1]
    Sep 12 23:04:38 WebServer0 postfix/smtpd[23634]: 6DCC74C005B: client=localhost.dmgenterprises[127.0.0.1]
    Sep 12 23:04:38 WebServer0 postfix/cleanup[23627]: 6DCC74C005B: message-id=<[email protected]>
    Sep 12 23:04:38 WebServer0 postfix/qmgr[2435]: 6DCC74C005B: from=<[email protected]>, size=1299, nrcpt=1 (queue active)
    Sep 12 23:04:38 WebServer0 postfix/smtpd[23634]: disconnect from localhost.dmgenterprises[127.0.0.1]
    Sep 12 23:04:38 WebServer0 amavis[2157]: (02157-05) Passed CLEAN, <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: jKq7EqFq6SjZ, Hits: -1, size: 749, queued_as: 6DCC74C005B, 1857 ms
    Sep 12 23:04:38 WebServer0 postfix/smtp[23631]: 956B34C0083: to=<[email protected]>, orig_to=<root>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.1, delays=0.19/0.01/0/1.9, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=02157-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6DCC74C005B)
    Sep 12 23:04:38 WebServer0 postfix/qmgr[2435]: 956B34C0083: removed
    Sep 12 23:04:38 WebServer0 postfix/local[23635]: 6DCC74C005B: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.19, delays=0.11/0.02/0/0.07, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
    Sep 12 23:04:38 WebServer0 postfix/qmgr[2435]: 6DCC74C005B: removed
    Sep 12 23:04:49 WebServer0 postfix/anvil[5603]: statistics: max connection rate 1/60s for (smtp:69.170.62.138) at Sep 12 23:00:17
    Sep 12 23:04:49 WebServer0 postfix/anvil[5603]: statistics: max connection count 1 for (smtp:69.170.62.138) at Sep 12 23:00:17
    Sep 12 23:04:49 WebServer0 postfix/anvil[5603]: statistics: max cache size 1 at Sep 12 23:00:17
    Sep 12 23:05:02 WebServer0 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Sep 12 23:05:02 WebServer0 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured

    Sep 12 23:04:38 WebServer0 postfix/smtpd[23634]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
     
    Last edited: Sep 13, 2014
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no root domain. A server has just a hostname. You get this hostname by running:

    hostname -f
     
  8. dgeho1

    dgeho1 Member HowtoForge Supporter

    ok, so what kind of DNS entry do I need to reach the Server by it's hostname? (or is it for local only.

    Is there a way to modify the emails and other links to point to the correct address/hostname?

    Is there a way to point a URL to the hostname so I can use something other than the IP address on the public side?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You need a DNS A-Record for the hostname that points to the IP address of your server.

    I tried thaton a server but mailman complains when there is no placehlder for the domain in the URL in its config file.

    The hostname is a subdomain and not an IP address.
     
  10. dgeho1

    dgeho1 Member HowtoForge Supporter

    so let's say I point a DNS record for the hostname of the server to it's public IP..

    will apache respond with the ISPConfig default pages for the "root" (ie no site created in isp) or serve the mailman pages?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    A DNS record for the hostname has to exist for a server, independantly of mailman, as all services need that as they identify themself to external ressources with this hostname and if your hostname does not exist, external serveras and clients will treat your server as a potential security risk and spam source.

    So the hostname has to be set anyway.

    Trough this hostname, you can reach the apache root and also mailman and other software that is configured to be reached trough the apache root.
     
  12. dgeho1

    dgeho1 Member HowtoForge Supporter

    so I had a dns record creted for the hostname of the server, and it seems to be working fine.

    Thank you
     
  13. dgeho1

    dgeho1 Member HowtoForge Supporter

    ok so I created a dns entry for http://webserver0.dmgenterprises.xcy and I can browse to MailMan.. is t possible to create a redirect in ISP to direct to the server's host name so that the address given out in emails from MailMan can get directed to the server's hostname?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    That should be possible and might be a good option. I don have the exact URĂ–'s that mailman sends here at the moment. If you have them somewhere, can you post them please.
     
  15. dgeho1

    dgeho1 Member HowtoForge Supporter

  16. dgeho1

    dgeho1 Member HowtoForge Supporter

    I just need some direction on how to best setup a redirect with what parameters
     

Share This Page