mailman headache

Discussion in 'Installation/Configuration' started by Bikerepairman, Nov 6, 2014.

  1. Bikerepairman

    Bikerepairman New Member

    Hi, I have installed ispconfig3 recently and all works fine. I wanted to create a mailinglist with mailman but I can't access it with domain.tld/cgi-bin/mailman. When I try I get a 404.

    Mailman is working, since I get a mail from mailman when I change the password.
    following the link in that mail, domain.tld/cgi-bin/mailman/admin/maillijstje, I also get a 404... When I try with local_IP/cg-bin/mailman/admin/maillijstje, it does work, but some links refer to domain.tld

    It must be something I overlooked is my best guess.
    suexec is off, cgi, perl and python is on.

    (small edit to add more info)
    Last edited: Nov 6, 2014
  2. srijan

    srijan New Member HowtoForge Supporter

    Which server distribution your are using??
  3. Bikerepairman

    Bikerepairman New Member

    I use ubuntu 12.xx
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    mailman is accessed either trough the IP address of the server or trugh the server hostname, you cant access it trough the website when the website ahs its wn cgi-bin.
  5. Bikerepairman

    Bikerepairman New Member

    So I can't access it through the website when the website has it's own cgi-bin directory... I disabled cgi in the controlpanel and now I can access it through the website
  6. Bikerepairman

    Bikerepairman New Member

    It all seems to work fine, but no posts are in the list. I have subscribed to the list, posted 2 messages through the list e-mail address, checked if they were withheld (awaiting moderation etc).

    The list archive stays blank.

    addition: I do get a digest mail with all posted things, but nothing in the archives list/mailinglist
    Last edited: Nov 7, 2014

Share This Page