Mailman CGI error!!!

Discussion in 'ISPConfig 3 Priority Support' started by misterm, Apr 13, 2015.

  1. misterm

    misterm Member HowtoForge Supporter

    hi
    By following this tutorial with an error below:
    https://www.howtoforge.com/running-mailman-on-nginx-lemp-on-debian-squeeze-ubuntu-11.04-11.10
    Mz
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You use a server without ISPConfig? I just ask because the above tutorial is for servers that dont run ispconfig. If you use ispconfig, then install it as described in the perfect server tutorial which contains mailman as well.
     
  3. misterm

    misterm Member HowtoForge Supporter

    hi
    I just set the directive in this tutorial and I have the same error message when opening the page.
    Error page :
    an idea

    Mz
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    According to the errr message, your server has a group dsapm which does not exist on ispconfig servers and this group is executing the mailman cgi. I guess you mixed several tutorails which broke the ispconfig mailman setup so that cgi files run under wrong users now.

    Probaly the easiest way to fix this is to install a clean ispconfig perfect server and then compare your config files with this clean setup.
     
  5. misterm

    misterm Member HowtoForge Supporter

    Till I followed your tutorials from the beginning that I use ISPConfig 2 and 3.
    Via the link "/ pipermail / mailman /" focntionne it when I look at the persmissions files and folders, I have this:
    Are these permissions must be the same or not
    Mz
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorial that you posted above which you claimed to have followed is incompatible with ispconfig, if a tutorial does not specifically mention ispconfig 3 in the description, then it is not made for ispconfig 3 and should not be apllied to a ispconfig 3 setup before evaluating if anything might conflict with your existing setup. So if its true what you posted in the first post, then you mixed already a ispconfig setup (perfect setup guide) with a incompatible tutorial (ubuntu mailman tutorial). Your error message shows that your system is running something under a user dspam, this user can not exist on your server if you followed the perfect server guide, so you must at least added software with a third titorial. The more tutoroils you mix, the more likely your server will fail.

    I just checked my debian 7.8 server for a user dspam to be sure that it does not exist in a perfect server guide:

    [email protected]:~# grep dspam /etc/passwd
    [email protected]:~#
    [email protected]:~# grep dspam /etc/group
    [email protected]:~#

    The folder permissions seem to be ok, the problem is that you seem to have installed the software dspam and reconfigured cgi to run udner the dspam user instad of the www-data user, www-data is the right user for a debian or ubuntu setup. So you have to find out where you configured dpsma in nginx and then remove it or change the setup in a way that cgi scripts get executed as www-data again and not as user dspam.
     
  7. misterm

    misterm Member HowtoForge Supporter

    Till I understand that Google Translate provides insights mistakes, but what I want to say that it's been that I'm on the forum and includes tutorials that you and falko you create.
     
  8. misterm

    misterm Member HowtoForge Supporter

    hi
    Did you ever had this problem?
    I change this to get this error message
    File : /etc/init.d/fcgiwrap

    Mz
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    No.
     
  10. misterm

    misterm Member HowtoForge Supporter

    Till we leave this topic, because having found the solution, I decided to move on, an alternative to mailman.

    Mz
     
  11. misterm

    misterm Member HowtoForge Supporter

    hi
    I have this error when creating a list
    What should I do?
    thank you
    MZ :mad::mad:
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Where do you get this error message?
     
  13. misterm

    misterm Member HowtoForge Supporter

  14. till

    till Super Moderator Staff Member ISPConfig Developer

    mailinglists are created trough ispconfig mail module. Login to ispconfig, go to the mail module and add the mailinglist there.
     
  15. misterm

    misterm Member HowtoForge Supporter

    Thank you for your help Till
    I had to reinstall the mailman, I also test Sympa with ISPConfig, bug.
    Now it works
    Thank you, we close the topics, but I do not see how it's done.
    A tutorial picture to "Close" the topics, it would be better.
    Mz
     
  16. misterm

    misterm Member HowtoForge Supporter

    Till I was too fast.
    The url, how we can do to make it more secure (ssl)
    thank you
    Mz
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Enable the default ssl vhost on your server. mailman should be available then on ssl too.
     
  18. misterm

    misterm Member HowtoForge Supporter

    If enabled, but in the messages I receive is not activated all, even
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the exact error message that you get in the web browser?
     

Share This Page