mailman and Recipient address rejected: User unknown in virtual mailbox table;

Discussion in 'Installation/Configuration' started by mxc, Jan 9, 2014.

  1. mxc

    mxc ISPConfig Developer ISPConfig Developer

    Hi there,

    I have installed mailman and updated ISPConfig to the latest version but I can't get mailman to work with ispconfig. There seems to be serveral ways of configuring mailman to work with ISPConfig from posting and how to etc but none of them work for me.

    I have done the following:

    1) replaced /etc/mailman/ with the following:
    #sed -r -e 's/(^[^#]\S+\s+).+$/\1local/' $1 > /var/lib/mailman/data/transport-mailman
    /usr/sbin/postmap /var/lib/mailman/data/transport-mailman
    2) edited postfix/ and added hash:/var/lib/mailman/data/transport-mailman to transport_maps. (It may have been there already I can't recall)

    When I send an email tot he list I get "User unknown in virtual mailbox table". I have tried adding hash:/var/lib/mailman/data/aliases to alias_maps, and hash:/var/lib/mailman/data/virtual-mailman to virtual_alias_maps with no detectable effect on the problem.

    I am using ISPConfig, Centos 6 and postfix. I hope someone can at least provide me with a hint at what to do to solve this.

  2. mxc

    mxc ISPConfig Developer ISPConfig Developer

    Hi there,

    Just to add the /var/lib/mailman/data/virtual-mailman fill is empty so that is why adding the hash to virtual_mailbox_aliases doesn't work. It seems ISPConfig/Mailman is not generating this file.

    In addition, although the /var/lib.mailman/data/alias file is generated it is never hashed i.e it is not run through postmap and there is no *.db file produced.
    Last edited: Jan 9, 2014
  3. mxc

    mxc ISPConfig Developer ISPConfig Developer

    it seems the virtual-mailman file is being updated under /etc/mailman but not /var/lib/mailman/data. Also the /etc/mailman/aliases file is being postmapped int he /etc/mailman directory but not the /var/lib/mailman/data directory.

    So I did the folowing:

    1) added /etc/mailman/aliases to alias_maps in
    2) delete /var/lib/mailman/data/virtual-mailman and created a sim link for /var/lib/mailman/data/virtual-mailman to /etc/mailman/virtual-mailman.

    Not sure if this is how ISPConfig is meant to work.
  4. wozniak

    wozniak New Member

    ISPConfig and Mailman: User unknown in virtual mailbox table: Similar issue

    Hi mxc- I think I am having the same problem you are. I looked at your steps. Did they work for you? I do not have a /etc/mailman/aliases file. Linking/copying to /etc/mailman/virtual-mailman did not help.

    Does anyone else have information about what the intended behavior is? Thanks in advance!
  5. mmmexp

    mmmexp New Member

    For me adding hash:/etc/mailman/aliases to alias_maps worked.

Share This Page