Mailman and email malfunction in Lenny+ISPConfig3

Discussion in 'Installation/Configuration' started by spanish, Dec 14, 2009.

  1. spanish

    spanish New Member HowtoForge Supporter

    Hello,

    First, I have installed ISPConfig3 in a OpenVZ virtual machine (Debian Lenny minimal template). At this, all is OK.

    After, I have installed Mailman following the Planet_Fox tutorial: http://www.howtoforge.de/howto/mailman-auf-einem-ispconfig3-server-einrichten/

    And now:

    1.- I have the same problem that kisong describes in http://www.howtoforge.com/forums/showpost.php?p=111040&postcount=2

    That is, when I try to log into my mailman installation via http://myFQDN/cgi-bin/mailman/admin , there is a 404 error. However, if I log into my mailman installation via http://myIP/cgi-bin/mailman/admin , I can get to it fine. But when I click on a link to add a new list, for example, the link is to the FQDN version of the url and this does not work. If I just change the domain name to the IP address, any page within mailman works.

    Moreover, if I send a email to mailman@myFQDN (the email that is in http://myIP/cgi-bin/mailman/listinfo/test ), I receive this failure notice: "Sorry, I couldn't find any host named myFQDN. (#5.1.2)"

    2.- Email does not work (Postfix problem?) (before Mailman installation it worked).

    This is my configuration:

    -------------------------------------------------------------

    1.- My hostname

    # hostname
    server1
    (Note: this has changed after Mailman installation: before was server1.mydomain.org)

    # hostname -f
    server1.mydomain.org

    -------------------------------------------------------------

    2.- My IP (Fail Over)

    111.222.333.444

    -------------------------------------------------------------

    3.- DNS records in my ISP provider (OVH):

    mydomain.org DNS

    DNS server name DNS server IP
    ns1.mydomain.org 111.222.333.444
    ns2.mydomain.org 111.222.333.444
    server1.mydomain.org 111.222.333.444
    ns.kimsufi.com -

    -------------------------------------------------------------

    4.- DNS Zone and Records
    Like http://www.howtoforge.com/forums/sho...26&postcount=8

    DNS Zone
    Server: Server 1
    Client: -
    Zone (SOA): mydomain.org.
    NS: ns1.mydomain.org.
    Email: admin.mydomain.org.
    ...

    Records
    A mail 111.222.333.444 0
    A mydomain.org. 111.222.333.444 0
    A ns1 111.222.333.444 0
    A www 111.222.333.444 0
    MX mydomain.org. mail.mydomain.org. 10
    NS mydomain.org. ns1.mydomain.org. 0
    NS mydomain.org. ns2.mydomain.org. 0

    -------------------------------------------------------------

    5.- Mail Domain

    Server: Server 1
    Client: Client 1
    Domain: mydomain.org
    Spamfilter: Normal
    Active: Yes

    -------------------------------------------------------------

    Any idea?

    Thanks,

    Manuel
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please ediot the file /etc/hostname and make sure that it contains a fully qualified hostname like: server1.example.com
    Then run:

    /etc/init.d/hostname.sh

    and then restart amavisd.
    If you use just server1, then amavisd will not start again and all mail delivery fails.
     
  3. spanish

    spanish New Member HowtoForge Supporter

    Hello Till,

    I followed your advice, but after 15 hours no changes (the same problems).

    More info:

    -----------------------------------------

    If I try to send a email from Squirremail, the system is left waiting indefinitely.

    -----------------------------------------

    /var/log/mail.err

    Every minute:

    Dec 15 07:26:55 server1 postfix/local[12211]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory
    Dec 15 07:26:55 server1 postfix/smtpd[12212]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory

    -----------------------------------------

    /var/log/mail.info

    Every minute:

    Dec 15 07:28:57 server1 postfix/local[12234]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory
    Dec 15 07:28:57 server1 postfix/smtpd[12235]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory
    Dec 15 07:28:58 server1 postfix/master[1039]: warning: process /usr/lib/postfix/local pid 12234 exit status 1
    Dec 15 07:28:58 server1 postfix/master[1039]: warning: /usr/lib/postfix/local: bad command startup -- throttling
    Dec 15 07:28:58 server1 postfix/master[1039]: warning: process /usr/lib/postfix/smtpd pid 12235 exit status 1
    Dec 15 07:28:58 server1 postfix/master[1039]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

    -----------------------------------------

    /var/log/mail.log

    Every 5 minutes:

    Dec 15 07:30:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Dec 15 07:30:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Dec 15 07:30:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 15 07:30:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0

    Every minute:

    Dec 15 07:32:00 server1 postfix/local[12295]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory
    Dec 15 07:32:00 server1 postfix/smtpd[12296]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory
    Dec 15 07:32:01 server1 postfix/master[1039]: warning: process /usr/lib/postfix/local pid 12295 exit status 1
    Dec 15 07:32:01 server1 postfix/master[1039]: warning: /usr/lib/postfix/local: bad command startup -- throttling
    Dec 15 07:32:01 server1 postfix/master[1039]: warning: process /usr/lib/postfix/smtpd pid 12296 exit status 1
    Dec 15 07:32:01 server1 postfix/master[1039]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

    -----------------------------------------

    /var/log/mail.warn

    Every minute:

    Dec 15 07:35:03 server1 postfix/local[12363]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory
    Dec 15 07:35:03 server1 postfix/smtpd[12364]: fatal: open database /var/lib/mailman/data/aliases.db: No such file or directory
    Dec 15 07:35:04 server1 postfix/master[1039]: warning: process /usr/lib/postfix/local pid 12363 exit status 1
    Dec 15 07:35:04 server1 postfix/master[1039]: warning: /usr/lib/postfix/local: bad command startup -- throttling
    Dec 15 07:35:04 server1 postfix/master[1039]: warning: process /usr/lib/postfix/smtpd pid 12364 exit status 1
    Dec 15 07:35:04 server1 postfix/master[1039]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

    -----------------------------------------

    /etc/apache2/sites-available/ispconfig.conf

    ################################################
    # ISPConfig Logfile configuration for vlogger
    ################################################

    LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig

    <Directory /var/www/clients>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    # Do not allow access to the root file system of the server for security reasons
    <Directory />
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    # Except of the following directories that contain website scripts
    <Directory /usr/share/phpmyadmin>
    Order allow,deny
    Allow from all
    </Directory>

    <Directory /usr/share/squirrelmail>
    Order allow,deny
    Allow from all
    </Directory>


    NameVirtualHost 111.222.333.444:80
    NameVirtualHost 111.222.333.444:443

    -----------------------------------------

    /etc/apache2/sites-available/ispconfig.vhost

    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################

    Listen 8080
    NameVirtualHost *:8080

    <VirtualHost _default_:8080>
    ServerAdmin webmaster@localhost

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    php_value magic_quotes_gpc 0
    </Directory>
    </IfModule>

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    </VirtualHost>

    <Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    -----------------------------------------

    /etc/apache2/sites-enabled/000-ispconfig.conf

    ################################################
    # ISPConfig Logfile configuration for vlogger
    ################################################

    LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig

    <Directory /var/www/clients>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    # Do not allow access to the root file system of the server for security reasons
    <Directory />
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    # Except of the following directories that contain website scripts
    <Directory /usr/share/phpmyadmin>
    Order allow,deny
    Allow from all
    </Directory>

    <Directory /usr/share/squirrelmail>
    Order allow,deny
    Allow from all
    </Directory>


    NameVirtualHost 111.222.333.444:80
    NameVirtualHost 111.222.333.444:443

    -----------------------------------------

    /etc/apache2/sites-enabled/000-ispconfig.vhost

    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################

    Listen 8080
    NameVirtualHost *:8080

    <VirtualHost _default_:8080>
    ServerAdmin webmaster@localhost

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    php_value magic_quotes_gpc 0
    </Directory>
    </IfModule>

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    </VirtualHost>

    <Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    -----------------------------------------

    Please, can I show you any other prompt or configuration of my installation?

    Thanks,

    Manuel
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The following file is missing:

    /var/lib/mailman/data/aliases.db

    You might have to create it manually as ispconfig does not support mailman.
     
  5. spanish

    spanish New Member HowtoForge Supporter

    Thank you very much, Till,

    I'm excited: all is working now.

    :)

    ----------------------------------

    First, I've done the following:

    # cp /etc/aliases /var/lib/mailman/data/aliases
    # postalias /var/lib/mailman/data/aliases
    And restarted the server.

    Questions:
    Is this the best option to create /var/lib/mailman/data/aliases.db?
    I need restart the server or only one or several services?


    ----------------------------------

    Secondly, I've added the following register to DNS Zone:
    A server1 111.222.333.444

    And restarted MyDNS:
    # /etc/init.d/mydns restart

    Question: Is this the best option?

    ----------------------------------

    Now, all is working:

    Apache: http://111.222.333.444/

    Master domain: http://mydomain.org

    ISPConfig 3 (IP and domain):
    http://111.222.333.444:8080/
    http://mydomain.org:8080/

    Mailman (IP, domain and list)
    http://111.222.333.444/cgi-bin/mailman/listinfo/mailman
    http://server1.mydomain.org/cgi-bin/mailman/listinfo/mailman
    [email protected]

    Squirremail & Postfix (IP, domain and email):
    http://111.222.333.444/webmail
    http://server1.mydomain.org/webmail
    [email protected]

    ----------------------------------

    Now, I will try change server1.mydomain.org to lists.mydomain.org for Mailman (I suppose I need change /etc/mailman/mm_cfg.py and DNS Zone).

    And later, try get Virtual domains: http://www.gnu.org/software/mailman/mailman-install/postfix-virtual.html

    I will continue to report here.

    Thanks and regards,

    Manuel
     
  6. spanish

    spanish New Member HowtoForge Supporter

    Here again...

    ;)

    I tried unsuccessfully change server1.mydomain.org to lists.mydomain.org for Mailman:

    1.- Change in mm_cfg.py:
    # vi /usr/lib/mailman/Mailman/mm_cfg.py
    Changed:
    DEFAULT_URL_HOST = 'server1.mydomain.org'
    To:
    DEFAULT_URL_HOST = 'lists.mydomain.org'

    2.- New record in DNS Zone:
    A lists 111.222.333.444

    3.- Restart Apache, Postfix, Mailman and MyDNS (I don't know if this is right):
    # /etc/init.d/apache2 restart
    # /etc/init.d/postfix restart
    # /etc/init.d/mailman restart
    # /etc/init.d/mydns restart

    Now, I can access to http://lists.mydomain.org
    But I can't access to http://lists.mydomain.org/cgi-bin/mailman/listinfo/mailman

    4.- Reboot the server (I don't know if this is need):
    Proxmox -> Virtual Machines -> Server 1 -> Restart

    The same situation:
    I can access to http://lists.mydomain.org
    But I can't access to http://lists.mydomain.org/cgi-bin/mailman/listinfo/mailman

    ERROR 404 - Not Found!

    :(

    Please, any person knows what I'm doing bad? Thanks!

    -------------------------------

    Meantime, I will try get Virtual domains: http://www.gnu.org/software/mailman/mailman-install/postfix-virtual.html

    Greetings,

    Manuel
     

Share This Page