Mailman acting strange

Discussion in 'Installation/Configuration' started by azander, Sep 5, 2014.

  1. azander

    azander New Member

    I just finished installing on Ubuntu 14.10. I added 3 email domains. They are,, and

    I created a mailing list called CrystalBall on the domain When I send email to that list, I get the following bounce emssage:

    ===bounce message===

    > This is the mail system at host
    > I'm sorry to have to inform you that your message could not
    > be delivered to one or more recipients. It's attached below.
    > For further assistance, please send mail to postmaster.
    > If you do so, please include this problem report. You can
    > delete your own text from the attached returned message.
    > The mail system
    > <[email protected]> (expanded from
    > <[email protected]>): user unknown
    =====end message=====

    If this had tried to expand to [email protected] I could, somewhat, understand the issue, but it is converting to !

    I have checked the mail.err and mail.log files for anything that would lead me to what is causing the issue. Best (only) entry I can find:

    Sep 5 16:16:04 mail postfix/qmgr[19279]: EA27A3597: from=<[email protected]>, size=1138, nrcpt=1 (queue active)
    Sep 5 16:16:04 mail postfix/pipe[19304]: EA27A3597: to=<[email protected]>, orig_to=<[email protected]>, relay=dovecot, delay=0.37, delays
    =0.12/0/0/0.24, dsn=5.1.1, status=bounced (user unknown)

    I see other lines that are just the normal transport of the incoming email and the outgoing bounced email. Nothing else shows what this could be. No db files older than non.db file. No postfix errors.

    What am I doing wrong, and/or where can I start looking. I've looked at other entries in the forums, and it looks as if NOBODY has a mailman clue. If this is true (I hope not!), why is it even included in ISPConfig3 ?
    # See /usr/share/postfix/ for a commented, more complete version

    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = /usr/share/doc/postfix

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
    myhostname =
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination =
    relayhost =
    mynetworks = [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = hash:/var/lib/mailman/data/virtual-mailman, mysql:/etc/postfix/, mysql:/etc/postfix/
    virtual_mailbox_domains = mysql:/etc/postfix/
    virtual_mailbox_maps = mysql:/etc/postfix/
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    inet_protocols = all
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, check_recipient_access mysql:/etc/postfix/
    smtpd_tls_security_level = may
    transport_maps = hash:/var/lib/mailman/data/transport-mailman, mysql:/etc/postfix/
    relay_domains = mysql:/etc/postfix/
    relay_recipient_maps = mysql:/etc/postfix/
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = dovecot
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    owner_request_special = no
    smtp_tls_security_level = may
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    content_filter = amavis:[]:10024
    receive_override_options = no_address_mappings
    message_size_limit = 0

  2. azander

    azander New Member

    Mailman + apache aren't working correctly either. I followed the steps in the guide and it still does not work.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I used the ubuntu 14.04 guide to install 2 servers for customers this week, both servers are fully working. So the guide is not the cause here.

    Post the content of the files:


    Regarding apache: Ubuntu uses apache 2.4, so it might be that you have to adjust .htaccess files of your websites if they are ot amde for this apache version. ISPconfig itself is 100% apache 2.4 compatible but your sites might not.
  4. azander

    azander New Member

    [email protected]:~# cat /var/lib/mailman/data/transport-mailman

    [email protected]:~# cat /var/lib/mailman/data/virtual-mailman
    # This file is generated by Mailman, and is kept in sync with the binary hash
    # file virtual-mailman.db. YOU SHOULD NOT MANUALLY EDIT THIS FILE unless you
    # know what you're doing, and can keep the two files properly in sync. If you
    # screw it up, you're on your own.
    # Note that you should already have this virtual domain set up properly in
    # your Postfix installation. See README.POSTFIX for details.

    [email protected] mailman-loop
    [email protected] mailman-loop

    # STANZA START: crystalball
    # CREATED: Sun Aug 3 16:38:50 2014
    [email protected] crystalball
    [email protected] crystalball-admin
    [email protected] crystalball-bounces
    [email protected] crystalball-confirm
    [email protected] crystalball-join
    [email protected] crystalball-leave
    [email protected] crystalball-owner
    [email protected] crystalball-request
    [email protected] crystalball-subscribe
    [email protected] crystalball-unsubscribe
    # STANZA END: crystalball

    Problem I have with apache is that the individual domains ( and don't seem to get the Script alias from mailman.conf in conf-enabeled. The /cgi-bin/mailman/admin works from the control panel, but not for each domain.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have cgi enabled in these websites? Enabling cgi may redirect requests to the local cgi directory so they dont get forwarded to mailman.
  6. azander

    azander New Member

    Till, That fixed the website issue. Still have the issue of postfix re-writing the domain portion of the email.

    I found a way to make it work, but it is not the proper way. Since it is re-writing it to the server's Hostname minus the machine name (Machine name: and Postfix re-writing it to [email protected]) I just reset the machine name to which causes it to tr-werint it to

    I would rather have a proper fix. What do you need from me to help make that happen?

Share This Page