MailLog message

Discussion in 'Installation/Configuration' started by happz, Sep 21, 2008.

  1. happz

    happz Member

    My maillog has this entry- Sep 20 22:14:51 websrv1 postfix/smtp[8791]: warning: database /etc/postfix/sasl_passwd.db is older than source file /etc/postfix/sasl_passwd
    __________________________________________________________

    How do i resolve this message or problem?

    Also, if i may ask question #2.

    I can send and receive emails to all i.e. yahoo, msn, aol..you name it...i have config. outlook to do this. So all is good there but my actual websites that run php script sites such as, well, v Bulletin...that ability to send users a message from within the website administration or another example is when a user signs up...they should be receiving an email that they can click a link for to authenticate them but it never shows up. Can anyone explain how i fix this?
     
    Last edited: Sep 22, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This file is not used by ISPConfig.

    Do you run your server behind a dsl line with dynamic IP?
     
  3. happz

    happz Member

    Yes...DSL

    Till,

    to send and receive emails it took me a long time to figure out how to use my ISP for smtp but now i can send/rec emails using outlook. i use pop3 of my centos server via perfect server config and i use my isp setting for smtp. all will work but internal websites like my forum sites and youtube clones will not send any email at all.

    thanks
    happz
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please answer my question from above:

    We can not help you if you dont answer the questions :)
     
  5. happz

    happz Member

    please read on..

    Sorry Till but my title was the answer in the previous response but you are right...i forgot some info. the answer is yes, i am running server behind dsl and i have a static IP.

    thank you.

    happz
     
    Last edited: Sep 21, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

  7. happz

    happz Member

    does anyone else run php sites like vbulletin and can't send mail..

    if anyone can help, this is the last major problem i need to get through in order to close down my godaddy VPS. None of my php sites will send mail such as when a user signs up on my site...they should receive a welcome email....but nope...not getting it.

    thanks

    happz
     
  8. happz

    happz Member

    Thanks Falko..i do not have a dynamic IP and I can send/receive emails


    I can send/receive emails because i am relaying them. My problem is with my websites (all are php just like this one, howtoforge) but no messages will work...say you forget your password, click forgot password and nothing will go. that is my problem now.

    happz
     
  9. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when a PHP app tries to send a mail?
     
  10. happz

    happz Member

    here is one resulted log...

    i did an invite and here is the log, i did remove some personal info from the log----
    _______________________________________________________________
    Sep 23 22:39:21 websrv1 sendmail[1713]: m8O2dLB8001713: from=apache, size=711, class=0, nrcpts=2, msgid=<[email protected]>, [email protected]
    Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: connect from localhost.localdomain[127.0.0.1]
    Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Sep 23 22:39:21 websrv1 sendmail[1713]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: B7BCB34D07EB: client=localhost.localdomain[127.0.0.1], [email protected]
    Sep 23 22:39:21 websrv1 postfix/cleanup[1717]: B7BCB34D07EB: message-id=<[email protected]>
    Sep 23 22:39:21 websrv1 sendmail[1713]: m8O2dLB8001713: [email protected],[email protected], ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60711, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as B7BCB34D07EB)
    Sep 23 22:39:21 websrv1 postfix/qmgr[986]: B7BCB34D07EB: from=<[email protected]>, size=1192, nrcpt=2 (queue active)
    Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: disconnect from localhost.localdomain[127.0.0.1]
    Sep 23 22:39:21 websrv1 postfix/qmgr[986]: B7BCB34D07EB: to=<[email protected]>, relay=none, delay=0.09, delays=0.05/0.04/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to fmailhost.isp.att.net[204.127.217.18]: Connection timed out)
    Sep 23 22:39:21 websrv1 postfix/cleanup[1717]: CE90A34D07EC: message-id=<[email protected]>
    Sep 23 22:39:21 websrv1 postfix/local[1719]: B7BCB34D07EB: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.11, delays=0.05/0.05/0/0, dsn=2.0.0, status=sent (forwarded as CE90A34D07EC)
    Sep 23 22:39:21 websrv1 postfix/qmgr[986]: CE90A34D07EC: from=<[email protected]>, size=1362, nrcpt=1 (queue active)
    Sep 23 22:39:21 websrv1 postfix/qmgr[986]: CE90A34D07EC: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.01, delays=0/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to fmailhost.isp.att.net[204.127.221.14]: Connection timed out)
    [[email protected] log]#
    ________________________________________________________________
    here is another log----Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: 3C72834D07E6: client=localhost.localdomain[127.0.0.1], [email protected]
    Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: 3C72834D07E6: reject: RCPT from localhost.localdomain[127.0.0.1]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<websrv1.myhiddendomain.com>
    Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGm032362: [email protected], ctladdr=apache (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=60706, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown
    Sep 23 22:00:39 websrv1 postfix/cleanup[32366]: 3C72834D07E6: message-id=<[email protected]>
    Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 3C72834D07E6: from=<[email protected]>, size=1218, nrcpt=1 (queue active)
    Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGm032362: [email protected], ctladdr=apache (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=60706, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 3C72834D07E6)
    Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGm032362: m8O20cGn032362: DSN: User unknown
    Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 3C72834D07E6: to=<[email protected]>, relay=none, delay=0.07, delays=0.06/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to fmailhost.isp.att.net[204.127.217.18]: Connection timed out)
    Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: 4C08F34D07E7: client=localhost.localdomain[127.0.0.1]
    Sep 23 22:00:39 websrv1 postfix/cleanup[32366]: 4C08F34D07E7: message-id=<[email protected]>
    Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 4C08F34D07E7: from=<>, size=3226, nrcpt=1 (queue active)
    Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGn032362: to=apache, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31730, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 4C08F34D07E7)
    Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: disconnect from localhost.localdomain[127.0.0.1]
    Sep 23 22:00:39 websrv1 postfix/local[32368]: 4C08F34D07E7: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.09, delays=0.05/0.04/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
    Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 4C08F34D07E7: removed
    You have new mail in /var/spool/mail/root
    _______________________________________________________________-

    So any ideas?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you set the from header in the mail function of your php scripts to an existing email address.
     
  12. happz

    happz Member

    thanks! now i hate to keep this going but...

    here is my recent mail log when i clicked on one of my sites for lost password.::::::

    Sep 26 16:26:53 websrv1 postfix/smtpd[19731]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Sep 26 16:26:53 websrv1 sendmail[19730]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Sep 26 16:26:53 websrv1 postfix/smtpd[19731]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Sep 26 16:26:53 websrv1 postfix/smtpd[19731]: B458334D07D5: client=localhost.localdomain[127.0.0.1], [email protected]
    Sep 26 16:26:53 websrv1 postfix/cleanup[19734]: B458334D07D5: message-id=<[email protected]>
    Sep 26 16:26:53 websrv1 sendmail[19730]: m8QKQrE0019730: [email protected], ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30795, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as B458334D07D5)
    Sep 26 16:26:53 websrv1 postfix/qmgr[27421]: B458334D07D5: from=<[email protected]>, size=1329, nrcpt=1 (queue active)
    Sep 26 16:26:54 websrv1 postfix/smtpd[19731]: disconnect from localhost.localdomain[127.0.0.1]
    Sep 26 16:26:54 websrv1 postfix/qmgr[27421]: B458334D07D5: to=<[email protected]>, relay=none, delay=0.31, delays=0.26/0.05/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to fmailhost.isp.att.net[111.111.111.111]: Connection timed out)


    Now till, i heard what you asked me to do but i have not ever had to make any code changes on my other forum installs or any other site with godaddy. anything you can learn from this log? oh and i changed the real ip of isp to 111.111.111.111 and the server names...

    happz
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Is fmailhost.isp.att.net the relay server?

    Does websrv1.myCENTOSispserver.com exist in DNS?
     
  14. happz

    happz Member

    answers-

    Yes, fmailhost.isp.att.net is my relay server. Now websvr1.domainserver.com is what i named the server in like one of the first steps in Perfect Server CENTOS 5.2 configuration so i don't know how to answer the question. the name is the name of my server. is that what you need to know?

    thanks till and falko...i'll wait to hear back!

    happz
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Yes, but does your server name exist in DNS? Do you get an ANSWER section when you run
    Code:
    dig websrv1.myCENTOSispserver.com
    ?
     
  16. happz

    happz Member

    results....

    ; <<>> DiG 9.3.4-P1 <<>> websrv1.myCENTOSsrv.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 10151
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;websrv1.myCENTOSsrv.com. IN A

    ;; AUTHORITY SECTION:
    myCENTOSsrv.com. 10800 IN SOA ns57.domaincontrol.com. dns.jomax.net. 2008091200 28800 7200 604800 86400

    ;; Query time: 119 msec
    ;; SERVER: 205.152.37.23#53(205.152.37.23)
    ;; WHEN: Sun Sep 28 08:19:46 2008
    ;; MSG SIZE rcvd: 115

    [[email protected] ~]#::::::

    Now, when i followed the instructions on "prefect server" in the very begining you had example of server1.example.com i think, so i made up websrv1 for HOST and then used (exampleonly) myCENTOSsrv.com and then continued on...so my server became websrv1.myCENTOSsrv.com (ex only). Now i actually own domain name of [myCENTOSsrv.com] (hidden actual name here) but made up the websrv1 because i wasn't sure of how this played out. Please advice...thanks
     
  17. falko

    falko Super Moderator ISPConfig Developer

    Ok, please create an A record for websrv1.myCENTOSispserver.com.
     
  18. happz

    happz Member

    A little more info to tell...

    when installing ispconfig i answered the questions during installation this way... host:www Domain:mydomainongodaddy.com :::::: then in ispconfig i created the first site as www.mydomainongodaddy.com i.e. web1_mydomain so where i may be going wrong is trying to figure out where i manage that domain since it is the domain that my ispconfig is working from. you see, i can go into godaddy and add A records and mx records and it seems that the changes do go but then i think, why am i admin'ing so much within godaddy when i installed ispconfig to get me away from godaddy....so then i decided that maybe if because my centos server called websrv1.mydomainongodaddy.com is running dns, mail, ns and so on that maybe i could just take a couple of sites that i own and within godaddy just point them to ns1.mydomainongodaddy.com and ns2.mydomainongodaddy.com....well, when i pointed the first one to the ns it seemed to be okay...my emails would still go back and forth...i did another one...same thing..all looked good but then a little later i found that they cannot be opened with browser anymore. This is a lot of infomation but falko and or till and the rest, if you can make sense of this i would be so so very happy and it might help many others.... now, falko you asked me to create an A record for my server name websrv1.my...., where should this be done, on ispconfig or godaddy and what do i do about my main site which is also what ispconfig uses to functionn...

    happz...so it is so long but this may help many others i hope...
     
  19. falko

    falko Super Moderator ISPConfig Developer

Share This Page