Discussion in 'HOWTO-Related Questions' started by radox, Nov 14, 2006.

  1. radox

    radox New Member

    I am following this howto

    Postfix Monitoring With Mailgraph And pflogsumm - Page 2

    I have Apache/2.0.54 (Debian GNU/Linux) PHP/5.1.6-1~bpo.1 mod_ssl/2.0.54 OpenSSL/0.9.7e Server installed

    on this page there is a script which starts like this:

    #!/usr/bin/perl -w

    # mailgraph -- a postfix statistics rrdtool frontend
    # copyright (c) 2000-2004 David Schweikert <[email protected]>
    # released under the GNU General Public License

    use RRDs;
    use POSIX qw(uname);

    my $VERSION = "1.10";

    but in of mail going through the server? radox
    Last edited: Nov 14, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Please post your vhost configuration. I assume this is in /etc/apache2/sites-available/default on your system.
  3. radox

    radox New Member

    default file

    here is the default file as requested
    NameVirtualHost *
    <VirtualHost *>
    ServerAdmin [email protected]

    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
    # in /apache2-default/, but still have / go to the right place
    RedirectMatch ^/$ /apache2-default/

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined
    ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from ::1/128

  4. falko

    falko Super Moderator ISPConfig Developer

    Please copy mailgraph.cgi to /usr/lib/cgi-bin. In your browser, you must use .
  5. Ovidiu

    Ovidiu Active Member

    I had set it up according to the how-to from howtoforge but yesterday I had to mass change a lot of owners in my web directory and it seems I somehow also affected the cgi-bin folder as I stopped seeing output. I installed it months ago and everything was working fine.

    output was here:

    my vhost (partially):

    stuff is inside: /var/www/web1/cgi-bin/ and the cgi-bin folder is owned by web1_postmaster:web1

    so what could be the problem?
  6. falko

    falko Super Moderator ISPConfig Developer

    Please check the permissions of the image directory (where mailgraph writes the graphs).
  7. Ovidiu

    Ovidiu Active Member

    I opened mailgraph.cgi and found these lines:

    then I did a
    as the mailgraph.cgi is inside my web1 and I use suexec. Also did a
    and now I am waiting for some graphs to show up - right?

    and btw. the directory /var/lib/mailgraph was completely missing....

    or shall I reinstall it all, following the tutorial again?
  8. falko

    falko Super Moderator ISPConfig Developer

    Yes. Maybe you must do a chmod 777. Is it working now?
  9. Ovidiu

    Ovidiu Active Member

    I think 775 is enough, but anyway even a chmod -R 777 didn't change anything.... strange...

    shall I PM you a link?
    Last edited: Jan 27, 2007
  10. falko

    falko Super Moderator ISPConfig Developer

    Then there must be still another directory that mailgraph needs for creating the graphs.
  11. Ovidiu

    Ovidiu Active Member

    I narrowed it down, its a ownership problem...

    if I chown web1_postmaster:web1 I get permission denied errors 403 (this is the user and group for suexec for this client) if I chown web1_postmaster:www-data I get suexec errors... saying anyone is allowed to write ([2007-01-28 18:44:21]: uid: (10001/web1_postmaster) gid: (10001/10001) cmd: mailgraph.cgi
    [2007-01-28 18:44:21]: directory is writable by others: (/var/www/web1/cgi-bin)

    which is not true I chmoded to 774 ?

    can anyone using suexec for cgi scripts tell me who owns his cgi-bin directory and the containing mailgraph.cgi script? and how the folder and files are chmoded please so I can compare.

Share This Page