Mailgraph and CGi-bin

Discussion in 'HOWTO-Related Questions' started by namit, Oct 18, 2006.

  1. namit

    namit New Member

  2. nsurge

    nsurge New Member

    Did you make the cgi script executable?
     
  3. namit

    namit New Member

    Yes I did when i copied it over have it excutable.
     
  4. nsurge

    nsurge New Member

    What are the permissions on the file currently?
     
  5. namit

    namit New Member

    owner is: www-root
    permitions 755

    But it still comes up with the text

    Do i not have to activate or install cgi? and if so how?
     
  6. namit

    namit New Member

    Maby i should ask how do i activate cgi on apache2?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? Can you post your vhost configuration here?
     
  8. namit

    namit New Member

    Debian

    <VirtualHost *>
    ServerName mywebsite.org
    DocumentRoot /home/namit/public_html/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    LogLevel warn
    </VirtualHost>
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Try

    Code:
    <VirtualHost *>
             ServerName mywebsite.org
            DocumentRoot /home/namit/public_html/
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
    
            LogLevel warn
    <Directory /home/namit/cgi_bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    ScriptAlias  /cgi-bin/ /home/namit/cgi_bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    </VirtualHost>
    Of course, you must create /home/namit/cgi_bin before. Restart Apache, and put your CGI scripts into /home/namit/cgi_bin.
     

Share This Page