Mailer-daemon's reply for addresses of a deactivated mail domain says "loops back to myself"

Discussion in 'ISPConfig 3 Priority Support' started by Etcetera, Jan 2, 2020.

  1. Etcetera

    Etcetera Member HowtoForge Supporter

    Hello – and a great new year!

    I deactivated a mail domain, not wanting to delete it, because I might want to reactivate it at some point. Testing the deactivation with an e-mail from another domain to a test address within the deactivated domain, I get a mailer-daemon reply with a failure notice containing this snippet:
    Code:
    Reporting-MTA: dns; [host]
    X-Postfix-Queue-ID: 544A5141295
    X-Postfix-Sender: rfc822; [[email protected]]
    Arrival-Date: Thu,  2 Jan 2020 15:45:05 +0100 (CET)
    
    Final-Recipient: rfc822; [email protected][deact'd-domain]
    Original-Recipient: rfc822;[email protected][deact'd-domain]
    Action: failed
    Status: 5.4.6
    Diagnostic-Code: X-Postfix; mail for [deact'd-domain] loops back to
        myself
    Is this what is designed to get back to senders of mail to a deactivated domain? Is there a way to change status and code to something different for this case?

    This is ISPConfig 3.1 on Ubuntu 16.04 LTS set up according to "The Perfect Server – Ubuntu 16.04 (Xenial Xerus) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1".

    Thanks & cheers,
    Etc
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    When the deactivated domain is still pointing to this server or the system where it points now forwards the mail back and you send the test email from the same system, then this creates a loop and a loopback message is created. Try to send an email from an external system like a gmail account, in that case you should get just a denied / not available message.
     
  3. Etcetera

    Etcetera Member HowtoForge Supporter

    If I send the email from another server (tried two different ones), it looks like the mail is being sent and I get nothing at all in reply (at least not within a few minutes), as if the mail would have been sent successfully. (I have removed the MX record for the domain now.)
     
  4. Etcetera

    Etcetera Member HowtoForge Supporter

    More observations:
    • The test mails didn't reach the test account (so this is as expected).
    • I can still access the test account of the deactivated domain by IMAP.
    • I can still send from the test account of the deactivated domain with SMTP.
    • Both IMAP and SMTP even work when I check "Disable SMTP (sending)" and "Disable IMAP" for the specific mailbox.
     
    Last edited: Jan 2, 2020
  5. Etcetera

    Etcetera Member HowtoForge Supporter

    Addendum: Now, after the MX record removal was propagated to the server's DNS, two earlier attempts at sending which at first seemed to be sent out ok were returned with a "Host or domain name not found" notice.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely you deactivated the email domain but you did not deactivate the mailbox?
     
  7. Etcetera

    Etcetera Member HowtoForge Supporter

    Pardon the possibly stupid question, but if I still have to deactivate every mailbox in it one by one, what does deactivating the mail domain actually do?

    Back to the issue at hand, I did try every combination of activated/deactivated maildomain and activated/deactivated mailbox, including deactivated maildomain and deactivated mailbox ("enable receiving" off, "disable IMAP" on, "disable SMTP" on), but whatever I do, I can still access the mailbox via IMAP and use its credentials to send via SMTP.
     
  8. Etcetera

    Etcetera Member HowtoForge Supporter

    Ok, another addition (success!): Somehow it seems the connection between Thunderbird and dovecot did survive several changes of settings to the maildomain and the mailbox in ISPConfig.

    After closing and restarting both Thunderbird and manually restarting dovecot on the server the mailbox (maildomain deactivated + mailbox deactivated) is now inaccessible.
     

Share This Page