Maildrop: unable to open mailbox

Discussion in 'Installation/Configuration' started by KaiserGimmel, Jan 24, 2010.

  1. pebkac

    pebkac Member HowtoForge Supporter

    Distributor ID: Ubuntu
    Description:    Ubuntu 9.10
    Release:        9.10
    Codename:       karmic
    I have tried that hold many times and it does nothing. I think I may have found a fix. I did this last night and this morning when I ran the update it did not downgrade.

    I made sure everything in /etc/apt/apt.conf.d/50unattended-upgrades was commented out. Help it is the fix for now.

  2. pebkac

    pebkac Member HowtoForge Supporter

    Commenting out that file seems to have worked!
  3. valasule

    valasule New Member

    Possible fix to the problem

    I've been having a similar problem as everyone else and I think I might have found a fix for the unattended updates.
    in /etc/apt/apt.conf.d/50unattended-upgrades there is a blacklist area:
    // List of packages to not update
    Unattended-Upgrade::package-Blacklist {

    I've added "maildrop"; into this list and will let things run and see if that removes maildrop from the unattended updates. This does not effect manually updating though and even using the previous commands to hold or add maildrop to the don't update lists causes apt-get upgrade to want to upgrade maildrop.

    Something I just noticed was that executing:
    echo "maildrop hold"|dpkg --set-selections
    using sudo has started giving me an error:
    dpkg: operation requires read/write access to dpkg status area

    I hadn't noticed this when I issued that command a few days ago when troubleshooting this problem. If I sudo su and run that command it runs without error and if I run apt-get upgrade maildrop is now in the list of packages to hold back. So hopefully the combination of this and adding it to the black list in the other file will solve these issues until what ever changes that were made in the ?new? maildrop package are made compatible with ISPConfig.
    Last edited: Mar 2, 2010
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You should really consider to update your ubuntu system, as the maildrop packages of ubuntu 9.10 are ok, only the packages in 9.04 are broken.
  5. valasule

    valasule New Member

    Not really a helpful suggestion Till since we run multiple systems that 9.10 is not compatible with and we also run a local apt cache to reduce the amount of load we put on the repositories.
    As for my previous post I checked my ISPConfig box and the maildrop package did not get updated as it had been in the past.
    Now to figure out what is causing the break in the maildrop update and see if we need to harass Ubuntu or change something in ISPConfig.
  6. paxpacis

    paxpacis New Member


    I read several maildrop issues and mine is a little different than all of them.

    My error is: status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to write to temporary file - possibly out of disk space. )

    As this seems very easy, check diskspace and here is the catch:

    sudo df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 66G 26G 36G 42% /
    varrun 4.0G 124K 4.0G 1% /var/run
    varlock 4.0G 0 4.0G 0% /var/lock
    udev 4.0G 56K 4.0G 1% /dev
    devshm 4.0G 0 4.0G 0% /dev/shm
    /dev/sdb1 272G 1.4G 257G 1% /var/www
    overflow 1.0M 4.0K 1020K 1% /tmp

    There is no issue with any of my diskspaces..

    sudo mail drop -v
    maildrop 2.0.3 Copyright 1998-2005 Double Precision, Inc.

    I use Ubuntu 8.04.3 LTS and did not update anything before or after the error came and there is no autoupdate script running..
  7. falko

    falko Super Moderator ISPConfig Developer

    Maybe it's a quota issue - what's the output of
    repquota -avug
  8. paxpacis

    paxpacis New Member

    Hi Falko, do you want is for all users? can I direct message this info?

  9. falko

    falko Super Moderator ISPConfig Developer

    No need to post it - all I need to know if there are users and/or groups that are over quota.
  10. paxpacis

    paxpacis New Member


    There was no user over quota, I had to check the manual what all the output of the command was.

    I rebooted the server and the problem resolved. I know this is the Windows way but this time it worked with my Linux server as well.. :D

    Thanks for helping to solve this issue..

Share This Page