maildrop seems to work, but no messages in INBOX

Discussion in 'General' started by diablo81, Jan 3, 2011.

  1. diablo81

    diablo81 New Member

    Hi,
    I've installed some days ago ispconfig 3. My machine runs with ubuntu 10.04. I followed exactly "The Perfect Server - Ubuntu 10.04 [ISPConfig 3]" how to on howtoforge.
    All works well but not maildrop or better maildrop seems to work well, but I cannot find any message in INBOX and in vmail directory. I tried to use different email clients (roundcube, thunderbird), but the problem is I cannot see any file in the directory "new" (and also in cur) in the Mailbox diretory (I'm using imap).

    Here you are a mail.log.

    Code:
    Jan  3 19:31:05 ns39057 postfix/smtpd[20728]: connect from aa011-1msr.fastwebnet.it[62.101.93.131]
    Jan  3 19:31:06 ns39057 postfix/smtpd[20728]: 02BC71A2527: client=aa011-1msr.fastwebnet.it[62.101.93.131]
    Jan  3 19:31:06 ns39057 postfix/cleanup[20918]: 02BC71A2527: message-id=<4D2215E8.5090001@fastwebnet.it>
    Jan  3 19:31:06 ns39057 postfix/qmgr[3850]: 02BC71A2527: from=<gxxxxxxxxxxxx@fastwebnet.it>, size=830, nrcpt=1 (queue active)
    Jan  3 19:31:11 ns39057 imapd-ssl: Connection, ip=[::ffff:127.0.0.1]
    Jan  3 19:31:11 ns39057 postfix/smtpd[20927]: connect from localhost.localdomain[127.0.0.1]
    Jan  3 19:31:11 ns39057 postfix/smtpd[20927]: B9C451A252B: client=localhost.localdomain[127.0.0.1]
    Jan  3 19:31:11 ns39057 postfix/cleanup[20918]: B9C451A252B: message-id=<4D2215E8.5090001@fastwebnet.it>
    Jan  3 19:31:11 ns39057 postfix/qmgr[3850]: B9C451A252B: from=<gxxxxxxxxxxxxxi@fastwebnet.it>, size=1283, nrcpt=1 (queue active)
    Jan  3 19:31:11 ns39057 postfix/smtpd[20927]: disconnect from localhost.localdomain[127.0.0.1]
    Jan  3 19:31:11 ns39057 amavis[3476]: (03476-10) Passed CLEAN, [62.101.93.131] [62.101.93.131] <gxxxxxi@fastwebnet.it> -> <ixxxxx@sxxxxxxxxe.it>, Message-ID: <4D2215E8.5090001@fastwebnet.it>, mail_id: fnaV-PvPe+d4, Hits: -0.009, size: 829, queued_as: B9C451A252B, 5729 ms
    Jan  3 19:31:11 ns39057 postfix/smtp[20919]: 02BC71A2527: to=<xxxxxxo@sxxxxxre.it>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.8, delays=0.03/0.01/0/5.7, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=03476-10, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as B9C451A252B)
    Jan  3 19:31:11 ns39057 postfix/qmgr[3850]: 02BC71A2527: removed
    Jan  3 19:31:11 ns39057 postfix/pipe[20930]: B9C451A252B: to=<xxxxxxo@sxxxxre.it>, relay=maildrop, delay=0.02, delays=0/0.01/0/0, dsn=2.0.0, status=sent (delivered via maildrop service)
    Jan  3 19:31:11 ns39057 postfix/qmgr[3850]: B9C451A252B: removed
    
    I have nothing in mail.err and mail.warn, blank files.

    As you can see from log maildrop seems to work fine. Please help me if you have any idea.
    Feel free to ask anything you need about config files.

    Thank you for you help.

    Ps. I hid email boxes only for privacy.
    PPs. sorry for my english!
     
  2. diablo81

    diablo81 New Member

    I forgot to say that I'm using ispconfig 3.0.3.1 and that I have no problem sending mails (also saving them in Mailbox).
     
  3. diablo81

    diablo81 New Member

    omg I want to kill myself...

    it was my fault: home dir for the user used by maildrop was wrong, so all messages were deliver to a single file in the home directory of the user...

    Changed the home dir of the virtual mail user...worked!

    Hope this can help someone!

    Ps. I lose some hours :(
     

Share This Page