Maildrop problem

Discussion in 'Installation/Configuration' started by maced0n, Dec 23, 2009.

  1. maced0n

    maced0n New Member

    Hi, I followed perfect lenny ISP 3 guide and with small changes everything went fine except that i cant receive emails.

    This installation is in Linux-VServers and Lenny and everything is installed according to the guide except the quota part ( not available in this virtualization)

    This is from mail.log

    Master.cf

    Permissions are all fine.

    I Googled whole day without success, probably this issue is related with the quota.


    Any hints?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    grep vmail /etc/passwd
     
  3. maced0n

    maced0n New Member

    I don't think that there is a permission issue.

    Also I forget to write, I can send an email without a problem.


    As I said before can this be because my partition is mounted without a Quota ?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's your ISPConfig version?
     
  5. maced0n

    maced0n New Member

    The latest one " ISPConfig 3.0.1.6 ".

    I installed ISPConfig 3 on same identical server only this time mounted with quota, all conf files and permissions are same as before .

    Everything is working OK now.
     
  6. divendres

    divendres New Member

    Same problem

    I'm having the same problem as you do. What do you mean by "mounted with quota". You have configured quota in your system?
    I followed every step on the perfect server guide for debian lenny but i'm stuck with the problem of deferred mails.
    Can someone give me any advise?

    I'm running Debian Lenny and ISPConfig-3.0.2.1
    The error is:
    May 5 20:47:44 sipsda0005 postfix/pipe[29258]: 764354A81E0: to=<[email protected]>, relay=maildrop, delay=6262, delays=6262/0.08/0/0.06, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to change to home directory. )

    .mailfilter is receiving everything empty:
    .mailfilter(5): LOGNAME="[email protected]"
    .mailfilter(6): EXTENSION=""
    .mailfilter(7): RECIPIENT=""
    .mailfilter(8): USER=""
    .mailfilter(9): HOST=""
    .mailfilter(10): SENDER=""
     
    Last edited: May 5, 2010
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you followed the guide, then you have quota enabled. So that should be ok.

    Please ost the output of:

    ls -la /var/vmail/

    and the content of the postfix master.cf file.
     
  8. divendres

    divendres New Member

    ls -la /var/vmail
    master.cf:
     
  9. divendres

    divendres New Member

    I did not change any of postfix configuration files, it was all made automatically by ispconfig installation
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The domain directory in the vmail folder has the wrong owner. Please run:

    chown -R vmail:vmail /var/vmail

    to fix this.
     
  11. divendres

    divendres New Member

    The owner was set when i created the domain and the mailbox using the web control panel.
    I changed them as you say but i still have the same problem:

     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    grep vmail /etc/passwd

    and again the output of:

    ls -la /var/vmail
     
  13. divendres

    divendres New Member

    hosting:/var/vmail# grep vmail /etc/passwd
    vmail:x:5000:5000::/home/vmail:/bin/false

    ls -la /var/vmail
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Please change line for the vmail user in the /etc/passwd file to:

    Code:
    vmail:x:5000:5000::/var/vmail:/bin/sh
    I guess that there was a vmail user present in /etc/passwd before ispconfig was installed.
     
  15. divendres

    divendres New Member

    delivered via maildrop service

    Thanks a lot :D
     

Share This Page