maildir not used

Discussion in 'General' started by provell, Jun 16, 2008.

  1. provell

    provell New Member

    Hi Everyone,

    I have been studying the ispconfig/postfix setup lately, and in general postfix.

    Of the 2 ispconfig servers I have running, the mailserver part is giving me some trouble on one server.:(
    100% cpu usage(clamv), mailboxes that are full(when their not, so I just give the users an extra 100mb extra space).

    Anyway, after studying the difference between the two I found out
    that I did not setup the maildir option in "management -> settings -> mail".
    Thus the mail comes in /var/spool/mail/userxmailfile.
    After having a discussion in this thread:
    http://http://www.howtoforge.com/forums/showthread.php?t=24084
    I would like to use the maildir option, also it's better handling of mail as far as I know.
    ISPconfig wasn't setup that way for no reason.;)

    As I have been doing some testing.....
    When I set the "maildir" option in ISPconfig no mail get's deliverd to the excisting users.
    It does get diliverd nicely in the /example.com/user/userx/maildir, but when I try to receive the mail on my local computer I don't get anything.
    The mail just stay's in the "new" directory.

    My questions are:
    1. Should I leave it that way, I should have configured that earlyer?
    2. Should I reboot a deamon, or the whole server, and would it work than?
    3. If after a reboot it works(maildir) what happens to the mail in /var/spool/mail/userxmailfile?

    I don't want to be experimenting to much with this server so I thougt best to ask the professionals.

    Thaks in advance for your anwser.:)

    Rgds Edo
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. provell

    provell New Member

    maildir

    Hi Till,

    I found that thread already and was planning on doing that to get rid of the 100% cpu usage.

    Do you have any solution, concerning the maildir questions I asked?
    If I turn on the option, no one is getting any mail, but the mail stays in maildir directory of the user.

    Rgds Edo
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please reconfigure your system exactly as described in the perfect setup guide for your linux distributiona and enable the maildir checkbox.
     
  5. provell

    provell New Member

    got it

    Hi, thanks for the response again.

    I was already looking at the perfect setup I used of debian sarge.
    On page 4 at the bottom I think I forgot to do the following:
    apt-get install courier-imap courier-imap-ssl courier-pop courier-pop-ssl

    So postfix and ISPconfig default to mbox mail format....
    I gues it couldn't hurt to apt-get these packages and then use the maildir options?
    Am I right?

    Anyway thank for the help so far, got a lot of understanding now:):)

    Rgds Edo
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That's right.
     
  7. provell

    provell New Member

    That's right

    Wow, I'm glad I looked again if there was an update on the(this) post I did.
    Those 2 words "That's right", you posted just saved me from sleepless nights, testing and researching and posible angry customers.

    Let me reply with two words -> THANK YOU!! :D:D:D:D

    Rgds Edo
     

Share This Page