Maildelivery: unknown user

Discussion in 'Installation/Configuration' started by wiseguy, Apr 26, 2010.

  1. wiseguy

    wiseguy New Member

    Hallo,

    I tested the Mailservice with a mail from gmx.de. But I got an error mesage:
    Code:
    This is the mail system at host meinedomain.de.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                      The mail system
    
    <[email protected]> (expanded from <[email protected]>): unknown user:
       "admin"
    Reporting-MTA: dns; meinedomain.de
    X-Postfix-Queue-ID: 2B07C68E0DC
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Mon, 26 Apr 2010 18:26:02 +0200 (CEST)
    
    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user: "admin"
    
    Von: Erler Benjamin <[email protected]>
    Datum: 26. April 2010 18:18:51 MESZ
    An: [email protected]
    Betreff: Testmail
    I have a mailbox "[email protected]" and an alias:
    Source mailadress: "[email protected]"
    Destination mailbox: "[email protected]"
     
    Last edited: Apr 26, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. wiseguy

    wiseguy New Member

    Okay I sent the mesage and I saw the error message in logfile:
    Code:
    warning: do not list domain meinedomain.de in BOTH mydestination and virtual_mailbox_domains
    But I have the entry
    Code:
    mydestination = meinedomain.de, localhost, localhost.localdomain
    in the main.cf and in the mysql-virtual_domains.cf is the following:
    Code:
    user = ispconfig
    password = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    dbname = dbispconfig
    table = mail_domain
    select_field = domain
    where_field = domain
    additional_conditions = and active = 'y' and server_id = 1
    hosts = 127.0.0.1
    
    In the table mail_domain in field domain is in one line the entry "meinedomain.de" of course, too.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not use a domain as mydomain, myhostname or mydestination in postfix that is used as virtual mail domain. Please change the line:

    mydestination = meinedomain.de, localhost, localhost.localdomain

    to

    mydestination = localhost, localhost.localdomain

    and make sure that meinedomain.de is not used as myhostname or mydomain. Then restart postfix.
     
    TLH, marquillo and Ahmad Hamada like this.
  5. wiseguy

    wiseguy New Member

    You are the Best!!!
    Thanks that was it. Now that works ;-)
     
  6. Ahmad Hamada

    Ahmad Hamada New Member

    Many Thanks to you :)
     
  7. marquillo

    marquillo New Member

    Thank you, it works
     
  8. TLH

    TLH New Member

    I had a similar problem and your answer helped me as well. Thank you Till!
     
  9. Olhutch

    Olhutch New Member

    Yeah just had the same problem thanks Till.:)
     
  10. Mujtaba

    Mujtaba New Member

    Thanks for your post, my main domain in ISPCONFIG 3 is giving me this error and rest of the domains were working, i tried various option but this one worked very well.
    if i summarise again because the command was not here
    In putty window, type
    nano /etc/postfix/main.cf
    search for line
    mydestination = yourdomain.com, localhost, localhost.localdomain
    remove yourdomain.com and make this line look like this
    mydestination = localhost, localhost.localdomain
    save it Ctrl X and yes
    then restart, or reboot and then the problem is resolved
    ((((Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user)))))
     
    till likes this.

Share This Page